Maya Harden edge nothing happens??? NEED HELP

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 03 March 2013   #1
Maya Harden edge nothing happens??? NEED HELP

Hi. I'm desperate for help. I have some models made in maya for a computergame, which I want to take to mudbox for diffuse/displacement/bump painting/extraction. When I transfered the model to Mudbox and added subdivision levels i realized that all my edges are soft, which is a no go when not wanting to add extra polygons to the models. I then went back to Maya and tried to harden the edges i want to be hard but nothing seems to happen. I have turned on soft/hard edges in display to be able to view the hard edges on my model. and can just see that all edges are soft even though I try to harden them (all dotted edges=soft). Tried to Google my problem, and found a few suggestions but no cure yet.

So can please anybody PLEASE help me. I have a deadline next week for the models and really need to get cracking!

I've added two screenshots. One non smoothed and one smoothed with display>soft/hard edges visible.

The model is a simple pillar.

I would really appreciate ANY help! Thanks
 
Old 03 March 2013   #2
I constantly have to open the Normals section with Maya.
Do this in the Polygons/Normals tab.
Unlock Normals
Conform
Set to Face
...Then "Set Normal Angle".. and set it to 65 or 95ish.
Maya has a lot of problems with normals.
After you do that, you can select edges and make them harder etc..
 
Old 03 March 2013   #3
Hi. Thanks for your reply. Did exactly as you said. still no change...???
 
Old 03 March 2013   #4
Wait, the edges becomes solid lines now, meaning the they should be hard. I set the angle to 90. is that right? and should i export in .obj or .fxb format to Mudbox?
 
Old 03 March 2013   #5
I have tried to import into mudbox with both fbx and obj. Adding subdivision with preserve hard edges. still no change...
 
Old 03 March 2013   #6
Perhaps what you are looking for is edge creasing?
 
Old 03 March 2013   #7
I tried creasing too, with no luck. set the creasing to 3, imported in mudbox, still no change and smoothing all around when I subdivide. Horribly frustrating. What am I doing wrong. Should it be so hard figuring out hard edges. Must be something game artist use all the time when making displacement maps and so forth???

This i what i'm looking for. so I know its possible.

http://www.youtube.com/watch?v=IzW1g6psuXk
http://www.youtube.com/watch?v=q9YYgAl0FMc
 
Old 03 March 2013   #8
I am not familiar with mudbox but occasionally I run into an issue where my soft/hard edge tool just does not want to make the seam.

I conform and set to face then export only the mesh as an .OBJ restart Maya and import it back in a new scene so I can define my edges. I figured that some where the normal angles got messed up.

I don't know if conforming or setting to face does any thing but usually it is in the process along the way with delete history of things I try first before exporting.

If you've found another answer I'd love to know.
 
Old 03 March 2013   #9
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:14 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.