CGTalk > Software > Autodesk Miscellaneous > Autodesk MotionBuilder
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 01-12-2013, 01:29 PM   #1
Kanga
KillaRoo
 
Kanga's Avatar
portfolio
Chris Kautz
Freelancer/Character artist.
Netherlands
 
Join Date: Feb 2004
Posts: 9,566
Send a message via ICQ to Kanga Send a message via MSN to Kanga
Loading saved pose files.

Motionbuilder 2012
Cant seem to load saved pose files. Saving the poses out as an fbx and the loading them shows they are loading but the dont appear anywhere in the application, not in the pose controls and not in the pose folder. Also dragging the file directly into the pose folder doesnt work.

Any help appreciated.
Cheers
__________________
The terminal velocity of individual particles is directly related to pink rabbits on a bank holiday.
Characters, Games, Toys
 
Old 01-13-2013, 01:11 PM   #2
ErikSvensson
Señor Animator
 
ErikSvensson's Avatar
portfolio
Erik Svensson
Senior Animator
Guerrilla Games
Amsterdam, Netherlands
 
Join Date: Feb 2003
Posts: 685
Send a message via MSN to ErikSvensson
That's strange. And you haven't disabled importing of poses in the FBX dialogue? Save as FBX, set pose exporting to true and the same for import should add them to the pose library. I've done that at work in MB 2012 x64 so I know it's not a motionbuilder bug.
__________________
Vimeo
 
Old 01-13-2013, 06:25 PM   #3
Kanga
KillaRoo
 
Kanga's Avatar
portfolio
Chris Kautz
Freelancer/Character artist.
Netherlands
 
Join Date: Feb 2004
Posts: 9,566
Send a message via ICQ to Kanga Send a message via MSN to Kanga
Yup it isnt a bug because I get this in MB 2012 and 2013. Importing the fbx everything is enabled. Importing with Take001 or not makes no difference. The poses load because I can see the bar moving, they just never appear anywhere in the UI. Its something simple and stupid, but it is annoying me!
Thanks for your help.
Cheers
__________________
The terminal velocity of individual particles is directly related to pink rabbits on a bank holiday.
Characters, Games, Toys
 
Old 01-14-2013, 11:08 PM   #4
ErikSvensson
Señor Animator
 
ErikSvensson's Avatar
portfolio
Erik Svensson
Senior Animator
Guerrilla Games
Amsterdam, Netherlands
 
Join Date: Feb 2003
Posts: 685
Send a message via MSN to ErikSvensson
Would it be possible for me to look at the scene and see if something is wrong? (if it's not something secret..) I will try it out here at home and see if it works. Could you try just make some poses with the characters that came with mobu, export poses and import to a new scene with the same character? I wonder if it is something in your character setup.
__________________
Vimeo
 
Old 01-14-2013, 11:14 PM   #5
ErikSvensson
Señor Animator
 
ErikSvensson's Avatar
portfolio
Erik Svensson
Senior Animator
Guerrilla Games
Amsterdam, Netherlands
 
Join Date: Feb 2003
Posts: 685
Send a message via MSN to ErikSvensson
Do you do merge or motion file import? Merge or append as import settings? I noticed it does not work with motion file import but both merge and append worked on the aragor rig in MB 2013 x64.
__________________
Vimeo
 
Old 01-15-2013, 07:24 AM   #6
Kanga
KillaRoo
 
Kanga's Avatar
portfolio
Chris Kautz
Freelancer/Character artist.
Netherlands
 
Join Date: Feb 2004
Posts: 9,566
Send a message via ICQ to Kanga Send a message via MSN to Kanga
Hi Erik

I have been trying to merge the fbx file. I couldnt find append unless that is just a term they use for merging, no buttons or menu items in the UI or manual. Opening the pose file wants me to clear out the scene and save it so that is not really handy.

Your idea of using Mia was super, I am having exactly the same problems with that character. My character is just max bones characterized and with a control rig so there is nothing unusual about the rig MB is doing all the FK and IK work

Really weird when I try to load the poses via merge the pose directory icon flashes as if it wants to display the files but fails. Maybe it is something to do with my NVIDIA display. According to google I am still the only person in the world with this problem so I am sure I am missing something.

Thanks for your offer to check out my file that is very kind of you. I assure you though it is a very unspectacular rig!


The steps I go through

Select which parts of the rig I want to pose and add a pose at the default/rest position.
Rename the pose.
Select and move the bones/effectors into the pose and create and rename.
Test the pose, works every time.
Select the poses and choose Save Selection from the file menu.
Save as FBX with everything checked except lights and cameras, saving with or without take001 makes no difference.
Delete the poses in the pose controls window.
From the asset browser or from the file menu, dragging the file into the scene and merging like I have seen on tutorials fails, dragging into the pose control window or over the folder in the pose controls or the pose folder in the navigator all fail.

Saving the poses with the rig parts selected only merges those parts of the rig into the scene not the poses.

Thanks for all your help so far, maybe you can see the obvious thing I missed.

Cheerio
__________________
The terminal velocity of individual particles is directly related to pink rabbits on a bank holiday.
Characters, Games, Toys
 
Old 01-15-2013, 09:34 AM   #7
ErikSvensson
Señor Animator
 
ErikSvensson's Avatar
portfolio
Erik Svensson
Senior Animator
Guerrilla Games
Amsterdam, Netherlands
 
Join Date: Feb 2003
Posts: 685
Send a message via MSN to ErikSvensson
I'll have a go at it tonight as well and see if I can get it not to save. I'll keep you posted.
__________________
Vimeo
 
Old 01-15-2013, 03:54 PM   #8
Kanga
KillaRoo
 
Kanga's Avatar
portfolio
Chris Kautz
Freelancer/Character artist.
Netherlands
 
Join Date: Feb 2004
Posts: 9,566
Send a message via ICQ to Kanga Send a message via MSN to Kanga
Thanks Erik.

Just so I understand correctly you can save the pose files independent from the model right? I can save them with a model but not without. If you cant see anything wrong with my process then it has to be a video setup thing on my computer.

Cheers
__________________
The terminal velocity of individual particles is directly related to pink rabbits on a bank holiday.
Characters, Games, Toys
 
Old 01-17-2013, 10:17 PM   #9
ErikSvensson
Señor Animator
 
ErikSvensson's Avatar
portfolio
Erik Svensson
Senior Animator
Guerrilla Games
Amsterdam, Netherlands
 
Join Date: Feb 2003
Posts: 685
Send a message via MSN to ErikSvensson
Quote:
Originally Posted by Kanga
Select the poses and choose Save Selection from the file menu.


After reading this again (sorry got dragged into lots of overtime at work..) this is your problem. Do not use save selection, use save as -> then only choose poses, nothing else. That will most likely fix it! As far as I know you can't save selection from anything in the UI, only things in the viewport.
__________________
Vimeo
 
Old 01-18-2013, 12:02 AM   #10
Kanga
KillaRoo
 
Kanga's Avatar
portfolio
Chris Kautz
Freelancer/Character artist.
Netherlands
 
Join Date: Feb 2004
Posts: 9,566
Send a message via ICQ to Kanga Send a message via MSN to Kanga
Quote:
Originally Posted by ErikSvensson
After reading this again (sorry got dragged into lots of overtime at work..) this is your problem. Do not use save selection, use save as -> then only choose poses, nothing else. That will most likely fix it! As far as I know you can't save selection from anything in the UI, only things in the viewport.

AHA! That was it. Works like a charm. Made some test poses, saved them out like you said, deleted, reloaded and presto!

Thanks a million Erik
Cheerio
__________________
The terminal velocity of individual particles is directly related to pink rabbits on a bank holiday.
Characters, Games, Toys
 
Old 01-18-2013, 04:50 PM   #11
ErikSvensson
Señor Animator
 
ErikSvensson's Avatar
portfolio
Erik Svensson
Senior Animator
Guerrilla Games
Amsterdam, Netherlands
 
Join Date: Feb 2003
Posts: 685
Send a message via MSN to ErikSvensson
Glad it worked!
__________________
Vimeo
 
Old 01-18-2013, 04:50 PM   #12
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:15 PM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.