CGTalk > Software > Autodesk Maya > Maya Character Setup
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 11-08-2012, 07:18 PM   #1
hellspawned
Know-it-All
Tomas Landberg
Huddinge, Sweden
 
Join Date: Sep 2004
Posts: 430
Wrap deformer and blend shapes together?

I've got a character with a face mask in a stretchy material. The face underneath is complete with blend shapes. At first, I thought it would work fine to use a wrap deformer to attach the mask to the face to allow for it to follow the face movements of the character, but it seem like it doesn't work, at least not straight up.

When I flip through my blend shapes, the mask flies all over the face, but definitely doesn't follow the blend shapes as I would've expected it to - I thought it bound the meshes on a vertex to closest vertex basis, but that doesn't seem to be the case. It may be worth to mention that the topology of the mask and the face aren't the same, as that would make the mask deform oddly, and have an unnecessarily dense topology. Also worth mentioning is that when I move the head and neck around using the joint controllers, it doesn't behave like this, so my conclusion is that it's a problem between the wrap deformer and the blend shapes node.

So, does anyone have an idea on why this is, and how to get these two features to work together?
 
Old 11-10-2012, 06:50 AM   #2
djx
Where's my pony?
 
djx's Avatar
David Johnson
vfx & creature td
Melbourne, Australia
 
Join Date: Jun 2003
Posts: 3,464
Wraps and blendshapes work ok. The only thing I can think of that might be creating problems is:
The mask surface is too far away from the face surface when you wrap it. This could exaggerate the movement due to the "rotation" of the surface normals, especially if the face is more dense than the mask, and even worse if you use exclusive bind.

Maybe you could post some before and after wireframes so we can see the result of the problem.

David
__________________
http://www.djx.com.au
 
Old 11-12-2012, 12:50 AM   #3
hellspawned
Know-it-All
Tomas Landberg
Huddinge, Sweden
 
Join Date: Sep 2004
Posts: 430
It sorted itself out, somehow. I'm not sure how it happened, but now it works as it should
 
Old 11-12-2012, 12:50 AM   #4
CGTalk Moderation
Expert
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,478
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:51 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.