fixing animated uv's WITHOUT deleting history

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #16
Originally Posted by NolanSW: I think this tip might help your issue. Pretty simple and cleaver.
http://www.youtube.com/watch?featur...d&v=uzN_5ugDxa8



yup that's what I suggested back in post #5
__________________
blah blah blah
 
Old 02 February 2013   #17
I cannont agree more with Gmask, we use this BULLETPROOF technique extensively, as we very often start facial shapes/rigging before texturing starts.
If you have time, I'd strongly suggest you make a script that allows to make it instant, and nobrainer, and updating uvs on a deformed mesh will become a routine task.
Idea is simple, let's say you want to transfer uvs from meshSRC(good uvs) to meshDST(bad uvs, eventually with any deformer down the stream)
You need to inspect if "meshDSTshape.inMesh" attribute receives an incoming connection, and if yes, parse all it's siblings intermediate shapes, and polyTransfer uvs only on those whose inMesh is free. For the cost of time polyTransfer execution, you can proceed without searching if any of those intermediate objects are really usefull or not. But of course you could make the check for the really usefull ones.

Bonus is that with this approach, you can even update base shape of your model (with a vertex transfer), if any retake happened after you started modeling, provided the topology didn't change.
Extra bonus is that you can make your script smart enough to figure the kind of shape it's
processing, because the same principles apply to nurbsSurface/Curves...

You can even reuse some code to make a script that cleans useless intermediate shapes under a transform, as they can cause you scene size to grow fast...

Nicolas
 
Old 03 March 2013   #18
You could make a copy of your mesh, fix the uvs there and set the original mesh as blendshape target, then template the original mesh.
 
Old 03 March 2013   #19
been some time..

Originally Posted by zaskar: You could make a copy of your mesh, fix the uvs there and set the original mesh as blendshape target, then template the original mesh.

doing this - is no different then using the deformer, and yup - it'll work.
the other posts in this thread have tried to find a way to not have that extra model and extra deformer, although there were nice suggestions and smart ones - in my rig, still the only one that works is still the deformer (unfortunately), because there is a wide chain of complicated stuff, having all blend-shapes, deformers, clusters and even curves&geomatry effecting the rig - no other solution has worked.
P.S. I have tried ALL the suggestions, and I appreciate a lot the time you all put into this..
 
Old 03 March 2013   #20
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:51 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.