How do stop maya automatically hiding child objects when hiding their parents?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 01 January 2013   #16
when you say you have a nurbscurve parented under the joint, do you mean you've just parented it, or shape parented it? If you've shape parented then the joint visually becomes that nurbsCurve anyway. I'm assuming you've done this so you have a nurbsCurve to select the joint as a controller right?
__________________
Founder & CEO : Red9Consultancy
Red9 StudioPack : Red9 StudioPack GitHub
Author: Autodesk Masterclass 2011 - 'Live Animation Binding'
 
Old 01 January 2013   #17
@ gmask
They're just the standard nurbs circles and boxes.

@Mark-J ... I just parented it.

@animatedfox .... The reason why I can't use the joint masking on the status bar is because I need other joints visible and selectable and animatable.

I've been doing test animation.... all seems well.

Thanks for all your input, Fellas!

Sometimes I think "God bless CGTalk."
 
Old 01 January 2013   #18
well if you're running the nurbs as an easy select / reference for it as a controller then shape parent the nurbs, this way the joints visually are nurbs AND you can still pickwalk their hierarchy via the nurbs
__________________
Founder & CEO : Red9Consultancy
Red9 StudioPack : Red9 StudioPack GitHub
Author: Autodesk Masterclass 2011 - 'Live Animation Binding'
 
Old 01 January 2013   #19
I finally got around to doing a few test with this.. sadly it appears that you cannot override the display visibility of the parents visibility status which sucks.. but at least with joints you can set the draw style to none and it does not effect the joints below it
__________________
blah blah blah
 
Old 01 January 2013   #20
@gmask: Like I said joint display set to "none" they are still selectable! You just can't see them in the viewport. Do a marquee select and check it out. The answer is set the joint drawing override to bounding box.
 
Old 01 January 2013   #21
Quote:
Originally Posted by egglybagelface
@gmask: Like I said joint display set to "none" they are still selectable! You just can't see them in the viewport. Do a marquee select and check it out. The answer is set the joint drawing override to bounding box.


Ah.. crud.. you're right but it does appear that setting the override to bounding box does achieve the desired results.
__________________
blah blah blah
 
Old 01 January 2013   #22
Yes I agree! not giving you option to not hide the chidren of a parent when toggling visibility to off is a real bummer, I don't understand the concept of the doing this.
Everybody have been struggling with this for 13 update of maya, too bad autodesk doesn't use it's own product they'll see that it's counter intuitive sometime .

As a workaround you can effectivelly hide the shape of the object..not joint though but they've told you a workaround for that.
You can also put the shape of an object in a display layer in that case it will hide just the shape also and not worry about hiding the children.
 
Old 01 January 2013   #23
Quote:
Originally Posted by thematt
Everybody have been struggling with this for 13 update of maya, too bad autodesk doesn't use it's own product they'll see that it's counter intuitive sometime .


I guess.. I don't really recall ever having much of an issue with this myself. In Maya there are many other things I wish that could be fixed or improved that I'd ask for besides this.
__________________
blah blah blah
 
Old 01 January 2013   #24
We just put the shapes in display layers and that gives us a pretty solid show hide setup. Though I can't remember if we have setups with things parented to joints...not sure if they don't work with this setup.
 
Old 01 January 2013   #25
Quote:
Originally Posted by animatedfox
We just put the shapes in display layers and that gives us a pretty solid show hide setup. Though I can't remember if we have setups with things parented to joints...not sure if they don't work with this setup.


right well it's never been an issue for me because the animators are only selecting curves using a selection filter and they only display the joints for a visual reference and not for selection.

I suppose another route is to enable the selection handles for joints and then not display joints in the viewport?
__________________
blah blah blah
 
Old 01 January 2013   #26
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:49 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.