Normal Map Produces Ugly Seams

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 11 November 2012   #1
Normal Map Produces Ugly Seams

Hey guys I'm new to the forums so I apologize if I am posting this in the wrong place.

I'm trying to bake a normal map for one of my low poly models. I have tried baking the normal map in zbrush, mudbox, xnormal, and 3ds max 2013 and every time I bake the normal map I end up with these very obvious and ugly seams. As a matter of fact I get this every time I have ever baked a normal map in the past with other models and I just don't know why this is happening. Here are some pictures of what's going on.






Here is the normal map itself


Here are the max and normal map files for those who want to test it out for themselves.
http://www.sendspace.com/file/ahzq4g
http://www.sendspace.com/file/agzgll

At first I though that there was some problem with 3ds max but I tried to render the model in max 2013, max 2012, Marmoset tool bag, and UDK and I get the same results.

I tried flipping the green channel in photoshop, I tried different uv map setups, I tried hardening the normals at the seams before baking, ect. Please if anyone knows how to fix this then let me know because i'm all out of ideas :(.
 
Old 11 November 2012   #2
In case you did not solved the problem here it is what you have to do: when you import the normal map file, instead of using system gamma (which in your scene I saw it was 2.2) choose override with the value of 1.0. That is all. Hope it works for you!
 
Old 11 November 2012   #3
I just tried that but still nothing. I think that there must be something wrong with my shader settings. Or it could be a 3ds max 2013 bug. I heard others had some normal map issues for 2013.
 
Old 11 November 2012   #4
try checking Flip green in the noramal map. I tried your scene and it worked for me.
Attached Images
File Type: jpg NoramalMap_01.jpg (73.1 KB, 71 views)
File Type: jpg NoramalMap_02.jpg (75.5 KB, 67 views)
 
Old 11 November 2012   #5
OMG that did it . Thank you so much, you have no idea for how long I had this issue. I always flipped the green channel in Photoshop and even in zbrush along with xnormal when I rendered the map but I never thought of just flipping it in 3ds max. Although now I don't understand why flipping the green channel in max worked but flipping it outside of max before importing the map didn't work. Is there something special that 3ds max does as opposed to photoshop?
 
Old 11 November 2012   #6
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:07 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.