Rolling a ball

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 09 September 2012   #1
Rolling a ball

Hello there,

So I've come upon a big challenge for me in 3D animation... Rolling around a ball.

Creating a rig that - without the use of dynamics - allows me to freely move around a ball and have it rotate accurately according to it's traveled distance.

Using the setup in this thread , you get good results in the X axis, it breaks down in the Z axis and Zeus help you if you want to move the sphere diagonally in both axes at the same time. It just doesn't work right.

Using the same principle, you can use the length of a spline to calculate the rotation and put the sphere aligned to the spline. It will follow the spline and seem like it's aligning correctly. But for all the flexibility this gives you, you might as well try to control a sphere with dynamics or witchcraft.

There is a plugin called Roll-it on eggtion.net, which appears to be perfect and fit all the criteria. But it's not working in R12+

Does anybody have any idea how this could be done? Have a control you can grab and drag around in X,Z and the sphere rolls around perfectly. I'm guessing that by rolling around a sphere in a circle for example and get the proper alignment you need to be able to call upon the previous frames' values of rotation or a vector or something (I'm not good at math).

This guys seems to have done this for Max a long time ago: http://www.cuneytozdas.com/tutorials/maxscript/

Last edited by ChrisCorr : 09 September 2012 at 07:21 PM.
 
Old 09 September 2012   #2
Howdy,

They also have the Roll-it Xpresso setup (created before it was a plugin) that still works in R12.

Adios,
Cactus Dan
__________________
It doesn't matter what people say about you, just as long as they're talking about you.

cactus3d.com, cactus3d-Plugins, CD Character Plugins forum
 
Old 09 September 2012   #3
Yeah I definitely read about it, but I can't find it anywhere.
 
Old 09 September 2012   #4
Originally Posted by Cactus Dan: Howdy,

They also have the Roll-it Xpresso setup (created before it was a plugin) that still works in R12.

Adios,
Cactus Dan


Hey Cactus ... Just tried to open the sample file in the v1 2007 folder ...
and it seems to be missing parts ??? Can you advise what version you have?


TIA
__________________
David

iMac 3.06 ghz Intel Core 2 Duo / 16 GB / OS 10.9.5 / C4D StudioR12 / CS6

R.I.P. 11.02.11 ... my dear friend .
 
Old 09 September 2012   #5
Howdy,

Hmmmm, looks like they changed their site around. I don't see a link to the file with the old original Xpresso setup anymore.

It was there earlier this year in March when I downloaded it and used it for this rig:
http://www.cactus3d.com/HandTruckRig.mov

Maybe contact them and see if they still have it available.

Adios,
Cactus Dan
__________________
It doesn't matter what people say about you, just as long as they're talking about you.

cactus3d.com, cactus3d-Plugins, CD Character Plugins forum
 
Old 09 September 2012   #6
This one?

- link -



Peace,
Rich_Art.
__________________
Retired Cinema4D Guru


 
Old 09 September 2012   #7
Originally Posted by Rich-Art: This one?

- link -



Peace,
Rich_Art.


That's the site I have too.
Downloading will get you a "zip.pdf" file ... delete the ".pdf" portion and it'll
change over to a regular zip file. From there you can install but not working
for me :(
__________________
David

iMac 3.06 ghz Intel Core 2 Duo / 16 GB / OS 10.9.5 / C4D StudioR12 / CS6

R.I.P. 11.02.11 ... my dear friend .
 
Old 09 September 2012   #8
Strange,

Works without any problems here. See image..

Peace,
Rich_Art.
Attached Images
File Type: jpg Untitled-1.jpg (92.7 KB, 24 views)
__________________
Retired Cinema4D Guru


 
Old 09 September 2012   #9
Originally Posted by Rich-Art: Strange,

Works without any problems here. See image..

Peace,
Rich_Art.


Hmmm, doing a bit of research shows that many report the plugin
not working in 64 bit ... as my console shows.

Changing my info specs to open in 32 bit still had missing plugin data.

Am I missing any content in the Folder as shown ?

TIA

I've been using Nitro's magic roll but would like to solve the "why"
Roll-It doesn't work with my Mac system.
__________________
David

iMac 3.06 ghz Intel Core 2 Duo / 16 GB / OS 10.9.5 / C4D StudioR12 / CS6

R.I.P. 11.02.11 ... my dear friend .
 
Old 09 September 2012   #10
Originally Posted by Rich-Art: Strange,

Works without any problems here. See image..

Peace,
Rich_Art.


I don't see how, it doesn't work in my R13 neither with the 32bit exe nor with the 64bit executable. And I can't find the 0.9 version anywhere at all.

Is there a way for someone with the working plugin or the xpresso setup to transcribe the code/nodes here? Plugin is completely free so perhaps it's okay.

Last edited by ChrisCorr : 09 September 2012 at 05:01 PM.
 
Old 09 September 2012   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:27 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.