Nitrous Viewport Shadows Question

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 09 September 2012   #1
Nitrous Viewport Shadows Question

I'm just now getting around to firing up max 2013. Is it possible to get better nitrous viewport shadows (less jaggy) when using the default lights? I use the default lights to model with normally. See first image below.

If I add a light (in the second image below, a photometric), the best shadow I've been able to get is as you see there. It has a pretty sad little grungy edge to it.

I'm using a 9800 GTX with nitrous.

The "lighting and shadows quality" slider doesn't change much from 1.0 default to 8 or even 16 times.

From the Help file, it seems like it should.

Can someone help explain this?


Thanks,
Mahlon
Attached Images
File Type: jpg Shadows.jpg (12.3 KB, 26 views)
File Type: jpg Shadows_photometric.jpg (21.1 KB, 26 views)

Last edited by Mahlon : 09 September 2012 at 09:19 PM.
 
Old 09 September 2012   #2
Edit to the above post: I've added two more pics: why does the Nitrous viewport (frist image) look worse than the Direct3d viewport (2nd image)? The aliasing is far worse in the Nitrouse. Shouldn't it be better? Could it be my graphics card?

Thanks,
M.
Attached Images
File Type: jpg Viewport_Nitrous.jpg (64.2 KB, 29 views)
File Type: jpg Viewport_Direct3d.jpg (63.4 KB, 30 views)
 
Old 09 September 2012   #3
looks like progressive refinement is off, try clicking the cube-like icon on the bar below the viewports. (or in the viewport's configuration menu)
__________________
The GPU revolution will not be rasterized! - http://www.jdbgraphics.nl
 
Old 09 September 2012   #4
there are a few additional tweaks for Nitrous shadows:

* in the ViewportConfiguration->VisualStyle&Appearance tab there is the "Lighting & Shadow Quality" slider. You can play arround with it. It has -besides the rightmost high quality position - a softshadow setting (2. position), which makes jagged shadows look better in some situation

* when you are on Max 2013, there is an additional hidden nitrous setting to deal with shadow map sizes. It's accessable via maxscript only

nitrousgraphicsmanager.ShadowmapSizeLimit


it defaults to 512, you can set it to a higher value to test wether it helps in your situation or not. (Depends on the Shadow type you have set on your lights)

Or - the more convenient way to tweak all this and a lot more regarding Viewport would be using my PowerPreview script. The next version - which will be released sometime in the next 2~3 weeks has an shadowmap resolution spinner added ( Max 2013 only) too..
http://www.scriptspot.com/3ds-max/s...itrous-previews
__________________

PowerPreview: High Quality Nitrous Previews for 3ds Max 2012|2013|2014

[ Free Download (ScriptSpot) ]

Home of The Frogs | Online Portfolio
 
Old 09 September 2012   #5
Thanks Jonathan and Space,

Jonathan, I didn't have progressive enabled and that makes a difference. On a better graphics card, would I see a more instantaneous progression? On my 9800 gtx, it's pretty slow.

Space, I'm going to give your script a try. Looks awesome from the website.

If I were to try and change the shadow size via the
nitrousgraphicsmanager.ShadowmapSizeLimit script, how would I do that? I'm woefully ignorant about stuff like this. When I put that text in the Listener and evalutate it, nothing happens.
Thanks again for the help.
Mahlon
 
Old 09 September 2012   #6
this should tell you at least tell you the current setting, which should be 512
nitrousgraphicsmanager.ShadowmapSizeLimit


and if you want to change it, you simply do it by assigning a new value

nitrousgraphicsmanager.ShadowmapSizeLimit=1024


But honestly, i'm not even sure if that helps with the default light sources, but it helps for the lights you place in the scene and which use shadow mapped lights.

I just have seen your GFX card spec, 9800GTX and to be honest:
you will not become lucky with it when using nitrous. AFAIK the 9800GTX has maximal 512MB of gfx card memory, which is the lowest limit for Nitrous to even work. i would consider spending a couple of hundred bucks for a new GFX card with at least 2GB on board mem ( nvdia 670 or 660Ti ), if i were in your situtation...
__________________

PowerPreview: High Quality Nitrous Previews for 3ds Max 2012|2013|2014

[ Free Download (ScriptSpot) ]

Home of The Frogs | Online Portfolio

Last edited by spacefrog : 09 September 2012 at 07:02 PM.
 
Old 09 September 2012   #7
Thanks very much. I think it is, indeed, time for a new graphics card. I've been putting it off.

Mahlon
 
Old 09 September 2012   #8
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:02 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.