Scaling issue from Imperial and Metric

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 12 December 2012   #1
Scaling issue from Imperial and Metric

Please see the attached file.

The file is saved in Imperial Units, and needs to be opened in a Max environment that is currently set to Metric, so that when you open the file, you will get the question popup: "Fie Load: Units Mismatch" and you can choose between "Rescale the File Objects to the System Unit Scale" (which at the moment is set to Metric) or "Adopt the File's Unit Scale"

There, you find two meshes of value:
* "Weird box" : this is the mesh that is behaving weird
* Reference Box : this is the reference mesh, showing the size the "weird mesh" should have had if the scaling was properly.

If you were in Imperial units (or in Metric units, and choose Adopt the File's Unit Scale), no Units-Mismatch-Popup would come and you would see a scene of two meshes with similar size.

If you were in Metric units, and pick Rescale the File Objects to the System Unit Scale.
What happens now is that the "Weird box" is been scaled up. If you check the scale value, you find 254. That is correct, the difference between Imperial and Metric is that value, however, currently it should be 100. If you set the value manually to 100, you will see that the boxes now matches.


This is some sort of a bug that I dont understand. I currently run Max2013 and have tried to create new scenes, in Imperial, and open up in Metric. The bug doesnt exist in my version of Max. I think this is Max 2009 related.

What I need is to understand what's happening. I have a couple of similar scenes and it's a complicated process to go through each mesh, make sure that nothing failed through the units conversion and so on.
Attached Files
File Type: zip _Test.zip (52.6 KB, 5 views)
__________________
/Haider
www.haider.se
 
Old 12 December 2012   #2
I decided to bump this thread, so that hopefully someone who understands this finds the thread and can help me out.
__________________
/Haider
www.haider.se
 
Old 03 March 2013   #3
No answers so far.

However, I managed to find a walk around which I want to share. With that said, I still don't know what's causing the problem or whether its a bug or not.

Info:
Standard units: Metric (cm)
Conversion: from Imperial > Metric

* Open max file in its original units (imperial), in other words, pick "Adopt the File’s Unit Scale"
* Select all the objects that can have scale units; geometries, helpers, shapes
* HIERARCHY > Reset: Scale
* Save to a new file
* Reset 3dsMax > Pick "Adopt the File’s Unit Scale "- I am assuming that you have a Maxstart.max file with the startup settings, like Metric units etc.
* Open the last saved file (with the reset scale) and pick "Rescale the File Objects to the System Unit Scale". You will notice that the scaling went all wrong
* Select all the items that were scaled wrong (geometries etc)
* Set transform pivot setting to "Use Pivot Point Centre"
* Right click the Scale tool, and set 100 to X, Y and Z

Hope someone find use of this information

What I would like to see is some sort of script that does a scene cleanup (so I wont forget to reset a scaling for anything that has another scaling than 100) and upon Rescale, that everything that has 254 (because of that bug) is scaled back to 100
Or even better; an explanation to why this happens
__________________
/Haider
www.haider.se
 
Old 03 March 2013   #4
Normally the way I'd deal with this is to open the scene that's in metric (providing that's what you want) and import the object that's in inches. choose "Rescale the File Objects to the System Unit Scale". That will as you say add a scale of 254. Then go to the utilities tab and find Reset Xform. This will transfer the scale to an xform modifier. Collapse. Scale gone, object now 100%.

That will not work if the object is skinned and/or rigged though.

Reset scale in the hierarchy tab is a bit different. I'm not really sure what it does, but it doesn't cleanly make the model at 100% scale. PEN or someone might be able to point out the difference.
 
Old 03 March 2013   #5
Originally Posted by robinb: Normally the way I'd deal with this is to open the scene that's in metric (providing that's what you want) and import the object that's in inches. choose "Rescale the File Objects to the System Unit Scale". That will as you say add a scale of 254. Then go to the utilities tab and find Reset Xform. This will transfer the scale to an xform modifier. Collapse. Scale gone, object now 100%.

That will not work if the object is skinned and/or rigged though.

Reset scale in the hierarchy tab is a bit different. I'm not really sure what it does, but it doesn't cleanly make the model at 100% scale. PEN or someone might be able to point out the difference.


This would work if the original scene was in 100%. If its a dirty scene (the samle provided is rather clean actually), where the meshes haven been Reset XForm, it would end up give you something that is not 254. If it had scaling 1041-something, it would give you 2646-something.
At the end, I still must clean up the original scene before rescaling and then scaling back to 100 from 254.

Reason why I used the Reset scale in the hierarchy tab is that I can reset the scale only and not the rotation in those cases I need to keep the rotation.
There might be some other solution, maybe PENs script for these kind of things has a clean Reset Xform solution, but at the end, we still have to clean up the original file which seems not necessary on newer scenes.

I cant help being a curious person and wonder what is wrong with that particular mesh where reset Xform doesn't help. If you open up the scene I attached in the beginning of this thread, you will see that the "weird box" won't convert properly even if it had got a potion of Reset XForm, while the other box, "Reference box", will convert properly.

Can there be other things that one can apply to a mesh? Another cleaning process?
__________________
/Haider
www.haider.se
 
Old 03 March 2013   #6
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:09 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.