Area light Highlights Problem .

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #1
Question Area light Highlights Problem .

Hi ,

- I Create an area light ,
- Set it's area light type to "User" and 1 sample
- Use the mib_amb_occlusion shader as the light shader of the light

It works as expected , but im getting specular highlights from the area light. Is there any way to turn this off in Maya?

Thanks.
 
Old 02 February 2013   #2
Remove check mark for "emit specular" in the light's attribute.
 
Old 02 February 2013   #3
Originally Posted by Panupat: Remove check mark for "emit specular" in the light's attribute.


I Use the mib_amb_occlusion shader as the light shader of the light and "emit specular" does not work .
 
Old 02 February 2013   #4
In your mia_material_x shaders for the scene, in the Advanced section, set the "Specular Balance" to 0. This will turn off legacy Blinn/Phong type specularity, and you'll only see reflections in your shaders. This is the physically accurate way to do reflections in mental ray; specularity isn't an actual attribute, but a legacy workaround to give point, directional, and spot lights some fake "area". Using area lights nullifies the need for this workaround, as they already have reflectable area.
__________________
Commodore 64 @ 1MHz
64KB RAM
1541 Floppy Drive


"Like stone we battle the wind... Beat down and strangle the rains..."
 
Old 02 February 2013   #5
Originally Posted by InfernalDarkness: In your mia_material_x shaders for the scene, in the Advanced section, set the "Specular Balance" to 0. This will turn off legacy Blinn/Phong type specularity, and you'll only see reflections in your shaders. This is the physically accurate way to do reflections in mental ray; specularity isn't an actual attribute, but a legacy workaround to give point, directional, and spot lights some fake "area". Using area lights nullifies the need for this workaround, as they already have reflectable area.


Thank you "InfernalDarkness" . very appreciate .

But I need specular highlights from other light sources . and I dont want to remove specular highlight from all materials in my scene . I need specular highlights because I work for production .

I want to remove specular highlight only from area light .
 
Old 02 February 2013   #6
Why the heck I don't see "user" type to chosse in maya 2013. It has "custom" instead.
Anyway, if u using mia materials, them go to your area light, change the type to "rectangle"
, mark visible and set the type to "user" or "custom" again.
In the mia material, if No highlights for visible area lights is checked, them the specular won't show. But that only works if u are using mia materials.
Other materials like phong or misss will still show the specular from this ambient light.

I guess when you put the ambient occlusin as a light shader, the ambient occlusion shader controls the light, and give this specular always on for the materials, so you have no control of that.
 
Old 02 February 2013   #7
Thanks Bilgames .Your guide was very useful .

Last edited by zelda64 : 02 February 2013 at 01:29 AM.
 
Old 02 February 2013   #8
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:08 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.