CGTalk > Software > Autodesk Maya > Maya Character Setup
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 03-11-2013, 03:51 AM   #1
FloydBishop
Expert
 
FloydBishop's Avatar
portfolio
Floyd Bishop
Microsoft
Seattle, USA
 
Join Date: Apr 2002
Posts: 3,514
Control rig channels disappearing

I thought I would make a post about this, as it's not a very obvious thing. I've seen many people have controls on a display layer. If the display layer is turned to reference ("R" in the display layer next to the name of the layer), your channels will "disappear" from the channel box. It's confusing, because they don't disappear until you deselect a control you have active. I've seen many people (myself included the first time it happened) stumble around, trying to get the channels to show up again. I've even heard of people reinstalling Maya, which still doesn't "fix" the problem.

Hopefully this thread is easily found in a search, if someone is pulling their hair out.
__________________
=============
Floyd Bishop

YouTube Channel
Char Maya Character Rig
 
Old 03-11-2013, 01:19 PM   #2
djx
Where's my pony?
 
djx's Avatar
David Johnson
vfx & creature td
Melbourne, Australia
 
Join Date: Jun 2003
Posts: 3,419
Its not very obvious to me how to even reproduce this behaviour. I have controls on a display layer. I've set that layer to reference mode. Now I cant select my controls in the viewport (as expected). I can still select them in the outliner, and when I do their channels still show up in the channel box. The only way I can make them disappear is to use one of the attribute filters.

Is what you describe something that always happens for you, or just on rare occasions?

David
__________________
http://www.djx.com.au
 
Old 03-12-2013, 06:32 PM   #3
FloydBishop
Expert
 
FloydBishop's Avatar
portfolio
Floyd Bishop
Microsoft
Seattle, USA
 
Join Date: Apr 2002
Posts: 3,514
This recently came up during a demo I was doing at a school running Maya 2013.
__________________
=============
Floyd Bishop

YouTube Channel
Char Maya Character Rig
 
Old 03-14-2013, 09:04 PM   #4
smillz999
New Member
portfolio
Bob Saget
aurora, USA
 
Join Date: Jan 2011
Posts: 11
That's funny because that literally just happened to me the other day. For some reason on my rig the shape node was getting selected instead of the transform node. No idea why though. For the life of me I couldn't replicate the problem, but it always happens with the control curves in my rig. I guess technically since it's display layer is on reference it shouldn't be selectable anyway, but it just gets confusing when you can still select the shape node (in my case it was in the layer by accident, so imagine the reaction I had when all my beautiful controls were gone ). Again, no idea why or how this happens, but if it does happen to you Floyd is spot on

Edit: found exact cause. If the nurbs curve has a drawing override to change the color, it does what Floyd was talking about. This always happens with a previously combined nurbs curve and most of the time with a normal nurbs curve. Sometimes it locks the drawing override settings on a normal nurbs curve.

Last edited by smillz999 : 03-14-2013 at 09:39 PM.
 
Old 03-14-2013, 09:04 PM   #5
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,480
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:02 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.