skinned jumped off skeleton

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #1
Question skinned jumped off skeleton

I was wondering if anyone has come across the issue of the skin rotating off the skeleton. I had just worked on the skin weights and had almost finished them, closed out the file and came back to it later. When I had come back to it the mesh had rotated about 100 degrees in the Y off the skeleton. The funny thing is that the weights are still there and working just fine. Just wondering if anyone knows what would have caused this, so I can avoid having this happen again. Here's a screen shot.
Attached Images
File Type: jpg skin.jpg (49.5 KB, 7 views)
 
Old 02 February 2013   #2
did you freeze transforms on your geometry and remove all possible constraints or connections before skinning?

You should be able to save the skin weights then re-apply after checking on your geo.
 
Old 02 February 2013   #3
yes did a freeze transform and deleted history.
 
Old 02 February 2013   #4
Hi,
Save the file as .ma ASCII format. open in wordpad and check for "-lockNode". Delete the line.
Save the wordpad and open in maya see if the problem is solved.
Rgds,
__________________
Prem
Download Vehicle Rig
Blog
 
Old 02 February 2013   #5
Gave that a shot but it didn't find any "-locknode" in the file. I'm using Maya 2012 hotfix 4 and the weights are set to post. I've never had this happen before when doing skin weights and would like to avoid it happening again. Any other ideas?
 
Old 02 February 2013   #6
check if your mesh transform, or any of it's parent groups, is moved/rotated in any weird way.
__________________
Victor
ngskintools.com - skinning plugin for Autodesk Maya
 
Old 02 February 2013   #7
Everything is clean. I just found the fix to it about 20 minutes ago. I opened a new scene and imported it in and it was fine back over the top of the skeleton. Saved it out and it was still where it needed to be. I still have absolutely no idea what caused it and would love to find out to avoid it but at least it's fixed. If anyone has any other idea's would love to here them and thanks for all the help.
 
Old 02 February 2013   #8
Usually when you get a mesh that is double rotating or rotating off of the object it's due in part to a heirarchy issue. If the Mesh is linked to or parented underneath the node that is transforming it will inherit the transforms of that object along with the transforms of the bones. The quick fix if you absolutely have to have the geometry setup that way is to turn off the inherit transforms. otherwise simply relink the geo outside of the node heirarchy.

when you re-imported the geo back into the scene what more than likely happened was you took it out of the heirarchy where it was and placed it into the scene outside of the rig heirarchy "fixing" the issue.
__________________
There is no one right way to do anything.
Only the un-explored ways. =)
 
Old 03 March 2013   #9
I've had that issue before. I was double rotating or transforming when I grabbed a controller. The mesh was on the skeleton and I worked on the weights. Would do test poses to check and move things around and everything looked fine. Saved the file and when reopening the file it wasn't posed or anything cause it was still in the bind pose. It was just up off the skeleton which I had never seen before. The weights still worked. The mesh deformed properly and moved appropriately. I also had the mesh outside of the hierarchy to keep that from happening and hadn't gotten around to grouping the rig and mesh into a group for cleanness.

Thanks for the idea though.
 
Old 03 March 2013   #10
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:06 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.