enjoyMentalRayStringOptions, a UI to easely use MR string options

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 09 September 2011   #61
Has anybody got this UI to work with OS X? Maybe I am doing the install incorrectly, but it doesn't seem to work for me.

Very interested to check this out!
 
Old 09 September 2011   #62
Originally Posted by jcsaline: Has anybody got this UI to work with OS X? Maybe I am doing the install incorrectly, but it doesn't seem to work for me.

Very interested to check this out!

Hi!

Have you any error message un the script editor? Don't hesitate to paste it (with the "line in error" in the script editor).
__________________
My blog (fr)
 
Old 09 September 2011   #63
Found a thread at mentalimage forums that people has the same issue. It seems that Maya 2012 with progressive rendering and using IPR does not work. :(
 
Old 09 September 2011   #64
Autodesk doesn't implement the correct API for Progressive so changes in 2012 lead to crashes with IPR and Progressive.
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 09 September 2011   #65
Thanks for the information!
__________________
My blog (fr)
 
Old 09 September 2011   #66
Originally Posted by JayHoo: I have seen his post with the mel codes but nothing is rendered when I disable "Export StateShader".


I've had that happen too. It's finicky. But once it starts working, it usually stays working. Here's a thread with more info on it:
http://forums.cgsociety.org/showthr...?f=87&t=1006075

It can matter if you rendered once before changing the settings. Sometimes it helps, other times it hurts. Sometimes merely restarting Maya and trying again fixes it. It's odd.
I have a stock iRay scene posted in that thread that should work as a basis for you, just import your scene into it and things should hopefully render, with interactive IPR.
 
Old 09 September 2011   #67
You should be able to leave the state shader on. It might spit crap out but it will work.
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 09 September 2011   #68
Originally Posted by Bitter: You should be able to leave the state shader on. It might spit crap out but it will work.


That junk data it spits out seems to break interactive IPR rendering with iRay. The IPR will start, but if you try moving/changing anything or closing the window while it's still rendering it will crash. If it's unchecked, everything works fine & dandy.
 
Old 10 October 2011   #69
Hey guys,

i just can't get the script to work properly in maya 2012.

When i execute the two lines

import enjoyMentalRayStringOptions
enjoyMentalRayStringOptions.Ui().create()


i laways get this error message

# Error: ImportError: No module named enjoyMentalRayStringOptions

Am is missing something?
I put the py file in the right folder

C:\Users\myname\Documents\maya\scripts

But i just can't start the script.


Any help is greatly appreciated.

BTW It's unbeliveable that the IPR + Progressiver Rendering Mode always crashs
Maya 2012. I used this feature almost anytime....
__________________
--
I'm drinking to drown my problems,

but these goddamn bastards can swim!!!
 
Old 10 October 2011   #70
Originally Posted by naik: Hey guys,

i just can't get the script to work properly in maya 2012.

When i execute the two lines

import enjoyMentalRayStringOptions
enjoyMentalRayStringOptions.Ui().create()


i laways get this error message

# Error: ImportError: No module named enjoyMentalRayStringOptions

Am is missing something?
I put the py file in the right folder

C:\Users\myname\Documents\maya\scripts

But i just can't start the script.


Any help is greatly appreciated.

BTW It's unbeliveable that the IPR + Progressiver Rendering Mode always crashs
Maya 2012. I used this feature almost anytime....


Wrong folder.
Put your script here : C:\Users\myname\Documents\maya\maya2012-x64\scripts

 
Old 10 October 2011   #71
Hi Damien,

thanks for dropping in.

I put the script EVERYWHERE.

In every script folder just to be sure that the folder is right.
It's still not working and i get this error message.

Do i have to load and execute the script first?
I did all i can imagine, but nothing worked.

To be honest, this is the first script which is not "working" for me.

cheers

naik
__________________
--
I'm drinking to drown my problems,

but these goddamn bastards can swim!!!
 
Old 10 October 2011   #72
Thanks Dorian!
__________________
maya@reddit r/maya
 
Old 10 October 2011   #73
Got it.

Copied it into C:\Program Files\Autodesk\Maya2012\2012-x64\prefs\scripts

Really strange, never copied a script into that folder.

cheers

naik
__________________
--
I'm drinking to drown my problems,

but these goddamn bastards can swim!!!
 
Old 10 October 2011   #74
Guys, is there any way to "correct" the corrupt progressive rendering mode in maya 2012?
I just can't believe it that i can not use it anymore until they send out a new fix.
__________________
--
I'm drinking to drown my problems,

but these goddamn bastards can swim!!!
 
Old 10 October 2011   #75
Originally Posted by naik: Guys, is there any way to "correct" the corrupt progressive rendering mode in maya 2012?
I just can't believe it that i can not use it anymore until they send out a new fix.

Maybe this can help?
http://forums.cgsociety.org/showpos...90&postcount=55
__________________
My blog (fr)
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:03 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.