Linear workflow, Vray, and Maya

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  04 April 2011
I made a LWFMe button for V-Ray Tuner to make the proper switches for LWF:

https://www.creativecrash.com/maya/...-tuner-for-maya

It also warns that you have to turn on sRGB in the VFB but it's done by the script for hte Maya render view. Obviously you should understand these things before just looking for a one click thing but I find it handy for new scenes. The optimize button also sets core and bucket size for your machine:

global proc lwfMe()
{
setAttr vraySettings.cmap_linearworkflow 1;
setAttr vraySettings.cmap_adaptationOnly 1;
setAttr vraySettings.giOn 1;
setAttr vraySettings.cmap_gamma 2.2;
setAttr vraySettings.sRGBOn 1;
//Dave's personal settings 
setAttr "vraySettings.cmap_affectBackground" 0;
//
warning "The Maya Render view is now corrected for Linear Workflow. Enable sRGB in the VFB to see it properly there too.";
}

Last edited by cgbeige : 04 April 2011 at 04:29 PM.
 
  04 April 2011
Thanks for the reply.

I have the settings set to what should be a linear workflow but I feel I might be doing something wrong.

If someone could take a look at the colour mapping settings I have and tell me what I am screwing up it would be greatly appreciated.



I have tried the renders with the convert image to sRGB for render view off and on and I get the same results as evidenced by the darker render of the car on the bottom. And above it is the same renders with the sRGB button in the render view pressed.


The bottom render is way too dark, I can not make out details at all and when I turn up the brightness of the lights i just get blown out highlights and no further detail comes through in the darker areas.


EDIT:::


Well I think I figured it out. I tend not to use the sRGB button in the vray frame buffer and having dont affect colours checked kinda forces you to have sRGB on in the VFB.....its always the simplest things that cause the biggest headaches!

I don't want to do any post work so I guess leaving dont affect colours checked off would give me the desired outcome right out of the VFB without any fiddling after the fact.

Would my assumption be correct?

Last edited by kpamir : 04 April 2011 at 07:06 PM.
 
  04 April 2011
Turn on Linear Workflow and enable sRGB in the VFB. You will probably need to tweak your lighting after since you weren't rendering with this rendering intent before. Also, if you're using a sun/sky system, exposure is usually controlled via the physical camera attribute added to the camera.

I only enable subpixel mapping only if i notice artifacts around lights like black aliased halos.
 
  04 April 2011
So I should check the linear workflow box or no?

My original intent was to render linearly but clearly I was screwing something up. I have the textures gamma corrected, and what not, so wouldn't enabling sRGB in addition to checking the linear workflow button in the Vray colour mapping just screw everything up?

As of right now I have the following settings.

affect background
don't affect colours are both checked on under colour mapping

gamma is @ 2.2
dark and bright multi are at 1
affect swatches is checked on

And in Vray common
convert image to sRGB is checked on as well

and the sRGB button is also turned on inside the VFB.

I get the same result if I have the dont affect colours checked off and the VFB sRGB button off as well. I assume this way the linear workflow is baked into the image?

I want to clarify and understand this as best as I can.
 
  04 April 2011
Since you are managing LWF yourself, you should leave the "linear workflow" button unchecked. This is the recommended way of working.

You should also leave sRGB checked in the VFB, and render to exr. You can then convert to any colorspace (eg sRGB) in post.

David
__________________
http://www.djx.com.au
 
  04 April 2011
sorry - I missed that you were managing textures individually so leave the LWF unchecked
 
  05 May 2011
Originally Posted by djx:
You should have a menu in the attribute editor like this one. (this snapshot is from 1.5 sp1)

David









Man! When I go in the texture > attribute editor > vray > NO AVAILABLE ITEMS

Thereīs no the option "BITMAP INPUT GAMMA"


Do you know how I can solve that?? I really need this.

Thanks in advance =)
 
  05 May 2011
Your version of vray is too old.
If you are using the 1.5 demo, you need to update to the 2.0 demo.
If you own vray1.5 you should be able to download the latest nightly build. Email support and ask for the download link.

David
__________________
http://www.djx.com.au
 
  05 May 2011
Originally Posted by djx: Your version of vray is too old.
If you are using the 1.5 demo, you need to update to the 2.0 demo.
If you own vray1.5 you should be able to download the latest nightly build. Email support and ask for the download link.

David






I see. But if I get the latest version, itīs demo so I guess when I render my scene there will be a watermark of chaosgroup in the render, wonīt it be?
 
  05 May 2011
If you have a 1.5 license you can just email support and they will give you a link and password for the latest 1.5sp1 nightly build. If you want version 2, then you need to pay for the upgrade.

David
__________________
http://www.djx.com.au
 
  05 May 2011
Originally Posted by djx: If you have a 1.5 license you can just email support and they will give you a link and password for the latest 1.5sp1 nightly build. If you want version 2, then you need to pay for the upgrade.

David


Thank you man, I will try. But what could I do if I donīt manage to do that? =)

Last edited by luisrosenstock : 06 June 2011 at 05:47 PM.
 
  05 May 2011
In that case, you can do LWF the old way, which is to insert gamma correct nodes. Its not so hard, especially if you do it at the same time as you create the fileTexture.

David
__________________
http://www.djx.com.au
 
  05 May 2011
Originally Posted by djx: In that case, you can do LWF the old way, which is to insert gamma correct nodes. Its not so hard, especially if you do it at the same time as you create the fileTexture.

David




I will check this out! Thank you buddy =)
 
  05 May 2011
David

I am running into problems with my Vray Frame Buffer. I wanna render my scene by using this feature so that I can render the elements to make a post work in photoshop. But my scene is getting darker when I render with that. When I disable it, my scene gets pretty cool but doesnīt render the elementes separately. I think VFB is not recognizing some lights of my scene or something like that. Do you know what is happening?
 
  05 May 2011
turn on the sRGB button at the bottom of the VFB. Also, make sure you're rendering to a 32-bit format like EXR if you plan on opening linear files in Photoshop since converting 8-bit or 16-bit images from linear in PS will be lossy
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright Đ2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:12 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.