Maya 2009, Seams problem with displacement, How mentalraySubdivApprox smooth uvs?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  07 July 2010
Maya 2009, Seams problem with displacement, How mentalraySubdivApprox smooth uvs?

Hi,


My issue is : In maya 2009, If mentalraySubdivApprox nodes smooth the mesh before rendering, What options does it use to smooth Uvs?

Cause I’m trying to render a displacement in maya 2009.

But i have a seams problem at the border of uvs’s shells.

To try to solve it, I test my displace with a clean scene, on a plane, with a non modified lambert assigned, my map of displace is a “.MAP “, the “feature displacement” of the shape receiving the displace is turn OFF, and i set up “memory limit” to : 1000 Mb ( to be sure there will be no memory problem ).
Seams are always visibles.

I used a script that Scott Spencer wrote to force maya 2009 to not to export CCmesh at render time, but to use same technique of maya 8.5.

It worked , but it low down a lot the quality of the displace. When i try to increase quality the seams begins to reappers…

Maybe, the problem come from I paint my map of displace on the exported low object, with uvs not smoothed. And MentalraySubdivApprox might smooth the Uvs at render time, as it smooth the mesh...But i don’t Know what options it use for this.

I anyone ,have any idea.... Or if anyone know that my problem is due to smothing else… Or if it’s a problem solved in maya 2010,or maya 2011.....Pleeease!Tell me!

Thanks a lot for paying attention!
 
  07 July 2010
I was wrong when i said before : " I paint my map of displace on the exported low object, with uvs not smoothed".
In fact I'm used to texture objects in their smoothed version. And I realize I did my displace map this way.

So I try to paint seams on the low object with uvs not smoothed, and rerender it and now the seams work really better!

Is that means that mentalray does not smooth Uvs when its smooths the mesh before rendering a displace???
 
  07 July 2010
I had this problem and it turned out the be a Texture filtering problem . I turned it off in the File texture Node and the seams were gone . Hope that helps .
 
  08 August 2010
Yah , I tried to turn the filter of my the displace map to OFF .
But when i do the batch render, it start but seem to block at 0 % of rendering, not crashing just doing nothing.
It 's rather strange cause I had no other Ram issue with this scene...but I will test this with another scene....

thanks for advice
bonne journee!
 
  08 August 2010
Are you using Final Gather? Final Gather "pre-render" is not shown in the percentage. You can still display more informations about your batch render by changing the verbosity level (options of the Batch render - Verbosity level - Progress or Detailed message).

Bonne journee
 
  08 August 2010
Are you using Final Gather? Final Gather "pre-render" is not shown in the percentage. You can still display more informations about your batch render by changing the verbosity level (options of the Batch render - Verbosity level - Progress or Detailed message).

Bonne journee

I 'm not using Final Gather neither final gather "pre-render". I render with "verbosity level" set to "Progress message"....

I'm not good at understanding very well technical maya language... But I had problem like : " MEM : scene cahe flushed asynchronously..."

...I does not understand either a lot of thing about computer hardware...but i heard there is in window 32 bits a way to increase the ram it can use ( writing something in the " boot.ini " file...)...

I try it without reading everything ,cause i had no time ... But i think it worked, cause now i can render with the filter of the displace map "OFF" with no errors!!!


Thanks! ( and thanks Progress mesage!! )
 
  08 August 2010
oups i copied the previous message in my post!!! :0 sorry!
 
  08 August 2010
I don't think the MEM message was causing any problem, I assume it's just a warning.

You can allow more memory for programs, that's true. For example, if you have 4 GB of memory, windows always keep 1GB for itself, just in case. In the boot.ini you can change it. But be aware that, if your software usually crashes when it reach the memory limit (by default 3GB), windows could also crash when it reaches its limit (by default 1GB). If you reduce too much windows memory limit, it will make your OS unstable. I tried it and reverted it pretty fast

But glad you managed to render.
 
  08 August 2010
Have you looked into this
http://www.pixelcg.com/blog/?p=386
 
  08 August 2010
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:39 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.