Transparent object´s shadow problem using mental ray lighting

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  03 March 2013
Transparent object´s shadow problem using mental ray lighting

Hey guys, i was working on a scene on maya 2013 that uses mental ray shadows and the transparency of an object looks weird, as if it were not transparent at all. Take a look:

upload pic
The right page is actually the same color than the left one, but it looks like that because there is a transparent page right over it, proyecting it´s shadow.
I tryed using a .png but i saw on another forum that png files are just not good for mental ray. I tryed using a mental ray material but it looked with even less transparency. I did tilted the "Alpha is luminance" tag on color balance. I also drop the shadow attenuation to 0, but still nothing. Last, i used a tiff file for the opacity but still didn´t get the result i wanted. By the way, every object has an ambient occlusion material assigned to it´s ambient color, but i tryed not using it and still looked like in the picture.
Any ideas or something i did wrong or anything?
 
  03 March 2013
Try plug the alpha to cutout opacity slot and make sure to use ray trace shadows.
 
  03 March 2013
I'm not entirely sure here, but I once had a similar issue. PNGs may be an issue because (IIRC) when you load a png as a texture (especially one with transparent parts in it), sometimes Maya automatically makes a connection to the transparency channel of the material, which would naturally override the transparency settings you're trying to give the material.

Does the material you're using for the transparent page have specularity or reflectivity? If so, turn them all the way to 0. Some things in mental ray try to be energy conserving, so if there is anything that causes light to deflect/scatter/be absorbed, shadows can be cast.
 
  03 March 2013
cutout opacity? where is that? i looked in hypershade for that value but couldn´t find it.
The material is a lambert, it has no specularity nor reflectivity. Although when i tryed with the mental ray material i did turn off those values (took them to 0)
 
  03 March 2013
When using mental ray avoid classic maya materials. You should use mia_material_x_passes mostly. Cutout opacity is in its advanced section.
__________________
 
  03 March 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:32 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.