Maya Discarding Material assignments

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  02 February 2013
Maya Discarding Material assignments

Hi there, I have a big problem with my Maya, whenever I save m scene and exit Maya, then start Maya up again and want to start working, I find that Maya has discarded the assigned shaders to the geometry. All geometry in the scene is referenced in from the main folder, and I find that I can't select groups and assign any materials to selection, I get the error, 'error wile parsing arguments'

I'm using Maya 2013 and Mental Ray. I find that Maya does it only to my AO shader and masking shader. For the AO, I have a surface shader, with an amb mib texture node plugged in to the out color and for my masking shader, I have an 'use background' shader with everything turned down except shadow mask on 1.

Any ideas or suggestions?

Thanks
Neal
 
  02 February 2013
ditch the surface shader

If the surface shader comes as a layer override in any layer, there are very high chances of this break happening
 
  02 February 2013
Did you assign any shaders to specific faces instead of entire objects? or maybe you performed a boolean, extract, separate or combine operation which will automatically assign shaders per face? This will often break your render layer shader assignment. It's an old, terrible bug in maya.

Delete all render layers, make sure all shaders are assigned per object, and then redo your render layers.
__________________
"No, the movement is good, it just has to travel faster from spot A to spot B in the same amount of time."
 
  02 February 2013
ive have had this issue a lot how do i properly prep layers so they doent break or is that how maya is. can be a paint to fix on a dead line
 
  02 February 2013
I have the shader assigned to the geometry objects, I haven't assigned any layer overrides or any per face assigning. I also have no idea on how to do a boolean extract. I read up on the error and found that this happens due to name clashes when using the render layer system and passes, so I've fixed all that, but my problem now, is that the misss fast x shader passes node, won't render in the render passes, except in the master beauty pass, I'm using diffuse material color, direct irradiance no shadow and raw shadow for my passes and then the AO pass. I went into another instance of Maya and tried again, and found the same result. What shader should I use for skin then, if the one that works ideal for skin, won't render in the passes?
 
  02 February 2013
Ok, so I tried creating a setup for a RGB pass, so that I can just use it in compositing stages, but I'm still running into the wireframe issue and the discarding of shaders, what I've also found, is that when I select the object in my outliner, I get the error, 'error while parsing arguments' for assigning a shader to an object, but when I select the object in my viewport and assign it, then the assigning works, until I exit and restart Maya....
 
  02 February 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:28 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.