CGTalk > Software > Autodesk Maya > Maya Rendering
Login register
Thread Closed share thread « Previous Thread | Next Thread »  
 
Thread Tools Search this Thread Display Modes
Old 01-31-2013, 04:53 AM   #1
mobkon
Frequenter
 
mobkon's Avatar
portfolio
J T
USA
 
Join Date: Oct 2010
Posts: 131
This render issue is driving me nuts!

I am pulling my hair out over this. Planar mapped the UVs in the correct axis...its showing up correct in my window and in my UV editor...yet the render is completely off. The render is the perspective view looking straight on from the front.

ARGH. Help!

 
Old 01-31-2013, 07:16 AM   #2
refract
Expert
 
refract's Avatar
portfolio
John John
Character modeling, Lighting, Compositing
Work
Los Angeles, United States
 
Join Date: Mar 2003
Posts: 712
Send a message via ICQ to refract Send a message via AIM to refract Send a message via MSN to refract Send a message via Yahoo to refract
Go to uv sets on top in the uv editor and see if you have any extra uv sets. Delete any extra's.
Do another uv planar map after and make sure you don't have the checkbox checked to make another uv set. (reset defaults when its open)
Option "c",.. export mesh and re import it, and re apply shader.
 
Old 01-31-2013, 04:19 PM   #3
mobkon
Frequenter
 
mobkon's Avatar
portfolio
J T
USA
 
Join Date: Oct 2010
Posts: 131
Quote:
Originally Posted by refract
Go to uv sets on top in the uv editor and see if you have any extra uv sets. Delete any extra's.
Do another uv planar map after and make sure you don't have the checkbox checked to make another uv set. (reset defaults when its open)
Option "c",.. export mesh and re import it, and re apply shader.


Thanks for the reply..but no, I don't have any extra UV sets, just the one.

Any other ideas?
 
Old 01-31-2013, 05:56 PM   #4
tswalk
Expert
 
tswalk's Avatar
portfolio
Troy Walker
USA
 
Join Date: Jan 2012
Posts: 717
looks to me like the UV layout is wrong (perhaps done by automatic layout)... i can see the vien borders touching along the top edge, and the dual pupil on top which tells me the texture is being repeated because the UVs are overlapping.

you can see the overlap if you toggle shaded UV display in the editor... perhaps try cutting the UV in the middle and separating the sides.
__________________
-- LinkedIn Profile --
-- Blog --
-- Portfolio --
 
Old 01-31-2013, 10:14 PM   #5
mobkon
Frequenter
 
mobkon's Avatar
portfolio
J T
USA
 
Join Date: Oct 2010
Posts: 131
Quote:
Originally Posted by tswalk
looks to me like the UV layout is wrong (perhaps done by automatic layout)... i can see the vien borders touching along the top edge, and the dual pupil on top which tells me the texture is being repeated because the UVs are overlapping.

you can see the overlap if you toggle shaded UV display in the editor... perhaps try cutting the UV in the middle and separating the sides.


It's actually planar mapped in the Z axis. The back of the eyeball even has the same projection due to the planar mapping.

I still can't figure this out.
 
Old 01-31-2013, 11:45 PM   #6
chafouin
Frequenter
 
chafouin's Avatar
portfolio
Fabien Christin
France
 
Join Date: Dec 2009
Posts: 239
Maybe you can show the shader network?
Could it be that your texture is using projection mapping?
 
Old 02-01-2013, 02:45 AM   #7
mobkon
Frequenter
 
mobkon's Avatar
portfolio
J T
USA
 
Join Date: Oct 2010
Posts: 131
Heres my shader network.

 
Old 02-01-2013, 03:16 AM   #8
Panupat
Expert
 
Panupat's Avatar
portfolio
Panupat Chong
Thailand
 
Join Date: Feb 2004
Posts: 1,942
Chafouin was spot on. You don't want to use neither projection nor 3D. Try delete those nodes including the file node and create a new one. What you want is to UV your eye. Then, while creating the file node, check on the left of your hypershade to make sure you choose 2D and not projection.
 
Old 02-01-2013, 03:37 AM   #9
mobkon
Frequenter
 
mobkon's Avatar
portfolio
J T
USA
 
Join Date: Oct 2010
Posts: 131
Quote:
Originally Posted by Panupat
Chafouin was spot on. You don't want to use neither projection nor 3D. Try delete those nodes including the file node and create a new one. What you want is to UV your eye. Then, while creating the file node, check on the left of your hypershade to make sure you choose 2D and not projection.


Hmm, this is what's odd and I know something is not right.

Here's my steps that leads to the above shader network I posted.

- Create Mia_material_X
- Assign it to my sphere
- Select sphere, then Create UVs > Planar Mapping in the Z axis
- Assign a 2D file to the Diffuse of the Mia_X

Doing all of that results in the above shader network. I even tried creating a new scene, and MAKING SURE I selected 2D File from the left column of the Hypershade. There is no 2D node created at all, only what you see in my shader network post.

Is something corrupted?
 
Old 02-01-2013, 04:34 AM   #10
Cyberone
SailingAtomSailingAtThem!
 
Cyberone's Avatar
portfolio
Simon Bull
Animal Logic
Sydney, Australia
 
Join Date: Dec 2004
Posts: 1,137

when you get to the part where you click on "file" in the hypershade selection thingy dont click on it. RIGHT CLICK it and do "create texture"
__________________
 
Old 02-01-2013, 09:57 AM   #11
chafouin
Frequenter
 
chafouin's Avatar
portfolio
Fabien Christin
France
 
Join Date: Dec 2009
Posts: 239
In the hypershade, in Create > 2d textures, make sur that the radial button at the bottom of the list is 2d normal, and not 2d projection. Then it will save the setting and always create your 2d textures without the projection node in your network, and it will use your UVs.

And when you occasionnally want to create projected texture, you can right-click on File on the left panel, and choose Create as projection, as Cyberone said.
 
Old 02-01-2013, 09:57 AM   #12
CGTalk Moderation
Lord of the posts
CGTalk Forum Leader
 
Join Date: Sep 2003
Posts: 1,066,481
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:36 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.