How to use PTex in Maya 2013

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 05 May 2012   #31
Originally Posted by nbreslow: Did anyone get this to you? If not I can make a test object/vdm for you. Would be great to get it working.

-NB


If you could make a test object, that would be great!
__________________
www.core-cg.com
MentalCore - Shading and rendering pipeline for Maya/Mentalray
 
Old 05 May 2012   #32
Here is a simple head with an ear on it's forehead made in and exported from Mudbox to test with:

HeadBaseTest.fbx

Here is a Maya 2013 scene setup with the head:

PtexVectorDispExample.ma

and here is the Ptex VDM file:

headTest.ptx


Hope these are helpful.
 
Old 05 May 2012   #33
Aha! Beat me to it. Look forward to seeing what you find out. Good luck,

-Nick
 
Old 05 May 2012   #34
Originally Posted by B15NYIT: Here is a simple head with an ear on it's forehead made in and exported from Mudbox to test with:

HeadBaseTest.fbx

Here is a Maya 2013 scene setup with the head:

PtexVectorDispExample.ma

and here is the Ptex VDM file:

headTest.ptx


Hope these are helpful.


Thanks, this is a tangent space map, correct?
__________________
www.core-cg.com
MentalCore - Shading and rendering pipeline for Maya/Mentalray
 
Old 05 May 2012   #35
Yes, the map was extracted in Mudbox as a tangent space VDM .ptx

Please let me know if you need anything else for your testing. In related news I have heard back from the Mental Images guys on why the VDMs crash the standard Maya displacement shader:

"Thanks a lot for the file! The crash happens because the maya shaders mess with state->type.

The good news however is that we could provide a workaround in the ptex shaders. We'll send more
information when the update is available for download."
 
Old 05 May 2012   #36
Originally Posted by B15NYIT: Yes, the map was extracted in Mudbox as a tangent space VDM .ptx

Please let me know if you need anything else for your testing. In related news I have heard back from the Mental Images guys on why the VDMs crash the standard Maya displacement shader:

"Thanks a lot for the file! The crash happens because the maya shaders mess with state->type.

The good news however is that we could provide a workaround in the ptex shaders. We'll send more
information when the update is available for download."


Ah well, no point me testing if that's the case, may as well wait for the fix from nvidia.
__________________
www.core-cg.com
MentalCore - Shading and rendering pipeline for Maya/Mentalray
 
Old 05 May 2012   #37
If you want to follow that thread from nVidia:

http://forum.mentalimages.com/showt...38881#post38881
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 05 May 2012   #38
Updated Ptex shaders: http://forum.mentalimages.com/showt...38936#post38936
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 11 November 2012   #39
Hello,

I'm having sort of a strange issue.

I went through all the steps in this tutorial, and it worked...for one object and one shader. Every other time I've tried to plug in the mib_ptex_lookup, I've gotten a permission denied message and the model renders black. I can still use that one working mib_ptex_lookup for other ptex files, so I know it's not the ptex file itself.

Does anyone have any ideas on why this is happening?
 
Old 01 January 2013   #40
bump....

I am curious about this too.

Also does anyone know if the updated ptex shader is included in the recent versions of Maya 2013? Or do you have to download it still?
 
Old 05 May 2013   #41
Total noob question ...

I have no idea how to install Ptex so I'm feeling rather dumb. Would someone mind telling me what to do once the file has been extracted? I was expecting some kind of exe file, but just have a folder and no idea what to do next.
Thanks much,
~CG
 
Old 05 May 2013   #42
Have you seen this?

http://area.autodesk.com/forum/auto...x-in-maya-2013/
__________________
Richard Culver
Protfolio Facebook WIP1 WIP2
 
Old 10 October 2013   #43
I don't have middle mouse button to connect the Ptex_Lookup to my material, and I was told to Connection Editor, but Im not sure what to connect, I already tried "NodeState" > "RGB", and nope, my render is a black material with some shine of the specular.

What should I connect?
Picture:
http://gyazo.com/91a9256e83b637794db4754e9388d951
 
Old 10 October 2013   #44
perhaps outValue ?

/risto
__________________
- Oh no, it's me -
 
Old 10 October 2013   #45
Originally Posted by ristopuukko: perhaps outValue ?

Doesn't even let me :(
http://gyazo.com/39a415f8ee245d8bac50466522c29fba

Risto can you set me up a Maya 2014 or 2013 file?, I just need someone to setup the connection of the mib_ptex_lookup to a material like mia_material_x, please
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:22 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.