MentalRay 3.9 - native UI integration

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 01 January 2012   #46
Dont worry, got it working, iRay doesn'y install with Maya 2012, so I had to copy the iRay files from my 3DS Max installation. Now iRay is working perfectly in Maya 2012, happy days!
 
Old 04 April 2012   #47
Finally got a tiny bit of time to play around with these settings but thought I'd say that and give the thread a little bump for those that have missed this.
 
Old 04 April 2012   #48
Small warning: using finalgather legacy 'on' with some new features may causes crashes

Turn it off. :-)
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 04 April 2012   #49
Noted

I'm just curious what is the difference between this interpretation and the other thread on these string options ?
http://forums.cgsociety.org/showthr...19&page=1&pp=15

Is there a major difference between either of them ?
 
Old 04 April 2012   #50
The other thread uses a reworked Maya UI instead of a separate scripted UI.

Either has advantages.
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 04 April 2012   #51
Quote:
Originally Posted by Bitter
The other thread uses a reworked Maya UI instead of a separate scripted UI.

Either has advantages.

Don't ya mean that the other way around? ;P
 
Old 04 April 2012   #52
Oh yeah. Derp.



Reverse that.
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 04 April 2012   #53
Cool, well I like this threads UI of it, so I'll stick with this for now, I just wanted to ensure I wasn't missing anything vital, it's just for testing at home.
 
Old 04 April 2012   #54
Really liked the UI and was wondering if it will work on Maya 2013 as well. Am currently downloading our new licenses and will give it a try once they're all set up properly...
 
Old 04 April 2012   #55
It worked fine for me on the Beta's. . .
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 04 April 2012   #56
This script works on maya 2013, but it gives an error every time. Something about changed strings.
__________________
http://markoshovljanski.com/
 
Old 04 April 2012   #57
Can anyone take a few moments to explain the 'Native IBL' section ?
I don't quite understand why the colours (for ex) look very different to just using 'Image Based Lighting' method (the typical way).

I know there are some pop up boxes that come up explaining a little bit about each option but I don't think I'm grasping what's happening.
From what I can tell it's acting much in the same way as Vray's 'dome light' but I'm unsure of the controls and starting points.

 
Old 04 April 2012   #58
Native IBL works like the user_ibl. Except that Native IBL rebakes the image before rendering, possibly losing some detail (might be better for glossy rays). It is a much smarter form of the Maya IBL 'emit light' since it is more modern and faster.

The reason it looks different is that you need to use a string option called "light relative scale", value 0.318, type scalar

New lighting techniques are more geared towards BSDF shading models. Right now the Native IBL and user_ibl will probably blow out existing materials to an extent. Use the above string option to correct for that.

Your main control is Quality. But if you've migrated to 2013, I would suggest using the user_ibl_env shader for simplicity reasons, it's direct samples. Native IBL has more options designed for adaptive feedback and progressive IPR that we don't (or can't from integration) use right now.
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Old 04 April 2012   #59
Many thanks again for info David

Quote:
Originally Posted by Bitter
The reason it looks different is that you need to use a string option called "light relative scale", value 0.318, type scalar


Do I need to add this string if I'm using the UI from this thread ?
 
Old 04 April 2012   #60
I haven't looked at this UI recently, originally it was not added. To be honest, it should be a default.

Look at your miDefaultOptions to see if it's there, if not, just add it.
__________________
My opinions are always my own...and maybe a friend's, but never my employer's.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:16 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.