ctrl_buffers

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  02 February 2005
thanks for that great tool - it is just what i was looking for ...

@elvis: i didnīt read all of your post (the "why does nobody..." thing was anoying me) but what might help you: material->buffer_store->SGroup ... thats what it must look like .. and the buffer write must be the output shader of the camera ...

donīt know anything else, just getting started
 
  02 February 2005
really cool

hey francesca

really cool but something is missing... write all the diffrent passes in one file (like exr) so maybe you have time to do something like that...
but big respekt for all the stuff

ghosh
 
  02 February 2005
I'd kind of like to second a little more help.

The shader's francesca makes are awsome, and really give users a chance to take MR to where it belongs, without having an in house programmer. That said, perhaps she should team up with Jozvax who could create somewhat better documentation, or somone else would help in explaining exact use, and perhaps some of the possibilities these tools provide.

Thanks again for supporting the community!
 
  02 February 2005
Hi!

Now i ran into problems as well: A fast test yesterday worked fine, with one exception, i used only one object and one "color"-shader.
now trying to work with a more complex scene today, i canīt get it to work.
I just have to objects, to different color-shaders for them. what I want is a buffer output into 1 color-pass, 1 ambient occlusion and a shadow pass.
But i donīt know what setup i need to get the 2 color shaders connected to the buffer_store without wasting one inbuffer-channel ...

Help and screenshots greatly appreciated!
Thanks,
Ulrich

****EDIT****
should have tested more intense first, then posted
sollution: use as many buffer_stores as you like or better: in every shading network one "buffer_store" node.

Last edited by ulei : 02 February 2005 at 03:06 PM.
 
  02 February 2005
Originally Posted by ulei: Hi!

Now i ran into problems as well: A fast test yesterday worked fine, with one exception, i used only one object and one "color"-shader.
now trying to work with a more complex scene today, i canīt get it to work.
I just have to objects, to different color-shaders for them. what I want is a buffer output into 1 color-pass, 1 ambient occlusion and a shadow pass.
But i donīt know what setup i need to get the 2 color shaders connected to the buffer_store without wasting one inbuffer-channel ...

Help and screenshots greatly appreciated!
Thanks,
Ulrich


Sounds like a job for the TripleSwitch. Check your docs on that.

AndY
 
  02 February 2005
@ulei.. Oh i've not read your full reply to thread (this ****EDIT**** anoyng me too) so i think you may read my post first, then start tweak your scene..

Thanks alot
__________________
So you get NOTHING! You LOSE! Good DAY sir!
ピザやマンドリン
 
  02 February 2005
sorry - it just sounded like "i get something for free and start complaining because itīs not perfect"
 
  02 February 2005
yes maya crashes alot, but this is v1.1.. I'm shure that francescaluce is working on the shader, as usual the time will pay us with a producion quality shader. (both hands cross fingered)
__________________
So you get NOTHING! You LOSE! Good DAY sir!
ピザやマンドリン
 
  02 February 2005
Originally Posted by Elvis75k: Very sad story because i have no more the original shader assignment..

I suppose you're about to laugh.. but i'm waiting for a help!!

Is this procedure correct? Do i have to assign multiple buffer_store per mesh?


You are correct (as far as I know). If you have more than one shader assigned to different parts of the same mesh, you need to apply a different buffer_store to each part. The only reason this is a problem for you is because you're using a scene that's already been created, before the ctrl_buffer shader was invented.

Normally you would plan to use the ctrl_buffer shader right from the start of you scene, so it wouldn't matter. To help manage your knife scene you could create Quick Select Sets of the different areas that need a different shader, that way you won't need to reselect the parts manually if you need to change shaders.

For other people out there who may not know, if you want to 'convert' a normal shading network (like a phong with textures in a few slots) you don't need to totally start again using seperate shaders for each frame buffer. You can branch your textures (say one for specular) off into a totally separate Surface Shader and then connect that Surface Shader into the buffer_store. Which means your original shader is unchanged, it just connects out to 'satellite?' Surface Shader nodes.

I think I better make some images and a scene! Hehe.

__________________
~ Jared Martin

Maya, 3Delight, mentalray, Maxwell Render, ZBrush
Photoshop, Fusion, Vegas Pro, Syntheyes
 
  02 February 2005
Haha, now I'm confusing my own self working on example scenes. Some things I've noticed:

* It seems to crash if you try doing more than one object at a time.

* If you're using a bumped shader as a frame buffer, you need to turn on 'Export with Shading Engine' on the Shading Group node of the buffer_store otherwise the bump renders crazily (at least with 2D bump). I got the idea from the Misss_simple shaders, you have to do it with them too.

* The object you're frame buffering seems to render with no anti-aliasing against other objects, so perhaps hide everything else (at least from primary visibilty).

__________________
~ Jared Martin

Maya, 3Delight, mentalray, Maxwell Render, ZBrush
Photoshop, Fusion, Vegas Pro, Syntheyes
 
  02 February 2005
Jozvex

Maybe you can help me with a simple setup. I don't know what I'm missing,but I can't get this simple scene to render out the buffer passes


Sample Scene
Bufers.mb

Thanks

Dan
 
  02 February 2005
Daniel Whitton, open the attribute editor for the buffer_write shader and change this "\" to this "/", at the filepath tab. Then it will render just fine
__________________


Bucket Watcher
 
  02 February 2005
@ Jozvex ::. You're a voice from the heaven. Your reply was very helpfull, very clear indeed.
I've run in many crashes too.. About the aliasing, i don't know.. I suggest to change the filtering option in the buffer_write node. For the bumb i didn't try, but the export for the shading engine sometime is exactely the medicine for crazy renders.

@ David ::. I'll test your scene as soon i can.. Thanks for posting.

-elvis
__________________
So you get NOTHING! You LOSE! Good DAY sir!
ピザやマンドリン
 
  02 February 2005
Hey all;

Iīm overhelmed of these things, I really want to try that but I canīt download the files, explorer says the .zip is CORRUPT ARGH!

Help me please!

Iīll try to download it at home just to make sure though.
__________________
3D Animator and TD at www.vortice3d.com

"Donīt trust on affemeral things, only love will last..."

Visit my BLOG: 3djoie.blogspot.com
 
  02 February 2005
anti-aliasing is not working here too
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright Đ2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:44 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.