ctrl_buffers

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  02 February 2005
...must...give...you...hug....once....its...done..
__________________
Colin Strause
http://www.hydraulx.com/
 
  02 February 2005
it is a pleasure to work with this shaders.
I consider this way better than using passes and override mechanisms.
unilimited buffers.. super !!

/n
 
  02 February 2005
That's great !!
Btw, it's crazy but I'd say that I went even and met fransceca in my dreams yesterday.. and she doesnt look like a girl with a cat on her chest.
__________________
Lazhar Rekik
 
  02 February 2005
Well done man, It's just perfect.

I just have a bit of wonder :

Is there a way to render a scene and seperate the shadows ?

What i mean is I want to have my color pass alone and my shadow pass alone, I went through and honestly couldn't make it, It always gives me the shadow in color pass as well as the shadow pass.

I would be so thankfull to have an example scene like that .

Once again great stuff man.
 
  02 February 2005
Arrow

Originally Posted by neutronic: unilimited buffers.. super !!
Especially since mr 3.4 do not keep extra buffers in RAM (unless you ask it to), making renders of huge dimensions w. huge buffer count not limited by RAM size.

Spiffy, innit

/Z
__________________
Mr Zap Andersson - Random Rendering Guy at Autodesk Inc.
old mr blog: mentalraytips.com | Stuff: www.Master-Zap.com | Follow me on TWITTER
 
  02 February 2005
Originally Posted by amir jahanlou: Well done man, It's just perfect.

I just have a bit of wonder :

Is there a way to render a scene and seperate the shadows ?

What i mean is I want to have my color pass alone and my shadow pass alone, I went through and honestly couldn't make it, It always gives me the shadow in color pass as well as the shadow pass.

I would be so thankfull to have an example scene like that .

Once again great stuff man.


First of all my compliments on this shader, too. Just great and even greater that you work so fast on the feedback, too.

I too wish for a shadow shader similar to the one available in XSI. If I remember correctly it's an illumination shader that plug's into the surface port of the material. It shouldn't be that hard doing, but who will?

UPDATE:

I just digged into the XSI shaders a bit, and i managed to write an .mi file to load the shader in maya from the sibase.dll. As this is my first time doing such a thing i might still need some help with the light list AEtemplate. I'll share it with all of you to use the sib_shadow_material.mi ;-)

AndY

Last edited by a23 : 02 February 2005 at 03:37 PM.
 
  02 February 2005
Im getting a diffrence in the way the images are sampled.Anybody else getting this:( Great shader, thanx for sharing
 
  02 February 2005
senza parole...
__________________
So you get NOTHING! You LOSE! Good DAY sir!
ピザやマンドリン
 
  02 February 2005
Shadow Shader

Ok, i'm posting the sib_shadow_material.mi here because it could still use a little help from the community.

With this .mi file and the sibase.dll which comes with XSI you can load the shadow material shader from XSI inside Maya. Which means any object you assing this to just renders the shadow it's receiving

Things to look out for:
- the shadow is rendered to the alpha channel if you don't check 'rgb'
- for the alpha channel to appear check the 'pass custom alpha' in the renderoptions > custom entries
- the shader should be plugged into the MR material shader i the shading group or else it's slow

I hope someone would write a nice light selector AEtemplate like with all pixero shaders.

That's it so far, enjoy! For all that have access to the sibase.dll (and don't ask me for it!)

Great almost forgot the link: http://www.twentythree.de/andy23/sib_shadow_material.mi

AndY

Last edited by a23 : 02 February 2005 at 06:19 PM.
 
  02 February 2005
Originally Posted by a23: Ok, i'm posting the sib_shadow_material.mi here because it could still use a little help from the community.

With this .mi file and the sibase.dll which comes with XSI you can load the shadow material shader from XSI inside Maya. Which means any object you assing this to just renders the shadow it's receiving

Uhmm.. what's so wrong about the useBackground shader? If that doesnt help, try Puppet's p_shadow:
http://www.puppet.cgtalk.ru/download/shaders_p_e.shtml
__________________

Astro Man
!!!!!!!

Six Tuts On Light And Shade
 
  02 February 2005
hey floze,

there's nothing wrong with the background shader, except that in my testing it always shadowed in the ambient part as well. anyway, thank's for the link, i didn't know of it.

Thanks again for posting, it should help a few other people out here. I'll try them out and see how they work for me.

AndY
 
  02 February 2005
In Maya 6.5 the use background shader is working with final gather !

thanks a lot francesca for this very very great set of shaders!

and thank in advance for the multilayer.openexr !!


Laurent.
 
  02 February 2005
Quote: I think we need to start building a giant marble statue of Francesca so we can praise her greatness all day long!


Franchesca you rock, I'm thinking we need a cgtalk working bee around at your place, lawns mown, garden weeded, hedges trimmed, dishes washed...I give great foot massages

Thanks again, you unbanable(sp?) cherub

MunCH
__________________
____________________________

An erection doesn't count as "Personal Growth"

Last edited by MunCHeR : 02 February 2005 at 07:43 AM.
 
  02 February 2005
I'm lost (or similiar).

I have my scene with my mesh and many shaders assigned.. Now i create the buffer_store in the hypergraph and start to put my shaders in the buffer.1, buffer.2 and so on.. I've set the buffer_write to the output shader in the persp camera with the name for the output render.. tweak the buffer_range to ..3
Now i think i'm ready.. So i render but in the output window i see many errors

PHEN 0.2 info : writing depth buffer to "last.zdepth.1.iff"
PHEN 0.2 error 051001: cannot map frame buffer: invalid fb index (14)
PHEN 0.2 error 051001: cannot map frame buffer: invalid fb index (15)
PHEN 0.2 error 051001: cannot map frame buffer: invalid fb index (16)
PHEN 0.2 info : -----------------------------------------------


So i decide to assign the buffer_store to the whole mesh and again the error came up..
Then i restore my shaders association and start to add the buffer_api to the invisible cube as read in the docs.. Booom. In the specified path now i see the sad.user#.#.iff but they are black images.. Ok, now, again assign the buffer_store to all and finally i see my outputs!!!

PHEN 0.2 info : ctrl.buffers ----------------------------------
PHEN 0.2 info : writing depth buffer to "last.zdepth.1.iff"
PHEN 0.2 info : writing user buffer 1 to "last.user1.1.iff"
PHEN 0.2 info : writing user buffer 2 to "last.user2.1.iff"
PHEN 0.2 info : writing user buffer 3 to "last.user3.1.iff"
PHEN 0.2 info : writing user buffer 4 to "last.user4.1.iff"
PHEN 0.2 info : -----------------------------------------------

Very sad story because i have no more the original shader assignment..

I suppose you're about to laugh.. but i'm waiting for a help!!

Is this procedure correct? Do i have to assign multiple buffer_store per mesh?

There you have my desktop.. (i wish i can capture the reflex of my face too)..




Why nobody post a simple scene? Why this simple scene is not included in the shader download?

Thanks for reading my story

-elvis
__________________
So you get NOTHING! You LOSE! Good DAY sir!
ピザやマンドリン
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 12:44 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.