maya 2013 ncache rendering problem

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  02 February 2013
maya 2013 ncache rendering problem

Hi,

I cached nparticles and want to render them on a farm with maya batch render. the problem is that the first frame of every batch is rendering without shading on the nparticles. for example if I submit 100 frames on 20 machines every 5th frame has non shaded particles (they appear in the alpha though). So every start frame of every batch don't get rendered properly.

A current workaround is turning the "post cache ramp evaluation" on before submitting to the farm and then everything renders fine.

I need another solution though because we wanna do cache reversing and time remapping which will cause problems.

did you come across the same problem and do you have a solution?

I also tried using pre render mels like dgdirty, moving the timeslider around but nothing worked.

any suggestions are much appreciated!
 
  02 February 2013
Hey Noticeus ,
are you using Motion blur ? I have been having a same problem rendering nParticles on farm...especially with Motion blur...frist frame of batch render was refusing color ..the glow is also so buggy.. I ended up putting it in post though.
If you are planing to time warp or retime the cache...FORGET about it. It doesn't supports in between frames interpolation. I switched to Standard particles sometimes when I don't need any specific nparticles features. It so disappointing that there are no cache interpolation support for the nparticles vs the old standard particle which works fine.

the caching bug is not new & its been there since 2009..still no support or plans to fix this bug :/
 
  02 February 2013
thanks for the heads up viki!

no I'm not rendering motion blur at the moment but we will come to that later on and will hit the wall again I guess. The nParticles are just a pain in the A$?. although I like the collision parameters and selfcollision and if nCache would work it would be nice as well but too many bugs and problems.

Til the current project I was using old particles because of the convenient way of addressing geometry and collision ids and caching just worked (but that's off topic now).

any other tips than switching software
 
  02 February 2013
The workaround that comes to my mind is..
Use Nparticles for simulation, Goal the standard particles on nParticles & then cache it.
now you can re-time the standard particles or do time warp & u can use the same shading as what u have applied on nparticles.

Best,
- Vik

Last edited by viki164 : 02 February 2013 at 12:52 AM.
 
  02 February 2013
thanks vik,

I might go down that route if it's the only way to get things done.
 
  02 February 2013
Duncan to the Rescue Again !

Hi Noticeus,

Just wanted to share this workaround suggested by Duncan..


Instead of goaling a classic system to nParticles, one can create an old style cache for nParticles using the cache command, then use that on the old system. One needs to make sure to specify attributes to cache in the command so that only ones that exist on the old system appear in the cache.

I did a quick test , I cached the nParticles in a old style , using dynExport mel command in .pdc or pdb format & then attached this cache to the old particle system I also re-timed it . It Works !!

Hope this helps

Best,
- Vik
 
  02 February 2013
Noticeus I can confirm you that I am facing same issues in batch rendering nparticles on farm. every first frame of the batch renders refuses the color but when I turned ON the post cache ramp evaluation then everything renders fine !
I can report this as a bug if you want unless you have already logged it as a bug to AD.
 
  03 March 2013
sorry, for the late answer. yes please log it as a bug at AD.

thanks.
 
  03 March 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:19 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.