mental ray, disabling shadows on cloud nparticles

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  02 February 2013
mental ray, disabling shadows on cloud nparticles

Hey everyone,

i'm currently using nparticle clouds to render an exhaust trail of a spaceship and want to use mental ray for my renders with raytraced shadows. The problem is that the particles shouldnt receive any shadows (its not a smoke trail/exhaust but i want it to be looking like a the fire or plasma trail out of the engine).

I tried unchecking "receive shadows" on the render stats of the nparticle shape but that didnt change a thing, the particles are still receiving the raytraced shadows. after that i tried setting the shadows flag of the mentalray settings of the nparticles to "No" instead of "derived from maya" but that didnt help either, i guess that only disables the ability of the particles to cast shadows but doesnt affect their ability to receive shadows.

is there any way to make sure the nparticle clouds dont receive any shadows when i render with mental ray and raytraced shadows?

thanks for your help.
 
  02 February 2013
This is funny because usually people are asking "How do I get shadows on my cloud particles?" Not quite sure why you are getting shadows. Just a test, if you disable the shadow casting on your light you don't get any shadows at all correct?
But really the easiest solution would be to add incadecense in the cloud shader. Since you want the clouds to be an incandecent material, this is the most 'correct' way to do it. Give that a try and that should do the trick.
Hope that helps.
~Ben
 
  02 February 2013
yeah when i disabled the raytraced shadows of the lights the shadows are gone. I had my clouds already with incandescence but you still could see a slight difference between the lit and the shadowed part. Using the incandescence i now figured out a way to get what i want.

i removed the light links between the clouds/particles and the light, so the clouds don't receive any light (or are "always shadowed") and then turned up the incandescence even more (i actually just multiplied the incandescence i had with the outcolor of the light to get the same look i had before).

thanks for your help.
 
  02 February 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:23 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.