CGTalk > Support > CGSociety Support Forum
Login register
Thread Closed share thread « Previous Thread | Next Thread »
 
Thread Tools Search this Thread Display Modes
Old 11-11-2013, 01:48 PM   #1
joana
***
 
joana's Avatar
portfolio
Joana Garrido
Digital Artist
Lisboa, Portugal
 
Join Date: Sep 2002
Posts: 460
Exclamation Issues with the new design

Sorry if late for the party, etc, but just logged in today, and found the site has a new design.

I am using a tablet, and will seldom use a destop again. Here are some of the issues I have encountered in the CGPortfolio site (Chrome, Safari and Dolphin all have problems):

  1. Page loads fine, but projects thumbnails do not (Safari and Dolphin).
  2. In Chrome, if you navigate to some other tab, and again to the portfolio one, the page starts loading again (this happens to the forum pages as well).
  3. Infinite scroll: this seems like a cool idea, but in reality it's a pain, since projects need to load all over again if you click on a thumbnail. Or in the Chrome case explained above, you need to click on the "Load more" over and over again, since it only loads the first batch initially.
  4. Pinch / zoom does not work: this ignores one of the most comfortable features of working with a tablet.
  5. In Safari, clicking on the top Profile Image> Drop menu for settings, links to a nonexisting page (http://.cgportfolio.org), so you cannot access your settings.


Thanks.
__________________


tumblr ░░░░ facebook

Last edited by joana : 11-11-2013 at 02:03 PM.
 
Old 11-11-2013, 06:28 PM   #2
leigh
blahblah
 
leigh's Avatar
CGSociety Staff
portfolio
Leigh van der Byl
A cog in the wheel
Hertfordshire, United Kingdom
 
Join Date: Feb 2002
Posts: 29,791
Thanks for letting us know! I'll make sure our tech wizards see this, and please don't hesitate to let us know of any other issues!
__________________
leighvanderbyl.com
 
Old 11-11-2013, 08:00 PM   #3
pokoy
dental floss tycoon
 
pokoy's Avatar
portfolio
Marcin Gruszczyk
Germany
 
Join Date: Aug 2003
Posts: 2,293
Issues I've seen so far:

- on the main page, the user avatar is missing in the main header
- on the Portfolio page, sometimes clicking on a project's comments symbol (which should direct you to the original thread) will result in a 'you do not have permission to access this page...' message. It seems to happen with closed threads mostly, some closed threads still open fine
- when clicking on the avatar on my own page (opens 'Edit Avatar' page), this is displayed as rule for image size: 'Note: The maximum size of your custom image is 0 by 0 pixels or 0 Bytes (whichever is smaller).' Zeros should be replaced with meaningful numbers
- portfolio > about > contact: e-mail and website links do not work
- just saw that the 'view portfolio' button grpahics under users' avatars in forum threads are missing, and clicking results in a 'file not found' message site

Other than that, it's great to see the improvements finally, congrats! It's so much better now with larger image previews. I'd still have some suggestions but I bet you don't want to hear!

Last edited by pokoy : 11-11-2013 at 08:42 PM.
 
Old 11-12-2013, 12:53 AM   #4
AJ1
User
 
AJ1's Avatar
CGTalk Forum Leader
portfolio
A J
Indiana, USA
 
Join Date: Jan 2012
Posts: 1,810
I think the design looks good! I'm using Firefox on Win7 and other than the comments issue, it seems to run smoothly.

Also, are the portfolio view counts calculated differently now? I noticed when I refresh the browser, it goes up by one. I don't think the old one counted views from the user. Also, it looks like the view count has roughly doubled for everyone? Is it also counting search engine bot hits?
__________________
 
Old 11-12-2013, 02:08 AM   #5
Kirt
Expert
 
Kirt's Avatar
CGSociety Member
portfolio
na
USA
 
Join Date: Apr 2002
Posts: 8,606
I'll just add that enlarging a 100x100 forum avatar to 250x250, on the Portfolio main page, looks really crappy. Even at 193x193, on the user's Portfolio page, the image looks fuzzle-messy. Bleh.
 
Old 11-12-2013, 07:06 AM   #6
phexitol
hot pixel
 
phexitol's Avatar
hex pilot
USA
 
Join Date: Sep 2002
Posts: 483
Unhappy

The "Latest Work 3D" gallery is now broken. Most of the threads are locked, with absolutely nothing inside, and the following at the top of the page:

Warning: Invalid argument supplied for foreach() in /showthread.php on line 826

Warning: Invalid argument supplied for foreach() in /showthread.php on line 929

I'm using the latest version of Firefox on Windows 7 x64.
 
Old 11-12-2013, 07:12 AM   #7
castles
admin
 
castles's Avatar
portfolio
Ben
The Art Society LLC
home, Australia
 
Join Date: Aug 2012
Posts: 359
Hi all,

THANKS for your feedback. It's very much appreciated.

We've been fixing bugs all day, so hopefully a good number of the mentioned ones are now non-issues. I'll try and address each in turn:
1. Page loads fine, but projects thumbnails do not (Safari and Dolphin).
--FIXED
2. Chrome, if you navigate to some other tab, and again to the portfolio one, the page starts loading again (this happens to the forum pages as well).
-- I'm not getting this behaviour, we might have fixed it. Can you recheck please?
3. Infinite scroll: this seems like a cool idea, but in reality it's a pain, since projects need to load all over again if you click on a thumbnail. Or in the Chrome case explained above, you need to click on the "Load more" over and over again, since it only loads the first batch initially.
-- Would you prefer a paging interface?)
4. Pinch / zoom does not work: this ignores one of the most comfortable features of working with a tablet.
--We will look into this one. It might be the case the the responsive design comes at the price of no pinching)
5. In Safari, clicking on the top Profile Image> Drop menu for settings, links to a nonexisting page (http://.cgportfolio.org), so you cannot access your settings.
--Can you try this again and tell me if it's fixed or broken please. If it's still not working, please try logging out then back in



6. on the main page, the user avatar is missing in the main header
-- FIXED
7. on the Portfolio page, sometimes clicking on a project's comments symbol (which should direct you to the original thread) will result in a 'you do not have permission to access this page...' message. It seems to happen with closed threads mostly, some closed threads still open fine
-- We will address this shortly
8. when clicking on the avatar on my own page (opens 'Edit Avatar' page), this is displayed as rule for image size: 'Note: The maximum size of your custom image is 0 by 0 pixels or 0 Bytes (whichever is smaller).' Zeros should be replaced with meaningful numbers
-- Can you send me a screenshot of this please. I can't replicate that behaviour - bencastles@ballisticmedia.net
9. portfolio > about > contact: e-mail and website links do not work
-- Can you send me a screenshot of where this link is please
10. just saw that the 'view portfolio' button grpahics under users' avatars in forum threads are missing, and clicking results in a 'file not found' message site
-- Sorry to ask for another screenshot, but if you circle where it should be that would help me find it!

11. Other than that, it's great to see the improvements finally, congrats! It's so much better now with larger image previews. I'd still have some suggestions but I bet you don't want to hear!
--We would love your suggestions. Fire away to my email address: bencastles@ballisticmedia.net


12. Also, are the portfolio view counts calculated differently now? I noticed when I refresh the browser, it goes up by one. I don't think the old one counted views from the user. Also, it looks like the view count has roughly doubled for everyone? Is it also counting search engine bot hits?
-- The portfolio views are coming from the DB. I'll have another look at how that works. Regarding incrementing the number do you think it should reflect the number of users who looked at a portfolio, not every page they looked at?

13. We will work on a I'll just add that enlarging a 100x100 forum avatar to 250x250, on the Portfolio main page, looks really crappy. Even at 193x193, on the user's Portfolio page, the image looks fuzzle-messy. Bleh.
-- The avatar system needs some work. What we see now is a temporary solution. Updating avatars to 193x193 looks much better than 100x100 if that helps!


Thanks again,
Ben
 
Old 11-12-2013, 07:31 AM   #8
AJ1
User
 
AJ1's Avatar
CGTalk Forum Leader
portfolio
A J
Indiana, USA
 
Join Date: Jan 2012
Posts: 1,810
Quote:
9. portfolio > about > contact: e-mail and website links do not work
-- Can you send me a screenshot of where this link is please


Hey Ben,

It looks like it might not be formatting the address correctly when you click on the website link in someones portfolio. I'm just using the new version of Firefox in Windows 7 64 bit.

http://i1339.photobucket.com/albums...zpsc2c16707.jpg

As far as the portfolio views goes, I just wanted to make sure something didn't go wrong. Maybe the old tally was only when someone would look at your main page, while the new one also counts when they click on images? My portfolio views were around 3300 before the update, and its like 6500 now.

Thanks for taking time to hear user input!

-AJ
__________________
 
Old 11-12-2013, 08:29 AM   #9
pokoy
dental floss tycoon
 
pokoy's Avatar
portfolio
Marcin Gruszczyk
Germany
 
Join Date: Aug 2003
Posts: 2,293
8. > see attachment (8_cgtalk_edit_avatar.jpg)
9. > see attachment (9_cgtalk_portfolio_dead_links.jpg)
10. seems to be resolved, I don't see this anymore

Another issue:

- Clicking on the avatar in the main header opens a dead link (http://.cgsociety.org/) - but ONLY on portfolio page. Works correctly when clicked from the forums.



AJ1, the user's website links seems to be formatted differently now. You need to update it in your profile without using 'http://'. I had to update this, too.

About the view counts, definitely increased my views a lot as well. I've had something around 180K and am at 320K now. How did counting work before the update?
Btw, I like that the counter is more responsive now...

My suggestions/requests:

- NO ADS on portfolio pages please! I know this isn't going to happen but I really hate any kind of ads when viewing others' portfolios

- I still miss a way to customize and organize my artwork. We NEED user customizable categories (and if it'd be a paid account benefit, I'd start pay again right away...) and it would be great to have arbitrary sorting back (like we had with the old system), sorting by name and date only is not enough imo

- design-wise, the new portfolio is still wasting a lot of space. I'm not sure if we really need that infographics-look or even the avatar. When sending a link to a potential employer, I really don't want him to see statistics, they may be interesting to me but why should he see my viewcounts or the '0 CG badges' bit? Let's face it, it is zero for 99,9% of users here, so why make it so prominent? At least give us an option to disable display of statistics for anyone else.

On the positive side, I love the SM sharing buttons, they look way better now!
Attached Images
File Type: jpg 8_cgtalk_edit_avatar.jpg (75.7 KB, 7 views)
File Type: jpg 9_cgtalk_portfolio_dead_links.jpg (93.2 KB, 15 views)

Last edited by pokoy : 11-12-2013 at 01:17 PM.
 
Old 11-12-2013, 01:54 PM   #10
Vielmond
Lvl 25 Artist
 
Vielmond's Avatar
portfolio
Camila Vielmond
Concept artist & Illustrator
Rio de Janeiro, Brazil
 
Join Date: Jan 2012
Posts: 32
1. Some of the projects thumbnails look bad, particularly if you do too much texture work on dark gray/black areas. Is this compression a temporary solution?

2. I add my voice regarding the ads on portfolios. However, I understand the need of them and I have a suggestion: Give an extra help to the user identify them as advertisements by placing a <small>Advertisement</small> tag near them or placing them inside a slightly lighter div, because right now they're inside the content area and integrated to the thumbnails' flow, being nearly indistinguishable from the true content—what isn't the best practice.

P.s.: New bugs located:

3. The names of the artists on the showcase gallery are wrong on the new posts, being a lowercased version of the forum nick instead of the portfolio name. They are also wrong inside the threads.

4. The descriptions of these new works aren't appearing on the threads. E.g.: http://forums.cgsociety.org/showthread.php?t=1133662

5(?). Another change was of the country. It displays the city too. Not sure if it's on purpose.

6(?). It seems that the regular showcase galleries are now validating the threads automatically. Is this change intended?

7. On the portfolios page the Register | Login options are always present on the header, regardless of you being logged in or not.


Anyway, thanks for the fast work fixing the bugs, guys!
__________________
Tumblr | deviantART | Facebook

Last edited by Vielmond : 11-13-2013 at 01:31 PM.
 
Old 11-13-2013, 12:12 AM   #11
Kirt
Expert
 
Kirt's Avatar
CGSociety Member
portfolio
na
USA
 
Join Date: Apr 2002
Posts: 8,606
Quote:
Originally Posted by Ben
Updating avatars to 193x193 looks much better than 100x100 if that helps!


Forum restricts uploads to 100x100. However, this is a minor issue. I'd rather see the other problems worked out first.
 
Old 11-13-2013, 03:26 AM   #12
Vielmond
Lvl 25 Artist
 
Vielmond's Avatar
portfolio
Camila Vielmond
Concept artist & Illustrator
Rio de Janeiro, Brazil
 
Join Date: Jan 2012
Posts: 32
Quote:
Originally Posted by Kirt
Forum restricts uploads to 100x100. However, this is a minor issue. I'd rather see the other problems worked out first.

That's odd.

As soon they changed the layout I've uploaded a 193x193 avatar; I've reuploaded it now and still had no problems. Are you sure the dimension is the problem, not the weight? It must be 45.0 KB or lower.
__________________
Tumblr | deviantART | Facebook
 
Old 11-13-2013, 02:57 PM   #13
Kirt
Expert
 
Kirt's Avatar
CGSociety Member
portfolio
na
USA
 
Join Date: Apr 2002
Posts: 8,606
My file is only 5 KB. Yes, I'm sure.
 
Old 11-13-2013, 06:25 PM   #14
Kirt
Expert
 
Kirt's Avatar
CGSociety Member
portfolio
na
USA
 
Join Date: Apr 2002
Posts: 8,606
Just noticed that the 2D and 3D galleries for latest work are not displaying the text descriptions that users submit with their images. Only the image and header info is displayed in new posts.
 
Old 11-14-2013, 05:15 PM   #15
Leaubellon
in the attic
 
Leaubellon's Avatar
portfolio
Leaubellon RN
Paris, France
 
Join Date: Jul 2003
Posts: 278

I used to have two badges on my portfolio page and I just noticed one (Expose 2) has disappeared. I don't know if it's connected with the change of design since I haven't been around in a while but I thought I'd mention it here just in case.
 
Thread Closed share thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:29 AM.


Powered by vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.