Proper DOF in Nuke

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

Thread Tools Display Modes
  10 October 2012
Proper DOF in Nuke

I'm working on a scene, but zblur is really really ugly, it's not even proper depth of field it just smudges my image. Defocus looks a lot closer but can't be used with a zdepth pass afaik.

Is there a way for me to get a proper depth of field pass that I can turn on/off in nuke?

I was hoping I can render it out of vray + maya and use as a separate image to merge into my composition.

This here is the scene I'm working on if seeing it helps at all. It has that ugly zblur in it. During school for my still life project I ended up just suffering an 11.5 hour render time so as to not have to use zblur... I NEEDED the shape to match a camera's.

  10 October 2012
Defocus w/ a Z-depth pass as mask is working fine over here:

What's does your Z map look like? Remember that if it's a floating point image you'll probably have to lower the gain values to get the data to appear.
"For what is a man profited if he gains the whole world but loses his own soul?"

- Jesus
  10 October 2012
My zdepth map is fine, it works properly, it's zblur that produces an ugly result. I want the filter shape, zblur has this option but it doesn't work well at all.

I'm trying to get a good bokeh effect and zblur just smudges an image which doesn't look like proper DOF at all.

Should end up something like this, not a guassian blur

I will try defocus again... but not sure I know how to make it work. I'm not good with nuke, a year ago or more when I was doing this I was told it couldn't work in that way; so how do you do it?

Last edited by JaredTaylor : 10 October 2012 at 01:50 AM.
  10 October 2012
Originally Posted by ndeboar: Try this

I'll look into that, cheers.
  10 October 2012
the zblur node does just a blur based on the depth channel (as the names tells you), a proper depth defocus doesnt come with nuke (well, the upcoming nuke7 has one). you have to look into plugins like the one posted already or the frischluft lenscare plugin.

the zblur in nuke can give you some circle bokehs if you set the filter shape slider to 1. this works best if you have higlights with values above one and a very strong blur value

a workaround without plugins:

you can use a zslice to cut your scene into different depth slices, defocus them and merge them back together.
  10 October 2012
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
Thread Closed share thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Society of Digital Artists

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump

All times are GMT. The time now is 05:11 PM.

Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.