Maya 2018 - How to fix banding with Arnold?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
  10 October 2017
Maya 2018 - How to fix banding with Arnold?

Hi, i just rendered an scene in exr stills, it has an Arnold Area light wich increases itīs exposure and intensity in about 7 seconds (from dark to regular light intensity), the problem im having with Arnold is that in the floor object i can see banding (lines moving) when the light starts to increase its intensity, this banding starts to move across the floor object like waves until light intensity stops, iīm working in linear workflow, only using arnold materials, arnold area light, already tested this in 3 different displays besides my laptop, all showing banding and also tried checking animation at Nuke and banding still appears.

I already tried to fix it by increasing AA, Difuse and Specular Samples (wich afected my render time real heavy, from 15 minutes to 40 minutes per frame, without solving my banding problem) also tried increasing light samples  and reducing my floor object specularity..........., but until now i havenīt been able to fix this banding issue with Arnold, maybe i can fix it in Nuke Studio 10, but i still dont know how to fix banding in post with Nuke, i have found cero video tutorials, but i would like to fix it in Maya 2018 to avoid having this problem every time and having to fix every scene.

what else can i do?

Last edited by Bloops : 10 October 2017 at 06:21 AM.
 
  10 October 2017
Just to be sure...., your EXR format is 16 or 32bit float?
__________________
3D Animator and TD at www.vortice3d.com

"Donīt trust on affemeral things, only love will last..."

Visit my BLOG: 3djoie.blogspot.com
 
  10 October 2017
Can you post an image? I suppose you mean something like a burnout area which grows without any details in it? Or do you mean really a banding like the ones which occurred with smooth ramps in 8bit images?
__________________
www.renderwiki.com - www.openmaya.net
 
  4 Weeks Ago
I actually thought EXR was already 32bits float by default, i also read that even if it is 16, it willl be enough to avoid banding, but i really dont know how to check if it is 32 or 16 in Maya 2018 or how to change it, please help

Yes it looks like horrible ramp lines moving across flat objects, it starts when light increase intensity, then the  ramp lines move over any flat object, like waves, i already tried several things but havenīt been able to solve it and Arnold site doesnīt say much about light and banding, just about light and noise.

Itīs hard to notice by a picture, i actually didnīt noticed the banding while i was making testing renders, its reall smooth but itīs very apparent when playing the animation and thatīs my biggest problem, i have to render at least 5 seconds to see it clearly, wich takes almost an entire day of continuous render with Arnold, hours and hours; as soon as ai-light increases intensity from dark to regular light intensity, this ramp of lines starts to move across every flat object, it looks like tons of ramp lines or waves growing or moving, making the animation look weird.

Last edited by Bloops : 4 Weeks Ago at 12:31 AM.
 
  4 Weeks Ago
You can set the exr data type in the "Common" tab in the render globals. If "half precision" is not checked, the rendered image will be a 32bit exr what is the default.

I think we can exclude the image bit depth as a reason for banding, but without images it is really hard to say what the reason could be. Could you post a small reduced scene, maybe with only one light and one plane so we can reproduce the effect?

As much as I can remember, we never had this problems, but we never rendered a sequence with Arnold5 yet.
__________________
www.renderwiki.com - www.openmaya.net
 
  4 Weeks Ago
Hi,

Am I mistaking that you are rendering something that has very low noise?

If so, switching to 32 bit has nothing to do with it, because even in 16bit,
to a very large degree are there more than suffiicient color substeps probably there (exponentially more than 8 bit),
you are just not seeing them on your (8bit) screen.

If then you load your image in something like nuke, you would see that the problem is non-existant because it dithers the result as a final step in the viewer.

So I think you just need to essentially introduce a very low amount of noise 
Were always trying to reduce noise, but a minimum of noise is essential for any wide gradient (like procedural skies) especially that the end result is often displayed as 8 bit.

You can tweak the noise while temporaily viewing with low gamma and high gain or in higher contrast, and of course zoomed,
then starting with 0 noise, while slowly increasing until the grain in one color step reaches the next color step.

Good luck!

Last edited by FxDuude : 4 Weeks Ago at 09:09 PM. Reason: typos
 
  4 Weeks Ago
Hi,  sorry you mentioned you opened it in nuke,

In preferences -> viewers,   what is your "disable viewer dithering" set to ?

The default is OFF (viewer dithering not disabled)

For the previously mentionned steps for introducing noise, there is a dither node for that purpose,
and you can provisionally disable the viewer dithering (affects new views in the same session) while tweaking it.

Cheers!
 
  4 Weeks Ago
This is my "default" viewer config at Nuke Studio 10:



But as i said, i want to fix it at Maya or all my renders will have banding and i still dont know how to fix banding with Nuke Studio 10 either.


The next image is how i see EXR in Maya 2018 by "default", i dont see any 16, 32 floating option, but Half Pecision is unchecked MR Haggi.



the next image, was... my original render configuration (4,2,1,1,0,0), in fact i was rendering some noise...... i didnīt wanted to fight Maya 2018 about noise too, the scene is pretty big and this "low" config was already taking 10 to 13 minutes to render each frame of my HD scene (for me this was ok), raising just 1 time AA or even Diffuse, was gonna take me extra 5 to 6 minutes per frame (i tested this average time before start rendering) so i didnīt care a bit of noise in my scene, just because i was going to use "denoise" at Nuke Studio... but

after this confg produced this horrible banding i raised way higher several times, my last was AA 8 diffuse 8, specular 8 and same way i raised ray deph values.. and i did this.. just to test if this banding was a "raising" values problem....but after Arnold took forever (days) to render my 5 to 7 seconds raised scene, banding continued to appear; since its an animation i also used lock sampling pattern and lowered clamp values to avoid fireflies, but i already tested this unchecked, i have made a lot of testings... still havent been able to solve banding in Maya 2018.



Iīm starting to think i shoud not make scenes with maya 2018 that imply raising light intensity... Arnoldīs banding is just wining and for me at least itīs also a render time issue, i know for big studios 15 minutes per frame itīs nothing, Avatar 2 is taking 24 hours per frame, i mean James Cameron is going to lough about my render times or he is going to scream at me.....  LOL.

i know i didnīt aded an still of the banding, but it will be useless, i test all my animations in diferent types of display, i even test them in my cellphone some times or in several types of TV displays, I know... im picky, but i didnt saw banding when testing single renders; the banding, ramps or waves of lines are more visible clearly in animation and before rendering.... as soon as light starts to increase intensity or exposure ( i tested both options), lines start to move across any flat surface, i also tested adding some noise to my flat surfaces textures, the banding is less obvious but banding is banding and i can not add noise to all my flat sufaces, my flat boxes are gonna look like leather OMG just to solve Arnoldīs banding, iīm just close to give up and change the beauty of my original concepts for the sake of avoid waisting rendering time.

I hope my configurations are usefull to find why this banding occours and if so to help others with same problem.

Last edited by Bloops : 4 Weeks Ago at 09:25 PM.
 
  4 Weeks Ago
Since a still image is not helpful, I think the only way to check what's happening is to post a reduced scene which we can check, one light and one plane should be enough if it shows the effect.

And I agree, 4 camera samples are very low and should render quite fast. If you set the diagnostic verbosity level to "warnings + info" and show us the result, we can maybe give some hints why the rendering takes so long with these settings.
__________________
www.renderwiki.com - www.openmaya.net
 
  4 Weeks Ago
This is another scene with Arnold Area light wich also has banding in Arnoldīs final render, this one didnīt required animation, so now i can show you my banding problem with Maya 2018, maybe this helps:




Same render settings,

Light:



Until now, no way to solve banding with Arnold 5.

Last edited by Bloops : 4 Weeks Ago at 10:30 AM.
 
  4 Weeks Ago
Hi, can you post the scene?
__________________
AI will never achieve Human Stupidity.
 
  4 Weeks Ago
What would help is an exr image or the scene itself. The scene itself would be most helpful.
__________________
www.renderwiki.com - www.openmaya.net
 
  4 Weeks Ago
Originally Posted by haggi: What would help is an exr image or the scene itself. The scene itself would be most helpful.

Here is an small test scene just with a simple cube, one area light, and one material, i wish itīs just a render settings problem, if not your pc will open it with your configurations and you wont be able to reproduce the banding, i hope it does.

I tried to insert it, i think i couldnīt, how you insert scenes now? i clicked insert/upload after file uploaded says completed and i clicked "add to post"....but nothing, its just 55kbs i think it should be aable to upload this size and i donīt think i can make it smaller, already tried like 10 times, how you insert maya scenes these days to the forum?

Last edited by Bloops : 4 Weeks Ago at 11:33 PM.
 
  4 Weeks Ago
Originally Posted by Bloops: Here is an small test scene just with a simple cube, one area light, and one material, i wish itīs just a render settings problem, if not your pc will open it with your configurations and you wont be able to reproduce the banding, i hope it does.

I tried to insert it, i think i couldnīt, how you insert scenes now? i clicked insert/upload after file uploaded says completed and i clicked "add to post"....but nothing, its just 55kbs i think it should be aable to upload this size and i donīt think i can make it smaller, already tried like 10 times, how you insert maya scenes these days to the forum?

Probably easier to just put it on dropbox/google drive and share a link.
__________________
AI will never achieve Human Stupidity.
 
  4 Weeks Ago
Originally Posted by DeepPurple: Probably easier to just put it on dropbox/google drive and share a link.
I uploaded scene here: banding

file will auto destroy on nov 6 2017...LOL

I thinks since this is a 3d content base forum, it should have better share options and bigger limits, some times you want to share a good quality render and you cant, then renders are useless since they dont represent normal quality even if you make them small, limitas are very low.

I hope you guys can reproduce the banding in the file, because if it is other than just some render settings i think it wont work because your computers are going to load with your settings, but thats all i can do.

If some one finds a solution for banding problems, please share, so this post helps others too, wich finally is the bigger purpose of the forum.

Last edited by Bloops : 4 Weeks Ago at 03:01 AM.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright Đ2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:53 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.