reflection

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2013   #1
reflection



I created a plexi-glass like object in maya. and, I want to get rid of that white reflcetion on the surfaces.

when I turn off all the lights, the reflection doesnt show up, but the object looks flat.
when i turn on the lights, the white reflaction shows up.

How do I get rid of that white reflaction with light?

thank you!
 
Old 06 June 2013   #2
Set the 'Reflectivity' attribure on your shader to 0.
__________________

gibby3d.com
 
Old 06 June 2013   #3
I tried and, anything changed in rendering image.
is this because i used phong2 for the material?
 
Old 06 June 2013   #4
That looks like the specular...make specular color black or assign a lambert shader.
 
Old 06 June 2013   #5
hi, Duncan
I changed specular color to black and, it worked perfectly.
Thank you so much




now, I want to get rid of those shadow boundaries (?) or make them smoother.
I just dont want to see those lines.

How do I reduce those dramatic changes?
 
Old 06 June 2013   #6
It is hard to know what your problem is. Did you model a simple wedge or model cracks inside it? I can't see how a simple wedge could shade with those artifacts.
 
Old 06 June 2013   #7


This is the object without lights.

It is a wedge shape and both sides are made out of 2 sheets of plexiglasses.
so total 4 sheets.

Each side, 2 sheets are stacked aslant. Those triangular shape at the middle comes from stacked part.

And, has a small plate at the bottom.



I think the problem with the lights is the shadow boundaries are too recognizable, so the lines between light and shadow are created (when I turn on lights), and the object become confusing.

I thought I could make those boundaries blurry. but I don;t know where I can make that change.
 
Old 06 June 2013   #8
You should use raytrace shadows, which handle semi transparent shadows better than depth map shadows. Also on the light and also in the raytrace options you need to have the shadow ray depth limit set high enough for light to penetrate through the multiples surfaces. You might also consider lowering the shadowAttentuation on your shader( shadow attenuation increases the shadowing when the surface is more angled away from the light).
 
Old 06 June 2013   #9
Thank you, it worked. Duncan vbmenu_register("postmenu_7610534", true);



I hope this will be the last question.
I want to get rid of those small noises.
I think that comes from the light I made and, I don't know how to fix it.

please help me again.
 
Old 06 June 2013   #10
Perhaps separate the plates very slightly. It could be precision errors of the rays for very close overlaps.
 
Old 06 June 2013   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:06 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.