Maya Doesnt Mirror my Weights

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2013   #1
Maya Doesnt Mirror my Weights

Ive got this model fully skinned, yet when i try to mirror onto the other side the weights, it doesnt work on the wrist, yet it works on every other joint.

Im using YZ, positive to negative, closest point on surface, and both influences to be closest joint, yet it still doesnt work. Ive tried multiple time but still doesnt work.

Any help???
 
Old 06 June 2013   #2
Is your character in the t stance bind pose?
__________________
Richard Culver
Protfolio Facebook WIP1 WIP2
 
Old 06 June 2013   #3
yes also i tried to remove the influence of the wrist and elbow twist so i can a fresh weight, but again when i mirror them, the elbow twist takes over the wrist influence.
 
Old 06 June 2013   #4
Do you have your normalization set to Interactive or Post? If I remember correctly interactive has some issues. Try setting it to Post instead.

Another thing to make sure of is before you do the initial Smooth Skinning, make sure you delete the history on the object and that all transforms are frozen.

And also what method of Smooth Skinning are you using?
__________________
Richard Culver
Protfolio Facebook WIP1 WIP2
 
Old 06 June 2013   #5
can i just send you the rig and see if you can fix it, please??
 
Old 06 June 2013   #6
I'll be glad to take a look at it. See if I can figure it out. But before that. Try the things I suggested.
__________________
Richard Culver
Protfolio Facebook WIP1 WIP2
 
Old 06 June 2013   #7
i am using interactive because everyone is saying to keep the weights into a maximum value of 100%. also yh i do have the mesh fully cleaned. plus my smooth bind settings are selected joints, closest distance, classic linear, interactive, distance, max influence 3, drop off 4.0 and all the checkboxes ticked. I am using maya 2014 btw. Would you prefer me to save it in a older version??
 
Old 06 June 2013   #8
The main difference between Interactive and Post is when the weights get normalized. You can set it to Post and all of your weights will get normalized when the mesh deforms. When you try and edit/paint weights with Interactive it can cause some issues, and may be the reason it is failing to mirror.

I am using 2014.
__________________
Richard Culver
Protfolio Facebook WIP1 WIP2
 
Old 06 June 2013   #9
Is the nonworking bone overlapping another one?
If this is the case, try to use "one to one" or "label" parameters in the mirrorSkinWeights options ...
 
Old 06 June 2013   #10
ive used every single combination...still doesnt work
 
Old 06 June 2013   #11
ok here's the file.... http://www.mediafire.com/view/ykxmzbqj9jzv8et/my_rig.ma

the way i see it, its something to do with the left wrist having a orient constraint and right doesnt because of the mirror bone....i think....i dunoo i could be wrong
 
Old 06 June 2013   #12
Joints which are not actually matching in mirrored space will cause issues when mirroring weights. I took a look at your file, the bn_r_wrist01 joint was not properly mirrored or moved at some point. Move cc_r_armPos01 forward about 0.042 in Z, then mirror skin weights with 'closest point on surface', association 1: 'closest joint', association 2': 'label'. This fixed it for me.

Oh yeah, make sure you enable weight normalization and unlock your joints in the paint skin weights window before you mirror your weights.

**Sorry, one more edit, I noticed the bn_r_forearmTwist_c01 was off as well, so after you move cc_r_armPos01 to align the wrist joints, use 'skin>edit smooth skin> move skinned joints tool' to move bn_r_forearmTwist_c01 back a bit (just eyeball it in side view) or you will lose skin weights on bn_r_forearmTwist_c01.
__________________

gibby3d.com

Last edited by jgibz : 06 June 2013 at 05:40 PM.
 
Old 06 June 2013   #13
i cant really get it to work...and its starting to get on my nerves....could you please fix it and let me know how it goes???
 
Old 06 June 2013   #14
Originally Posted by KHM3dia: i cant really get it to work...

Can you please specify? Did you follow my suggestions?
I'm not using a student version and I don't think you'll be able to open my .ma
__________________

gibby3d.com
 
Old 06 June 2013   #15
well i tried to have the exact same position...but it still didnt save the weights

Im pretty sure itll work....just please try it for my sake
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:05 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.