Mesh Normals seem fine -- but the direction is off? (maya)

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2013   #1
Mesh Normals seem fine -- but the direction is off? (maya)

So I've stumbled on an odd problem.

I prefer working with my backface culling turned on, just to make sure my normals are doing alright. The problem with this model, unlike others I've ever made, is that this time around the normals seem to be placed correctly, but the direction of the faces goes inside. So when I batch bake my model, the colour seems inverted (#2).

Now this is all much easier to explain in a picture, so here goes:
(If you can't see the image, here's a direct link: http://imageshack.us/f/705/surfaceproblem.jpg/ )



So in #1 is my model, #2 shows the inverted colours when batch baking. My bake-settings are alright, it's just this and another model are having the same invertion problem with the surface direction or something. I don't know. As you can see in #5, the normals are on the 'outside', but the direction isn't. When I reverse the normal (#6) it fixes the direction, but then the normals are on the inside. Does anyone know how I can fix this? :O
It's quite frustrating, especially since it's an easy model.

Cheers,

Last edited by Elydan : 06 June 2013 at 06:33 PM.
 
Old 06 June 2013   #2
Hmm, your images are not showing. Without seeing your images, you could attempt to unify the normals.
__________________
maya and zbrush training
creating CG3D since 2001

3D Models
@ Turbosquid

my Scripts
 
Old 06 June 2013   #3
Originally Posted by Stoehr: Hmm, your images are not showing. Without seeing your images, you could attempt to unify the normals.

Thanks Stoehr. I tried Unify but that doesn't seem to work.

I updated the picture and also added a link. Hopefully you can see the image now.
 
Old 06 June 2013   #4
Ok, a couple more things to try.

1. Unlock the normals, then lock them.

or

2. Set to Face > Option Box, use Match Face normal, apply

or

3. Send me a scene, so I can further diagnose the problem.
__________________
maya and zbrush training
creating CG3D since 2001

3D Models
@ Turbosquid

my Scripts
 
Old 06 June 2013   #5
Go to the 'Render Stats' of your shape and make sure 'Opposite' is checked off.
__________________

gibby3d.com
 
Old 06 June 2013   #6
Stoehr, I tried that and it didn't work. I was about to make an FBX for you to show you the problem, but while doing so figured out that the Maya file was to blame. I was going to upload the maya file today...

But then I saw jgibz's post. And it is exactly the problem!
I never touch those settings there, so I presume a new plug-in I was trying out must've perhaps messed it up? Regardless! Thanks a lot you guys. I checked off the opposite box and now all is fine again. Perfect.
 
Old 06 June 2013   #7
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:05 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.