Loads in 2012, crashes 2013, how to find out why?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 01 January 2013   #1
Loads in 2012, crashes 2013, how to find out why?

I have a character rig here that was built by someone for iAnimate students and then modified by one of the students there. The rig will load fine in 2012 SAP but not 2013 or 2013 SAP.
It gets to about 2% and Maya just quits with no warning. A couple of others at iAnimate have reported the same issue.

I'm just curious, is there any way to figure out what's causing the crash? I've had the script editor open while opening the rig but nothing shows up. I had a similar issue to this a while back with a client file, but in that case the rig was crashing Maya 2012 because of a missing 3rd party plugin, with this iAnimate rig there are no plugins being used in it though, just native stuff. I even tried doing a scene optimize in 2012 and resaving, but again Maya 2013SAP just quits when I try to load that version.

Cheers,
Brian
 
Old 01 January 2013   #2
It seems when going the other way, forwards compatibility (files created in 2013 trying to be opened in 2012) a " -ch ### " flag must be deleted in a text editor.

But backwards compatibility "should" always work, just like the other rigs.

That's not much help, but maybe a clue.

Last edited by egglybagelface : 01 January 2013 at 06:17 AM.
 
Old 01 January 2013   #3
Answer for anybody else out there:

In 2012 resave the .ma file as .mb and then retry opening in 2013.
 
Old 01 January 2013   #4
Hey cool, that works, I saved as .mb in 2012 and it loads fine now in 2013. Many thanks. Curious how you figured that out? Is it one of those Maya quirks you learn to keep an eye out for?

Cheers,
Brian
 
Old 01 January 2013   #5
I had a *feeling* in the back of my head that it would work, but I couldn't check as I uninstalled 2012, but Frank confirmed it on the site.
 
Old 01 January 2013   #6
Cool, good hunch so. What's your name on the iA site BTW?

Cheers,
Brian
 
Old 01 January 2013   #7
Jason Ryan
 
Old 01 January 2013   #8
Hey Jason, heh I never would have guessed it was you, I assumed you were a fellow student at iA. The location in your profile as Sidney threw me off the scent

Cheers,
Brian

Last edited by Horganovski : 01 January 2013 at 08:38 PM.
 
Old 01 January 2013   #9
I'll message ya when I get back home and I can log in to the iA site.

Don't want my name to come up in the google search engine.
 
Old 01 January 2013   #10
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:42 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.