How do stop maya automatically hiding child objects when hiding their parents?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 12 December 2012   #1
How do stop maya automatically hiding child objects when hiding their parents?

I have a nurbs curve parented under joint.

How do you hide a joint and not make the curve hidden also (as maya does automatically)?
Turning off visibility in the viewport is the only option that works, but there are joints on the rig that need to be visible.... so therefore unchecking show/hide joints in the vports is not an option.

I'm sure it's simple.

Thanks, guys.
 
Old 12 December 2012   #2
You could set the Draw Style on the joints you want to be invisible to 'none'.
 
Old 12 December 2012   #3
Hi egglybagelface


My advice would be that keep your rig and your geo parts separate.

If you need your geo to be somehow attached/parented to your rig, use constraints.


/risto
__________________
- Oh no, it's me -
 
Old 12 December 2012   #4
Originally Posted by ristopuukko: My advice would be that keep your rig and your geo parts separate.

If you need your geo to be somehow attached/parented to your rig, use constraints.


Bones have a few features that make it desirable to manipulate them directly.

Also if you can avoid adding unnecessary constraints then all the better.
__________________
blah blah blah
 
Old 12 December 2012   #5
Yeah, I agree about separating things.
I originally learned that the fastest/lightest way to rig was to parent/connect things directly...which is true. But this isn't the best way to set things up if you want clean display toggling, and an easily navigable character hierarchy. But there are many, many, many ways to rig a cat.
Hopefully it isn't impossible to tweak your rig...or at least something to keep in mind for future builds.
~Ben
 
Old 12 December 2012   #6
Thanks, guys, but the rig is virtually complete. And it will be the one and only rig I'll ever make.

"You could set the Draw Style on the joints you want to be invisible to 'none'."

Tried that before.... but they are still selectable in the viewport, even though you can't see them.

Last edited by egglybagelface : 12 December 2012 at 03:12 PM.
 
Old 12 December 2012   #7
Well you'd think that the 'visibility' attribute in the Drawing Overrides section of a node would do just that: Override the inherited property. But that doesn't seem to work for visibility. Go figure.

Oh, wait a minute... for future reference, you could have tried to place the joints in question into a display layer and use overrides for the curves? Maybe that would work.
 
Old 12 December 2012   #8
In all my rigs I use the drawing override and set the root joint level of detail to bounding box. Anything below it, that needs to be visible (usually the control curves and proxy surfaces) simply need their display override enabled (with the level of detail set to full (ie the default)). Like the other solutions posted here, it is a bit clumsy, but since it is all scripted as part of the rig build, and exposed to the animator as a simple toggle on the master control (or where ever appropriate) it actually is not so clumsy in practice.

David
__________________
http://www.djx.com.au
 
Old 12 December 2012   #9
This is unbelievable!

This was the last step to complete my rig.

It's 99.99999999999999999999999999999999% done. Basically 10seconds from finishing. Flicking the switch.

I thought drawing overrides would work!

Nothing works! This is crippling!

Is there a quick backdoor MEL to force the visibilty settings?
 
Old 12 December 2012   #10
Cheers goes to DJX! It seems setting the joint to bounding box and, if necessary, enabling the children to display override to full detail or whatever works.

But that is kinda........ ehhh..... a crappy workaround. Gotta be a better way about it. It does the job... but I foresee problems in the future.

Last edited by egglybagelface : 12 December 2012 at 03:42 PM.
 
Old 12 December 2012   #11
Originally Posted by egglybagelface: Cheers goes to DJX! It seems setting the joint to bounding box and, if necessary, enabling the children to display override to full detail or whatever works.

But that is kinda........ ehhh..... a crappy workaround. Gotta be a better way about it. It does the job... but I foresee problems in the future.


This probably doesn't solve your problem but I often will set a joints radius to 0.. it will still draw a thin line though or a dot if it's not in a joint hierarchy
__________________
blah blah blah
 
Old 01 January 2013   #12
The problem is marquee selection... those 0 radius sized joints would still be selectable. :/

I just hope the bounding box method doesn't backfire somehow.
 
Old 01 January 2013   #13
Originally Posted by egglybagelface: The problem is marquee selection... those 0 radius sized joints would still be selectable. :/

I just hope the bounding box method doesn't backfire somehow.


Hmmm.. I'm curious as to what your control handles look like?
__________________
blah blah blah
 
Old 01 January 2013   #14
Have you tried editing your selection priorities?
Joints are very high priority by default (9) curves are a (4)...if you crank down the priority you should avoid most selection issues.
You can also toggle off joint selection very easily with the little joint icon up in the status line.
Just some thoughts
And just a word of reassurance, if you are just changing display settings on things that you will never need to render, you can't really break a rig or make things un-fixable. Just save different versions just in case. Also make sure you have a solid naming convention so you can select/edit everything easily.
Good luck!
~Ben
 
Old 01 January 2013   #15
Originally Posted by animatedfox: You can also toggle off joint selection very easily with the little joint icon up in the status line.


This is true.. I have a shelf button that sets the selection filter to only select curves and all controls in the rigs I create use a curve for the handle. This seems to be pretty standard.
__________________
blah blah blah
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:06 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.