Blend Shapes not working

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 12 December 2012   #1
Blend Shapes not working

So, I'm working on this project. I created my characters, fully rigged, with everything working correctly. I then referenced the characters into my scene and animated the joints. I'm not adding in the facial expressions which are all in blend shapes. The problem is, only some of the blend shapes are working correctly now. For example, in the original file, the "Blinks" moves correctly over the eyeball. But, in the scene where it is referenced with all of the body animation completed, the "Blinks" slider moves the eyelids straight up and down, so it doesn't curve around the eyeball anymore. I've tried reloading the referenced file but nothing changed. Does anyone have any idea how to fix this so I don't have to start all over again? Thanks!
 
Old 12 December 2012   #2
It's possible that a reference edit in your animation scene file is breaking your rig. If this is the case you can look at the reference edits and remove the offenders, you can rename the blendShape node so that any edit will not beable to find it, you can lock the blendshape node and it's inputs to prevent the reference edits from taking hold. You can also make a fresh reference and copy your animation channels to it.

For starters I'd reference your rig in a clean scene and make sure it still works as expected.

Another strange thing that can happen is that if you are animating the blendshapes directly on the blendshape node rather than connecting attrs from controllers that the indexes of the blendshape node will change and your channels will no longer be animated the correct inputs. It's always best to connect attrs to the blendshape node and animate those.
__________________
blah blah blah
 
Old 12 December 2012   #3
Thanks so much for the reply!
So, I did a clean reference and everything works correctly. I then transferred the animation curves to the new reference and it screwed up the blend shapes. (This time, the blinks are going the opposite direction-getting wider instead of closing)
I'm really new to rigging, so I don't really know what you mean by attaching attributes to the blend shapes, but thank you so much for the suggestion. I guess that's my next step since the scene is not salvageable.
 
Old 12 December 2012   #4
Ok, after some minor research, I figured out how to add and connect attributes to the blend shapes. Everything works great in the original scene file. I create a clean scene, reference in the character, everything is still working fine, then I transfer the animation curves and suddenly it's doing the exact same original issue. Any ideas?
 
Old 12 December 2012   #5
Originally Posted by k8y: Ok, after some minor research, I figured out how to add and connect attributes to the blend shapes. Everything works great in the original scene file. I create a clean scene, reference in the character, everything is still working fine, then I transfer the animation curves and suddenly it's doing the exact same original issue. Any ideas?



Would it be possible for you to share the rig and scene file for me to check out? Or at least include some screen shots that illustrate this error?
__________________
blah blah blah
 
Old 01 January 2013   #6
I found the issue, I'm just not sure how to fix it.

It seems to be directly related to the head animation. If the head is turned in any way, the blendshapes no longer work properly. Do you know of any quick fixes for this? Or should I just completely reload in my blendshapes? And what do you think I should do to avoid this issue a second time?

Thanks so much for all of your help! If this doesn't work, I'll definitely be sending you the rig to take a look at! Thanks again!
 
Old 01 January 2013   #7
Sounds like the blendshapes might be last in the order of input operations after the skincluster or maybe you created the blendshapes with world position instead of local?

To change the input operations order right clock on the object in the viewport and choose Inputs> All Inputs

Then you should see a list of operations including your blendshape and your skin cluster. You want the blendshapes to be at the bottom of the list. So middle mouse click on the blendshape and drag it to the bottom.

In the future when you add a blendshape after skinning make sure in the Advanced options tab that you select "Front of Chain" for the deformation order.
__________________
blah blah blah
 
Old 01 January 2013   #8
Thank you so much! It's nice to know that it was such an easy fix for a problem I thought would kill me!
 
Old 01 January 2013   #9
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:12 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.