Slightly blurry image plane texture

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  11 November 2012
Slightly blurry image plane texture

I have an issue that is crippling my workflow somewhat: my imageplanes are blurring their textures ever so slightly in the viewport, however it's enough that I can't determine a windowsill on an architectural plan for instance.
It's driving me nuts. My viewport prefs are set to 4096x4096 for textures if that's relevant.

EDIT: image plane as in actual image plane node attached to a camera, not a geometry plane with a material on it.

Last edited by Richard7666 : 12 December 2012 at 02:58 AM.
 
  11 November 2012
Have you tried Viewport 2.0 ?

What resolution your imageplane is? Are you talking about Orthographic views like Front/Side for reference for modelling or just perspective camera for rendering...
 
  11 November 2012
Turn all filter settings in the file nodes to 0. A filter of 1 blurs the image so you dont get render artifacts.
__________________
www.danielelliott.co.uk
 
  12 December 2012
^I don't see filtering options? I'm not using a file node, I'm using an Image Plane node.

Originally Posted by Libor: Have you tried Viewport 2.0 ?

What resolution your imageplane is? Are you talking about Orthographic views like Front/Side for reference for modelling or just perspective camera for rendering...


Image planes don't even show up in 2.0 (was it added in 2013? I'm using 2012). Ortho and persp.

The jpegs I use on my image planes are usually several thousand by several thousand pixels (7606x2016 on a current project, doesn't help much)

Last edited by Richard7666 : 12 December 2012 at 09:04 AM.
 
  12 December 2012
Yeah i agree. That just sounds like filtering is going on. Up the top of a file node are the filter type in a drop down. By default it's set to quadratic.... set it to Off.
 
  12 December 2012
I'm not using a file node, I'm using an image plane, so that doesn't really help me.
 
  12 December 2012
Why dont you remove the camera image plane and create a geometry plane with a file texture and your image? If you use an image with a side length above 4096 pixels first set your viewport resolution in preferences up to 8192 pixels. Create a plane with aspect ratio according to your image and apply the file textures material, then move the plane a bit in negative x/y/z direction to get the grid aligned above the image in orthogonal views. Put the plane into a display layer and set its state to reference. This gives you a sharp, artifact free image to work with.
 
  12 December 2012
Originally Posted by Richard7666: I'm not using a file node, I'm using an image plane, so that doesn't really help me.


Image planes can be set to texture mode and you can then plug in a file node which will have the filter options.

Can I ask why you are using such a high resolution image in an image plane? I don't see why you would need that.
__________________
www.danielelliott.co.uk
 
  12 December 2012
go to your objects texture and turn of the mipmap or quadratic filter , These will blur textures on import.
 
  12 December 2012
Image sequences on geometry are usually inferior quality. And I can guarantee they are painfully slower than a camera image plane.
 
  12 December 2012
Originally Posted by danmarell: Image planes can be set to texture mode and you can then plug in a file node which will have the filter options.

Can I ask why you are using such a high resolution image in an image plane? I don't see why you would need that.


I had tried this but the image didn't appear, but I'll have another play around. Cheers for the suggestion.

I'm using such a high-res image because I need to see the details (though that's currently moot with this blurring situation)
 
  01 January 2013
Originally Posted by danmarell: Image planes can be set to texture mode and you can then plug in a file node which will have the filter options.

Can I ask why you are using such a high resolution image in an image plane? I don't see why you would need that.


Alright, tried this. The image doesn't even show up.
 
  01 January 2013
I noticed something annoying 2013... if the imageplane doesn't show up even though Image planes and Cameras are checked on in the show menu of a viewport, you sometimes have to switch them both off and on again.
 
  01 January 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:39 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.