Need help with Maya 2013 on Mac - MIA Glass

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 09 September 2012   #1
Need help with Maya 2013 on Mac - MIA Glass

Is anyone else having an issue rendering Glass in Mentalray?

I made a glass shader but when it renders it comes out opaque! I've lowered the reflections and glossiness because at first it looked like a mirror but it's still coming out opaque!

I've now had to introduce translucency to get my image out, but it does not work properly!

Any advice would be greatly appreciated it!

BTW, i'm using mountain lion...

Thanks,

-G
 
Old 09 September 2012   #2
2 things that come to my mind:
-did you make sure to set the transparency in the shader's refraction tab?
-did you set enough a high enough number in the rendersettings - quality - raytracing tab for refractions so that theyre calculated properly?
__________________

 
Old 09 September 2012   #3
try messing with the refraction settings, maybe lowering them. I sometimes get a solid black object if they're out of wack.
 
Old 09 September 2012   #4
what color does it render? is it opaque and shaded? or completely black?
 
Old 09 September 2012   #5
Originally Posted by julsVFX: 2 things that come to my mind:
-did you make sure to set the transparency in the shader's refraction tab?
-did you set enough a high enough number in the rendersettings - quality - raytracing tab for refractions so that theyre calculated properly?


Attached are the a couple of screen shots!
Attached Images
File Type: png Screen Shot 2012-09-21 at 2.20.14 PM.png (94.7 KB, 5 views)
File Type: png Screen Shot 2012-09-21 at 2.21.53 PM.png (78.7 KB, 5 views)
 
Old 09 September 2012   #6
Originally Posted by mecos: what color does it render? is it opaque and shaded? or completely black?


It's like a weird XRAY thru the building, it looks like a reflection but what you are seeing in the glass it's actually what's in behind the building!

See attached.
Attached Images
File Type: jpg glass shader.jpg (61.6 KB, 9 views)
 
Old 09 September 2012   #7
Originally Posted by zenonithus: try messing with the refraction settings, maybe lowering them. I sometimes get a solid black object if they're out of wack.


I have! it's really weird. Take a look at my other replies, i've attached a screen shot of the shader.

-G
 
Old 09 September 2012   #8
did you use a glass preset? if you didn't that's what i would do. make a new material x, select one of the glass presets and tweak it from there. there are jsut so many variables in maya that starting from scratch might be the simplest way. at least that will help rule out the shader settings as an issue.
 
Old 09 September 2012   #9
Originally Posted by mecos: did you use a glass preset? if you didn't that's what i would do. make a new material x, select one of the glass presets and tweak it from there. there are jsut so many variables in maya that starting from scratch might be the simplest way. at least that will help rule out the shader settings as an issue.


yes, before uploading the render test, i started over with a glass thin preset... I think it might be a mountain lion issue..
 
Old 09 September 2012   #10
Check your surface normals are pointing the right way.
__________________

 
Old 09 September 2012   #11
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:31 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.