Sunday Pipeline (Maya) Public release

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 08 August 2011   #1
Sunday Pipeline (Maya) Public release

Today I have released a public version of our in-house pipeline tool for Maya, Sunday Pipeline (Maya).
This is a public limited version but over time stuff from our in-house version will be implemented in the public version.

The initial beta version 0.1 only contains our Warehouse tool as I promised yesterday in another thread here on CGTalk

And yes, it's free

More information, demonstration video and download from my site 3DG.DK

More information will follow, but here is a quick screenshot:


If you are testing it please feedback It has only been used by a hand full of people... Looking forward to how it handles in the real world

Last edited by cesboa : 08 August 2011 at 08:43 PM.
 
Old 08 August 2011   #2
Awesome, thanks I will report any bugs that I find ...
__________________
LDEA Kon Kuatica
 
Old 08 August 2011   #3
I have made a little guide on how to use the Warehouse post import script feature.
 
Old 08 August 2011   #4
Found a UI bug. Maya 2012 hf3, win7. Look at screenshot.

edit:
More bugs: I canīt move the browser/create windows, and I think the button to close the windows are out of screenview, so therefor I canīt close the windows :/ (you can see that on the screenshot too)

When I click reveal warehouse I get the following error. I just put the warehouse in a subfolder of the windows standard "my documents".
# Error: WindowsError: 2 #

Last edited by Ekenryd : 08 August 2011 at 04:19 PM.
 
Old 08 August 2011   #5
awesome but I just spent 5 minutes trying to find teh link to download. Is it on that page?
 
Old 08 August 2011   #6
hahah I was doing the same until I realized that you gotta copy the python script into Maya directly and then will install it automatically ,,..
__________________
LDEA Kon Kuatica
 
Old 08 August 2011   #7
Originally Posted by Ekenryd: Found a UI bug. Maya 2012 hf3, win7.

Thanks for trying it on Windows . It it just the UI that screws up? Does everything else work?
I haven't tried any of the tools on Windows but I will get hold of a Windows license next week and test it out. The UI is standard QT but I must have missed something.

I will work as fast as I can. I have a lot I want to put in the pipeline and currently working on a "Warehouse Resources" page where 3. party models and shaders can be downloaded. but BUGS must have a higher priority - the UI will be fixed soon!


as SePu said the download, install and setup all happens at once when running the 4 python lines of code

I'm sorry you guys that the install procedure is not so straight forward as I have hoped. I will re-arrange the page and try to make it more clear.
Check back on 3DG.DK in a few minutes and It should be fixed

Originally Posted by Ekenryd: More bugs: I canīt move the browser/create windows, and I think the button to close the windows are out of screenview, so therefor I canīt close the windows :/ (you can see that on the screenshot too)


Strange... I hope that QT isn't so different on Windows. It should be platform independent but then again I must have screwed something up.

Have anyone tried it on linux?

Last edited by cesboa : 08 August 2011 at 04:29 PM.
 
Old 08 August 2011   #8
Maybe itīs my maya, I have a ton of different scripts. But nothing that should affect QT functionality really. Someone else with win7/2012 maybe can report if they have the same bugs.

Other than that, really looking forward to using this, it seems very clean and thorough
 
Old 08 August 2011   #9
Originally Posted by SePu: hahah I was doing the same until I realized that you gotta copy the python script into Maya directly and then will install it automatically ,,..


ah - ok got it now.

cesboa - if you're looking to test it in Windows, grab Parallels Desktop and install the Maya demo in there - that's what I do. Just make a snapshot before you install it and you can roll back when the demo times out and install again.
 
Old 08 August 2011   #10
Originally Posted by cgbeige: ah - ok got it now.

cesboa - if you're looking to test it in Windows, grab Parallels Desktop and install the Maya demo in there - that's what I do. Just make a snapshot before you install it and you can roll back when the demo times out and install again.


Yes, it seems like I have to test it on windows.
As you know macs aren't bundled with windows - is it's a license to MS issue I'm referring to I'm sure we have some xp or vistas license at the office, I'll check monday and get working on fixing the QT issues on Windows.

Great tip on the snapshot thing, then I don't have to lock up a Maya license for testing
 
Old 08 August 2011   #11
ya, that snapshot trick works for all Autodesk 3D apps.

i'm not sure if it's a bug or not but the assets import and the textures aren't linked to the copied textures, they're linked to the originals.

great work though - this is exactly what I've wanted for a while now.
 
Old 08 August 2011   #12
Originally Posted by Ekenryd: When I click reveal warehouse I get the following error. I just put the warehouse in a subfolder of the windows standard "my documents".
# Error: WindowsError: 2 #


Oooh That must because it trickers the "Finder" on OSX hehe... sorry. I will find a more cross platform solution.

And then I think the "Preview" icon feature would also suck on Windows and Linux because it trickers the "Preview" on OSX..

So sorry you guys, as I said early beta... may to early :(
But no worry, everything will be fixed asap. Just unload the plugin and forget about it for a few days
 
Old 08 August 2011   #13
Originally Posted by cgbeige: ya, that snapshot trick works for all Autodesk 3D apps.

i'm not sure if it's a bug or not but the assets import and the textures aren't linked to the copied textures, they're linked to the originals.

great work though - this is exactly what I've wanted for a while now.


Yes you are right about the texture link issue...
But I have thought of that . When exporting I can't change the path because it hard to revert in the opened document.
But there is an "Set Texture Path To Project (On imported Objects" feature in the browser. It changes the texture paths to the current project source images folder (where textures also are copied to).
But it sounds like it's not working... Have you set the project before importing assets?
I will test it out give me a few minutes

Edit: I have tested the texture issue you are talking about. It's working at It should when I create/set a maya project first.
On import:
- The texture is copied from warehouse to project source images
- If the texture is found under source images the file note is updated to "source images/*File*"
If the texture don't exists the file node will note be changed - so is the textures correctly copied to the project source images?

Last edited by cesboa : 08 August 2011 at 05:13 PM.
 
Old 08 August 2011   #14
ok - I understand now - I think the behaviour of copying to the active project and relinking there is good. Leaves the master untouched. Loving this already
 
Old 08 August 2011   #15
Originally Posted by cgbeige: ok - I understand now - I think the behaviour of copying to the active project and relinking there is good. Leaves the master untouched. Loving this already


Thanks

This is just the first step, more to come

And for you Windows users I will fix the UI issues as soon as possible!!
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright Đ2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 06:50 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.