Outliner 2.0 Scene Management tool

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
Old 04 April 2010   #46
Originally Posted by Gräck: So far I have experienced a few crashes/errors, could not reproduce them yet unfortunately.
Were there any crashes that didn't bring up the error report dialog? Do please send in any error reports that come up by the way, I'll look at all of them and see if there's something that can be done.
Well, maybe don't send them in if you find it's a recurring error

Quote: One bug I have noticed:

Each time you open/close the outliner, the position jumps up 1 pixel or so.
Hum I thought I had this covered.. I'll take a closer look at it. Thanks for reporting.
 
Old 04 April 2010   #47
Quote: Were there any crashes that didn't bring up the error report dialog?


humm, well I got one where the objects disappeared completely even if everything was set to unhidden, checking the filter affects viewports did get them back but I'm pretty sure it was a bug ... I saved the scene just in case, that was with version 2.0 through :-)

regard,
Martin
 
Old 04 April 2010   #48
Oh, another quite strange bug:

It seems the search field works with a timer, so each half a second or so it will select the objects you have searched for. I would find it better when the search field filters out the objects, and then you select them manually.

Now the bug:

Whenever you have searched successfully, and then select objects in the outliner, the selection timer is still active and keeps selecting the currently selected object
__________________
My Demoreel 2011:
http://www.youtube.com/watch?v=Gfq-4VoeAPU
 
Old 04 April 2010   #49
That's exactly right, it does work with a timer, set to 500ms. The main reason for doing this was to avoid serious slowdowns when there are a lot of objects in the scene and you're typing something in the filter textbox. And you're also exactly right on the bug, I forgot to stop the timer when it ticks. That'll be fixed.

I like your suggestion of having the text filter act like the type filter. I'll put that in for 2.1
 
Old 04 April 2010   #50
I've uploaded version 2.0.3, which addresses an issue with the access rights to the program files directory when you aren't logged in with administrator rights. All script files are now installed in the userscript directory. Uninstalling any pre 2.0.3 versions will still require admin rights, but after that, a regular user should be able to install it too.
I have also added a .NET Framework version check in the installer. I got two error reports which I suspect were caused by not having the 3.5 framework installed.
Oh and the preferences are no longer reset if you install a new version over an existing 2.0.x installation.

Another small change is that the email address in the error report form is stored, so you won't have to type it each time (well, I really hope there isn't too much use for this, that would be a bad sign )

Since this update doesn't give any real benefit to 2.0.2 users, the auto-update (or manual update through the options panel) won't pick it up.


So far, the error reporting seems to work really well. I have to say that it's definitely one of the features I am most content with. It makes tracking down bugs so much easier. I will of course investigate all reports: the next update will be a bunch of bugfixes.

Last edited by Pjanssen : 04 April 2010 at 10:55 PM.
 
Old 04 April 2010   #51
I don't know if this is related to outliner, but my Graphite Modeling Tools have suddenly stopped working completely. Means there does not appear any Ribbon when pushing the Graphite Modeling Tools button. I did not have this issue before, so it might be related to outliner, but I don't know. I really think Ribbon stopped working since I've installed and used the outliner.

Also there pops up a message when I open a scene which has been saved with outliner and I don't have outliner installed. This is a bit deterrent. Now I'm a bit afraid outliner could destroy something...
__________________
My Demoreel 2011:
http://www.youtube.com/watch?v=Gfq-4VoeAPU
 
Old 04 April 2010   #52
In risk of being kicked and shouted at
I´ve been using Outliner 1.61 for a while now and going to upgrade to the latest version. how do I uninstall the 1.61 version? Is it enough to delete the Outliner directory under Scripts?

Thanks for a great script!

Take care!
Matt
 
Old 04 April 2010   #53
Originally Posted by Gräck: I don't know if this is related to outliner, but my Graphite Modeling Tools have suddenly stopped working completely. Means there does not appear any Ribbon when pushing the Graphite Modeling Tools button. I did not have this issue before, so it might be related to outliner, but I don't know. I really think Ribbon stopped working since I've installed and used the outliner.
Hmm that does sound really odd. I don't really see a reason for the Outliner to cause this though, it does do anything with or to the Ribbon...
But just to be sure:
-Which 3dsmax version are you running?
-Does it happen when the Outliner is docked and when undocked?
-If you uninstall the Outliner, is the issue still there?

Quote: Also there pops up a message when I open a scene which has been saved with outliner and I don't have outliner installed. This is a bit deterrent. Now I'm a bit afraid outliner could destroy something...
Don't worry about the Outliner destroying the scene. The message is just to tell you that there are nested layers in the scene, but the Outliner isn't installed. That's all it does.
Again, just to be sure:
-Was the Outliner actually not installed when you got this message?
-Did you get it only once when opening (and saving) the scene?


Originally Posted by Massemannen: In risk of being kicked and shouted at
I´ve been using Outliner 1.61 for a while now and going to upgrade to the latest version. how do I uninstall the 1.61 version? Is it enough to delete the Outliner directory under Scripts?
The 2.0 installer will clean everything up nicely before installing the new version. You don't have to do anything manually.
The only thing that might happen is that if you've run the Outliner 1.61 before installing the new one, you will have to restart 3dsmax and run the installer again.
 
Old 04 April 2010   #54
edit: double post...

Last edited by Pjanssen : 04 April 2010 at 09:23 AM.
 
Old 04 April 2010   #55
-Which 3dsmax version are you running?
3ds Max 2011 32-bit on Windows XP

-Does it happen when the Outliner is docked and when undocked?
I think it doesn't matter. I have first docked the outliner, then I have used it in undocked mode on a second monitor.

-If you uninstall the Outliner, is the issue still there?
Yes. Again I'm absolutely not sure if the outliner is even the reason for this. It could also be a strange setting I've missed or so. I don't know. I have even tried to load a new UI scheme and tried to remove the 3dsmax.ini. Nothing did help.

-Was the Outliner actually not installed when you got this message?
Yes, that is correct and supposed to be so I think.

-Did you get it only once when opening (and saving) the scene?
Yes, resaving the scene with outliner uninstalled removes the message popping, so that is fine.
__________________
My Demoreel 2011:
http://www.youtube.com/watch?v=Gfq-4VoeAPU
 
Old 04 April 2010   #56
Just found kind of a bug. I am using 2.0.2 version

When i select objects and then rightclick/add selection/new layer the layer goes over the objects, that wouldn't be a problem, but when you start typing it goes offscreen and i dont see what name i am typing. Luckily i can type without looking at it but its kinda anoying.

Here is the image example

http://img340.imageshack.us/img340/9214/39304073.jpg

happens both docked and undocked.

edit: By the way is it possible to have nested groups ih hiearchy mode? Not like group in group but some sort of a fake just for the outliner :P
__________________
It is a poor artist who blames his tools for his work.

- Jeremy Birn

Last edited by DarkNemos : 04 April 2010 at 04:30 PM.
 
Old 04 April 2010   #57
@Gregor: it's really hard to say whether this is something caused by the Outliner or not. I guess you could try reinstalling max, and see if the ribbon works again. Then install the Outliner and see if it does anything to the ribbon...

@DarkNemos: Thanks for reporting this strange bug


I just found some really weird behavior whilst chasing a bug reported by a couple of people. The Outliner consistently crashes on opening if you've just performed an undo! Even if you hadn't opened the Outliner during that session yet. Makes no sense at all!
 
Old 04 April 2010   #58
Originally Posted by DarkNemos: edit: By the way is it possible to have nested groups ih hiearchy mode? Not like group in group but some sort of a fake just for the outliner :P


whilst i do find this idea interesting, i don´t know if it would be a good idea to give the outliner more features, that make the scene depend on having outliner installed. as far is i understand it, right now it doesn´t matter whether if the person you forward your scene to has outliner installed or not. With more and more features, that the outliner offers directly apart from just being a display-solution for operations, that max offers anyway, there could be a point, where the other guy would have to install outliner to make your scene work. I don´t know if i would like that.

But that is no offense...just my idea to it
 
Old 04 April 2010   #59
Yeah i agree, i didn't want myself to have a scene witch is dependent on a plugin installed. My thoughts were that if possible to be like on the nested layers, if you dont have an outliner installed you get a popup saying that you dont have that and continue working with the scene. If thats not possible i can live without the feature ofcourse
__________________
It is a poor artist who blames his tools for his work.

- Jeremy Birn
 
Old 04 April 2010   #60
I agree too, it should definitely not add anything to the scene ... just an idea, if something need to be saved let say nested layer, why not save it as an external file with the same name as the saved scene so if we open the scene and the outliner find a match file then it relink everything ?
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright ©2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 01:15 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.