Free procedural building generator: Building Generator v.01

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
Old 09 September 2009   #46
Awesome!

Cool. One of the greatest Maxscripts. Thank you so much!
 
Old 09 September 2009   #47
A little try... It's only my problem?



Mat

P.S.: ok... I read the same problem in your site....
__________________

VFX | CG Artist
available for freelance jobs
www.art2upz.com

RnD | Simulation Reel July 2014
3D Generalist Reel Winter 2012

Last edited by MatteoM : 09 September 2009 at 02:58 PM.
 
Old 09 September 2009   #48
Originally Posted by MatteoM: A little try... It's only my problem?



Hmmm....I've never seen a problem with floating roofs like that before. I was also unable to reproduce the error using your settings.....are you able to reproduce it on your side?
__________________
http://www.tysonibele.com
 
Old 09 September 2009   #49
Great job!

I wonder if you could integrate this building gen maxscript with Greeble?
__________________
CG Taiwaner
 
Old 09 September 2009   #50
Originally Posted by ivanisavich: Hmmm....I've never seen a problem with floating roofs like that before. I was also unable to reproduce the error using your settings.....are you able to reproduce it on your side?


I try again with the same setting, now is ok...



I try it on Max 2010 so I can analyze it with X-View... see image



I try the path setting... If I change some parameters is not very good... also to create a preview but the proxie is overraide on old (it's good is up-date the preview)...





I create a smooth path with a low point, but after the path change, is not very important, but if i will create a particular curve I can't? So I create another spline with more point and the result is... Max crash :(... (maybe is my workstation and my SO, now running on 32-bit, after I try on 64-bit)...






Another test... create palace with path and then i un-check path...



Sometime when you un-check path script give error and so re-run script... 1/10 time.

my first conclusion: It's a good script and i'm very glad to your share it. It's good the creation of group and some lement (example the door or ID on material -now I try some render- ) is not a mesh but a basic door so we can setting it. Maybe there are more work for devolepe it, and for future (if you have time) is very good

My english is not perfect, but I hope you can understand me.

Thank you for your time and have a nice day
Matteo
__________________

VFX | CG Artist
available for freelance jobs
www.art2upz.com

RnD | Simulation Reel July 2014
3D Generalist Reel Winter 2012
 
Old 09 September 2009   #51
Thank you very much for the detailed report, Matt....I'll be going through it soon to fix the bugs.
__________________
http://www.tysonibele.com
 
Old 09 September 2009   #52
Another fast test...

Create some spline and attach in only one... don't create correct (but I think is normal)





Detach spline and this is the result...



Ok, I try to create spline and apply the script. Save and close max. Open file and create a second spline and apply script... result. (strange is the big different of size of the element, ok the different, but is more in some case).



Do you try to create some palace and after use Proxie (Mental Ray or V-Ray)? I find this error, after I try on windows. (I try with default setting and change it)





Mat
__________________

VFX | CG Artist
available for freelance jobs
www.art2upz.com

RnD | Simulation Reel July 2014
3D Generalist Reel Winter 2012
 
Old 09 September 2009   #53
Originally Posted by MatteoM: Another fast test...

Create some spline and attach in only one... don't create correct (but I think is normal)


Yep...right now the script will only use the first spline in a spline object.

Detach spline and this is the result...




It's important to note that the size of your buildings is dependant on the length of each spline segment, when "normalize spline" is turned off.

So....if you have a spline with some verts, where some verts are spaced really far apart, and some closer.....you're going to end up with some HUUUUGE buildings and some tiny buildings.

If you find this undesirable, turn off "scale to fit" ....although if your segments smaller than the length of the building generated, you will get overlap.

The key to getting a good path setup is to create a path with vertices spaced out at approximately the length that you'd like a single building to be. So if you have a long road that you want lots of building to be on, for example, make sure that you have broken up the path with a number of verts that is equal to the number of buildings you want. 1 vert = 1 building, 10 verts = 10 buildings, etc.

Do you try to create some palace and after use Proxie (Mental Ray or V-Ray)? I find this error, after I try on windows. (I try with default setting and change it)





Mat


No, I haven't tested the script with vray/mr proxies yet...but I'll put that on my list now.

Note, that you should click on "combine meshes" under the generate button if you want to have the building collapsed into a single mesh (which will be necessary if you are doing Vray proxy mesh exports, for example).
__________________
http://www.tysonibele.com
 
Old 09 September 2009   #54
I do some test on Max 2009 and Mr Proxie... so, first time I use combine Mesh option and in the second time I convert one part in editable to poly and attach the rest...

With combine mesh have some problem on surface, with the second way create a good proxie.



Originally Posted by ivanisavich: It's important to note that the size of your buildings is dependant on the length of each spline segment, when "normalize spline" is turned off.

So....if you have a spline with some verts, where some verts are spaced really far apart, and some closer.....you're going to end up with some HUUUUGE buildings and some tiny buildings.

If you find this undesirable, turn off "scale to fit" ....although if your segments smaller than the length of the building generated, you will get overlap.

The key to getting a good path setup is to create a path with vertices spaced out at approximately the length that you'd like a single building to be. So if you have a long road that you want lots of building to be on, for example, make sure that you have broken up the path with a number of verts that is equal to the number of buildings you want. 1 vert = 1 building, 10 verts = 10 buildings, etc.


Thank you

Mat

__________________

VFX | CG Artist
available for freelance jobs
www.art2upz.com

RnD | Simulation Reel July 2014
3D Generalist Reel Winter 2012
 
Old 09 September 2009   #55
Woah...heh....that's a really weird thing happening with the surface when the meshes are combined I don't have a clue why it's doing that.
__________________
http://www.tysonibele.com
 
Old 09 September 2009   #56
The problem is only with Mental Ray because this renderer have a different analyze of normal. (I think for this )...



Mat
__________________

VFX | CG Artist
available for freelance jobs
www.art2upz.com

RnD | Simulation Reel July 2014
3D Generalist Reel Winter 2012
 
Old 09 September 2009   #57
superfine

Ty

Nice work, thanks for posting the script. Looking forward to see where you go with it !

Cheers !
 
Old 09 September 2009   #58
Great work from Matt here too, nice to see some thorough testing with screenshots helping the developer along. Putting back into the tool he got for free, that's ace!!! Keep up the team work.
 
Old 09 September 2009   #59
Hey Matt,

I think I've figured out what the MR problem was and have fixed it (the fix will be in the next release, which is coming out soon). It was an issue with the scale of the buildings generated, when "combine mesh" is turned on.

Once the next version is out it would be cool if you could confirm that the problem is solved though, since when I tried to replicate it I was getting slightly different results (normals weren't black....the mr proxy simply wouldn't render, and it wouldn't dispaly in the viewport properly).
__________________
http://www.tysonibele.com
 
Old 09 September 2009   #60
Ohh man, no words for this. Just awesome, Thanks for share with us.
__________________
Radeon
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:00 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.