Question about roulette animation.

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
  2 Weeks Ago
Question about roulette animation.

Dear all,

Recently I restarted 3ds max again, I used 3ds Max trial version 2018 trying to make a roulette spinning animation like this one:https://youtu.be/q0wJ9-2IVGQ
I've set up the ball and the wheel's rigid body: ball: Dynamic, Wheel: kinematic, key frame the wheel spinning for 100 frames,
when I active the massfx, the ball is falling to the wheel and just stay in the contact place, it doesn't spin with the wheel, I was wondering if I should set up themconstraint?
I was google for tutorial but couldn't find the info I need.
Please if anyone can help will be amazing.
Cheers.

Limi
 
  2 Weeks Ago
Hi all,

After few tests, I found the wheel's rigid body shape can't not fit the model properly (I've try different concave setting) cause the ball floating above,

[img width=590,height=300]https://s3.amazonaws.com/s3.cgsociety.org/forums/17/374017/o_npSSpjBvRGT7iaUozyxusyfm669lde.png[/img] [img width=430,height=300]https://s3.amazonaws.com/s3.cgsociety.org/forums/17/374017/o_aWepOoxb2WYnffA3tkXKgTLZaDUsY7.png[/img]
and I found my model's Friction may not be right setting, now the ball does spin a little, but not the result I want.
If anyone can point me some direction will be appreciate. Thanks.
( and 'm going to try using path animate and set the ball as kinematic. maybe will be another way?)
Cheers.

Limi
 
  2 Weeks Ago
you have to use Original

Not Concave
Not Custom
 
  2 Weeks Ago
Hi Vusta,
I did try to change to original,
but even when I change it, the ball still floating...
and, if I change it to static, the ball doesn't effect by the wheel spinning ( I saw an article mention about the dynamic object just effect by kinematic but not static object??)

[img width=499,height=357]https://s3.amazonaws.com/s3.cgsociety.org/forums/17/374017/o_0cxyGKhtkk870Mwjik8fOSziX6RNUU.png[/img]

Last edited by limih : 2 Weeks Ago at 09:18 AM.
 
  2 Weeks Ago
the complexed roulette spinwheel should be Original, Static, Regenerate (if you make mods as you go, must Regenerate to get the 'hull' updated)

for the ball, shape should be Sphere. It should be kinematic. So say you keyframed the ball
moving (being thrown) from frame 0 to 5, set Until to 4.
 
  2 Weeks Ago
actually, i think the spinwheel should be kinematic...throughout the entire sim....ie. you've keyframed it's rotation...

sorry, it's been awhile since i last used massFX.
 
  2 Weeks Ago
hi Vusta,

I've try both and the animation still not right, and when I set them both as kinematic, the ball stop the position in frame 5 and didn't simulate rest of frame,
just found when I set up the ball as dynamic and the wheel as kinematic, it does works but the ball seems start been effect after few small bumping,
still trying to figure out if it's setting problem or rigid body problem.
cheers.

Limi
 
  2 Weeks Ago
oh i see now....if the object is Static, then you can set to Original...but if it's Kinematic....the Original option is gone !!! Bummer.

I'll have a closer look.
 
  2 Weeks Ago
righto, here's a working roulette wheel...

https://1drv.ms/u/s!AvgNse7E8aaygxPa-iAV4m8wlR2E

01) any object you've keyframed...they have to be Kinematic
02) if an object is Kinematic, Original (ie. the original mesh shape) is not available...so you have to use Concave. Then you have to Generate in Physical Mesh Params (not the Generate Selected Physical Shapes). Play around with Mesh Details...you'd think setting it to 100% is the best
but...not necessarily so...in my example....I've got mine at 95% for the spinwheel
03) the 'ridges' you see I've setup as Kinematic and since their shapes are simple boxes...I could get away with using simply Box
04) The ball is Kinematic, keyframed from 0 to 3, therefore, set Until to 2...so at frame 3, MassFx takes over the sim.
05) normally you'd throw the ball onto the rim and let it roll down...but I got a 'nice' sim throwing to the centre..so I left it as is...
06) the outside walls are not moving so they are Static.

I don't know if you can make yours work cos your spinwheel is one mesh....it might be too complicated for massFX to handle, you might have to fake
the ridges with boxes like I have.

ps: I f**king hate gambling and casinos...they're just a bunch of a***holes, those scums should be wiped off the face of the earth.
 
  1 Week Ago
nicer version here:

https://1drv.ms/u/s!AvgNse7E8aaygxVGDnNLbv5QsSI7

 
  1 Week Ago
Hi Vusta,
Wow that's cool, I might try to change the setting and the models again and try ur way see id they're working,
so I guess maybe I need some invisible rigid instead the real wheel for helping the ball sim its movement.
Thank you so much!
Will update if it's working with my model.

P.s, I do not like scum too, and all those shit things are because ppl have no self control and greedy. I don't mind if ppl play for fun.
(and the good thing is u're in Aus, even though there has lots of casinos, but also u have plenty of natures all around u, what a amazing country
 
  1 Week Ago
Hi Vusta,
I 've seen ur model (big help, truly thank you!)
Seems like I have to separate the wheel's each part as different objects for correcting the physical material,
rebuild the model now, will see if it's working after all separately. update later.
Cheer.

Limi
 
  1 Week Ago
Hi Vusta and all, me again,

I tried to use ur setting in my model but it's said the model has a plugin.

[img width=364,height=142]https://s3.amazonaws.com/s3.cgsociety.org/forums/17/374017/o_uRXb6DLSQpViaIPWkNUNvscHqAO6Ix.png[/img]

Cause my max doesn't have any plugin, so I was wondering if possible use default system to build it?
I've change my model and use separate poly to make physical material but it becomes more funny sim. oops.
so, if u want to help me have a look the model?
https://drive.google.com/open?id=1Q...ABXdtP3T73RB6_k
Anyway still trying to figure it out.
Cheers.

Limi

Last edited by limih : 1 Week Ago at 09:05 AM.
 
  1 Week Ago
nah....it's just a spurious message re massFX....I did the file from scratch....no 3rd party plugins...
i think it's because you haven't got update 3 (2018) applied...but it should still just work...
 
  1 Week Ago
Hi Vusta,

Yes it 's working, I 've try to put the setting to my model but somehow the result looks still wrong in my model, that's why I thought it has plugin.
I'm trying the setting in different model now.
hopefully it's working.
Really thank you a lot.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:37 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.