2014 GPU AO crashes mental ray

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

REPLY TO THREAD
 
Thread Tools Search this Thread Display Modes
Old 04 April 2014   #1
2014 GPU AO crashes mental ray

I followed this video; https://www.youtube.com/watch?v=wG183KmxlKs
but whenever I try to render mental ray just crashes with a non-specific error. Anyone else having problems with this? I'll post the error message later.

Thanks.
 
Old 04 April 2014   #2
Your GPU must have enough VRAM to fit the entire scene, is that the case?
 
Old 04 April 2014   #3
I tried with a sphere on a plane in a fresh scene. My gfx card is a nvidia quadro 4000, 4gb ram. You'd think this would be good enough, or? Maybe drivers are old or something.
 
Old 04 April 2014   #4
Originally Posted by catche: You'd think this would be good enough, or?


Should be, but then again this is Max were talking about
 
Old 04 April 2014   #5
Installing the latest drivers should help.
 
Old 04 April 2014   #6
Yeah thanks, I'll attempt this over easter.
 
Old 04 April 2014   #7
Update: it did fix it and boy is gpu ao fast. However, would be nice to be able have more control over it, strange that they didn't add parameters for it (or did they?).

Is anyone using this in production yet or is it buggy/ineffective somehow? Only issues I have with it so far is the lack of settings and that it some times fails rendering it and spits out a black image immediately instead. Believe that last one is caused by having more than one max open at the same time though. Also curious how this will behave on the farm.
 
Old 04 April 2014   #8
Originally Posted by catche: strange that they didn't add parameters for it (or did they?).


They didn't, but there is someone who did:
http://www.infinity-vision.de/page/ro_menue
 
Old 04 April 2014   #9
Yeah I know about render optimizer by Thorsten Hartmann, he spams it everywhere
But I'm a bit reluctant to use 3rd party software since I'm not certain it won't mess anything up as other software we've used has. Isn't it possible to just add more strings?
 
Old 04 April 2014   #10
It is:

Strings


Other than that, it isn't oficially supported by Autodesk, and this is the reason it doesn't have proper UI exposure. In other words - if it works, good for you, if it doesn't... that's life...

Last edited by moulder6 : 04 April 2014 at 11:53 AM.
 
Old 04 April 2014   #11
Thanks. I miss having the option of excluding IDs though...

After having played around with it for a few hours it seems kind of useless to be honest. At least on my setup it fails to render (quick black render) whenever the scene gets a little heavy. Tried playing with different settings but couldn't get it to render in those scenarios.

Last edited by catche : 04 April 2014 at 08:28 PM.
 
Old 05 May 2014   #12
Originally Posted by catche: Yeah I know about render optimizer by Thorsten Hartmann, he spams it everywhere


And thank him for that very much! I have no idea how anyone uses Max with Mental without Thorstens Optimizer.
OK, now you can input strings manually, but i's so much easier with Optimizer.
 
Old 05 May 2014   #13
Originally Posted by catche: Thanks. I miss having the option of excluding IDs though...

After having played around with it for a few hours it seems kind of useless to be honest. At least on my setup it fails to render (quick black render) whenever the scene gets a little heavy. Tried playing with different settings but couldn't get it to render in those scenarios.


I guess you run out of memory on the GPU, and since it doesn't have a CPU alternative to fallback to it renders black.
 
Old 05 May 2014   #14
hi

do you shure, you use the render element as first element? The tutorial works only, if the Render Element the first in the List, or you must set the right Framebuffer Number in the String Option. For this Problem i have added this in Render Optimizer, and RO set for you the right Framebuffer Number.

PS: It give a new String Option in RO V4: "GPU AO - Filter".

mfg
hot chip

Last edited by thorsten hartmann : 05 May 2014 at 09:27 PM.
 
Old 05 May 2014   #15
Originally Posted by thorsten hartmann: hi

do you shure, you use the render element as first element? The tutorial works only, if the Render Element the first in the List, or you must set the right Framebuffer Number in the String Option. For this Problem i have added this in Render Optimizer, and RO set for you the right Framebuffer Number.

PS: It give a new String Option in RO V4: "GPU AO - Filter".

mfg
hot chip


Hi Thorsten

Yes, I'm sure of this. I've been testing it for several hours, testing different settings and getting it to render most of the time. It's just in certain more complex scenes where it comes out black. In those scenes, it will work if I isolate just a few objects, however.

What does "GPU AO - Filter" do?

Thanks.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 08:53 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.