Time slider scrubbing very tedious

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 08 August 2013   #1
Time slider scrubbing very tedious

Hello,

I have trouble with scrubbing through the timeline. I have 6000 frames animation and whenever I scrub through the timeline it skips over a 100 frames. Cant assess the quality of the animation. Tried turning off everything and also tried wireframe mode, didn't help at all.

Please advise.
__________________
Thanks all.
 
Old 08 August 2013   #2
3+ minutes is a pretty long timeline, no doubt. Can't you make it shorter more manageable?

Think about what is going on all these things add up to slow your system down:
1. how heavy is your scene geometry? If you are just previewing the animation, use simple proxy shapes to replace your render geometry. It can be helpers, boxes, low poly teapots, or even optimized scene geometry.

2. are you displaying any textures? Turn all of these off it you are. In fact better yet, not even have them in the scene so max doesn't even think to call them for one reason or another.

3. Particles, if you are using them disk cache them to a fast drive. (ie SSD or some form of ram drive)

4. Same with simulations, if you are using viewport previews make sure the caches are on a fast drive AND the viewport preview settings are as low-res as possible, just enough to give you an idea of what is happening.

5. If you never see it or use it, get rid of it. If you have things, hidden or not, that you don't use them, it can be any type of scene object, backup your current scene, then clean house. Keep your scene as clean as possible. Extra stuff takes extra resources.

Turn off/on adaptive degradation and see how max behaves. With it off max will try and redraw everything all the time. Turning it on, depending on your settings, should give you more manageable scrubbing/playback.

Try previewing in wireframe or flat shaded too.

Like everything have to learn how to scrub too. The more you do it the more you will notice how to do it without diving max into a stall. Particularly when you are using resource heavy geometry or particle systems.

Hope that helps.
__________________
poof ~>Vimeo<~
 
Old 08 August 2013   #3
Hello Johnny,

Everything is off. I just have a viewport background image and a space ship that is just flying in. I am checking on the animation of the space ship that when I am having this trouble. I have a lot of pflow objects and also fume grids in the scene, but they are all turned off and hidden from the scene.

Thanks Johnny.
__________________
Thanks all.
 
Old 08 August 2013   #4
Well a background is a texture and if it is a large file, well ya know like I said earlier, turn it off or get rid of it.

How many polygons is the ship?

A lot of this stuff depends on your machine specs too, you know. Graphics card and ram mostly.
__________________
poof ~>Vimeo<~
 
Old 08 August 2013   #5
Turning off the viewport background didn't help and the ship is 3,424,771 polys. While I was working on animation sometime back it was real smooth, it is after came back after I completed all the fume works this happened.
__________________
Thanks all.
 
Old 08 August 2013   #6
That is why I wrote what I wrote earlier Did you do any/all that stuff or at least look through it? Number #5 in particular. Are you using any of the fume or particles at this moment? No, then backup and get rid of it. Name your backup file appropriately and clean out your scene. You can always bring that stuff back in later. It is totally possible that one of those systems is calling in the background.

You kinda have to learn how troubleshoot this stuff yourself as only you know what you have done to the scene.

3.5 million polys is not light, it is not really heavy either, but you could replace that heavy geo with a proxy object of similar shape for under 1000 easily, if it is good enough I bet you wouldn't notice the difference look-wise through 99% of your timeline. Why model nuts and bolts if you never see/use them, ya know what I mean?
__________________
poof ~>Vimeo<~

Last edited by JohnnyRandom : 08 August 2013 at 12:28 AM. Reason: clarification of text
 
Old 08 August 2013   #7
Re-checking everything. I have to bring it down under 2500 frames. While working on the fume stuff and short animations I just choose a random frame and start working from their onwards and then at the end I re-work on the timings. That's my kind of workflow, That's what created all these troubles.
__________________
Thanks all.
 
Old 08 August 2013   #8
I don't do enough particle work to be intimately familiar, but as mentioned before, there are some things in Max that get evaluated even if the object is hidden from the viewport. Your best bet to bring those framrates back up is to temporarily remove the items you don't need to see while doing the animation and then bring them back when you're done. To clarify, remove them from the scene completely, don't just hide, save selected and delete or whatever you need to do!

Also, closing & reopening Max can be a good troubleshoot task every now and then, starting from a clean slate can be helpful, and also sometimes I manually do GC() or freeSceneBitMaps() in the listener window to try and clear out some excess memory.
__________________
| Twitter | LinkedIn | JCanimator.com |
 
Old 08 August 2013   #9
Hello James,

I was trying out what Johnny & you mentioned about deleting the scene objects and bringing them back later.

I have a lot of pflow systems and 5 FumeFX grids in the scene, I am just confused that I would mess it up totally. I believe deleting all the pflow systems would clear up everything, which I was trying a few minutes before and which froze up max.

Long time back I remember I had the same problem with another project which was caused only when the Pflow editor was open and it worked perfectly when it was closed.
__________________
Thanks all.
 
Old 08 August 2013   #10
Does disabling the pflows provide any better performance than just hiding them?
__________________
| Twitter | LinkedIn | JCanimator.com |
 
Old 08 August 2013   #11
Actually it is hidden and also disabled, didn't help at all.
__________________
Thanks all.
 
Old 08 August 2013   #12
what are your specs?

just interested
 
Old 08 August 2013   #13
Whatever his specs are, 6000 frames and PFlow and FumFX are way too much.

Quote: Actually it is hidden and also disabled, didn't help at all.

Doesn't matter, it's gonna be calculated anyway.

Try animBoost
http://www.scriptspot.com/3ds-max/scripts/animboost
 
Old 08 August 2013   #14
Here are my specs:

Core i7 2.66Ghz
24 GB RAM
240 GB SSD
Nvidia GTX 260 2GB

Will try animboost and post the results.
__________________
Thanks all.
 
Old 08 August 2013   #15
Hi J. Schreyer,



I was checking on the Animboost script, but I cant find the animboost category in the "customize User Interface" dialog. I am using Max 2014 and I copied the 2 folders to 3ds Max 2014/Scripts folder.
__________________
Thanks all.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 04:06 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.