Snapping Tool Changed?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

 
Thread Tools Search this Thread Display Modes
Old 07 July 2013   #1
Snapping Tool Changed?

Why did autodesk change the way the snap in 2014 worked prior to its dozen of version of max. The latest snapping tool sucks horribly now. Does anyone else have this problem?

You can no longer snap on a single axis?
__________________
____________ ___ __ _
John A. Martini
JokerMartini@hotmail.com
www.JokerMartini.com
 
Old 07 July 2013   #2
I don't have it in front of me, but surely you can check "Use Axis Constraints" in the snap options? I remember testing it out and it seemed fine, although a little different.
__________________
www.psvisuals.com - 3D Visualization and Content Creation
 
Old 07 July 2013   #3
Yep, snapping does not work for me in perspective views either. Well... it does, but only extremely rarely... each one of 5 attempts or so...

This is my first day with 2014 in production, and half of my hair is already torn out... Second half will fall out on it's own once i realize that SP2 will take ages to be released like SP1 did, and it will still probably leave a lot of things unfixed. As much hope as i had for this release, it is all now gone.
 
Old 07 July 2013   #4
Yeah, you can snap just fine, just tried it. Gotta make sure Use Axis Constraints is on, then it works just like always. One neat thing I see now is that if you click in the center of the circle (which appears on the gizmo when snapping) it will snap on all three axes at once. So with a single click, you can snap to either 3, 2 or just 1 axis at once, depending on where you click the gizmo.

It's also working consistently and in Perspective view, as well as Orthographic and others like Top and Front.
__________________
www.psvisuals.com - 3D Visualization and Content Creation
 
Old 07 July 2013   #5
I got axis constrain on and yet it doesn't work.
 
Old 07 July 2013   #6
You're dragging on the axis arrows right? Not the centre circle?
 
Old 07 July 2013   #7
To me it's working just fine. As Decency said pay attention to where you click on the gizmo as there is the little circle in it's center and with snap it uses all three axis, and that's a good thing.

Also, they finally corrected a major source of annoyance in snapping for a lot of people, now if you turn snap on on the fly, it uses the pivot of the object as the source of the snap and not an arbitrary point anymore. This is very good when objects are far away and you need to zoom to the see snap target.

Last edited by Eugenio : 07 July 2013 at 01:23 PM.
 
Old 07 July 2013   #8
using 3dsmax design 2014, same problem with jokermatini and rawalache here, 2.5d snap works like 3d snap in plan.
 
Old 10 October 2013   #9
Hm! Something wrong with the snapping now :(

Seems that snap radius doesn't work, if i start on the gizmo. But work if i freeze selection and start not on the gizmo.

Feels like a bug introduces with SP3, isn't it?
 
Old 03 March 2014   #10
I realize this is an old thread, but for me, the problem with the new snap tool is that when I have a group of verts selected and I want to snap to some other vert (not selected) using one of the selected verts (but also moving the other selected verts in relation to each other), it tends to average all the verts when it snaps if the vert I want to use resides within the gizmo. It will work if I zoom in far enough so that the vert is not in that space, or if I shrink the gizmo, but these are not exactly conducive to speed.

Before, if you could see the snap preview, you were golden. It just worked. Once the snap preview is locked onto the vert you want to move (again, with additional verts selected), it would use that as the point which to snap to the target vert.

Not so much anymore. Bare in mind I've tried this with the default settings and now I currently have the little box ("Center Box Handle" under the Gizmos tab) turned off and this has helped a bit, but I still need to zoom in pretty far to get this to work properly.

So yeah, any help would immensely appreciated
__________________
_deleted
=======
Acura RSX
Maxda RX-8: Devil Mod {Carbon Drip Edition}
Toyota Celica Custom
Bugatti Veyron
 
Old 03 March 2014   #11
I just toggle off the transform gizmo for that sort of situation. It's always gotten in the way sometimes, so a quick press of x gets it out of the way. Or whichever hotkey it's on these days.
 
Old 09 September 2015   #12
I have the same problem. And I hope there is a way to turn off the center axis in snapping. Pressing on X is helpful, but not the wondful solution.
In the MAX2012, the center circle is much smaller then the snap radius, so it makes no trouble almost. But after 2014 version, this circle is too large. When my mouse get close to the selected vertex (just one for example), it will touch the center circle, and change the snap axis which I chose into no axis constrians. This is why I want to turn off the center axis in snapping mode. Or if it could be much smaller such as MAX2012, that will reduse the misoperation at least.

Last edited by fenglingyu : 09 September 2015 at 02:43 AM.
 
reply share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 11:51 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.