Tips on animation performance

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2013   #1
Tips on animation performance

Hi,

Im trying to figure out what the biggest performance killers are while animating in 3ds Max (2013) so I can improve my Animation workflow...with framerates like 0.5 fps and preview creation times of 10 Minutes for a 20 second animation its really no fun...
Some more infos on the scene Im working on right now:
-Around 500.000 polys
-No rigging, just animated transforms, animated camera, some path deformers and noise modifiers

What Ive heard of or tried out so far...: turning off modifiers, setting all turbosmooth modifiers to render iterations, turning off nitrous, using dummy objects for animation...

Whats your experience? Do you have any tips or advice?
 
Old 06 June 2013   #2
Well, you can try gPoly. It has some limitations, so you better consult the 3dsmax help.
Other that that, i found that turbosmooth still had an performance impact even when
set to render-iterations only. So i turn them off in viewport completely.
Use strictly editable-mesh and avoid anything that converts to a poly-mesh like:
Poly-select,editPoly or editablePoly.

Consider using 3dsmax2014. Overall performance (not only animation) is much better.
__________________
Meli
 
Old 06 June 2013   #3
First of all: Thanks for the advice!
I already heard of the improved performance in max 2014, so Im really looking forward to getting an upgrade at work, unfortunately that wont happen mid-production...

Ive yet to figure out a better workflow.
Right now, beeing on some very tight deadlines, I just like to go from modelling to animation keeping everything as flexible as possible. Which means, keeping the modifier stack intact as long as possible, to be able to make changes quickly, if the client desires it.

Thus I do have some editable poly, poly select or turbosmooth modifiers active in my stack, which I need...
 
Old 06 June 2013   #4
i had the same problem with 2013. deformable animated objects kill playback. it was fixed in update 6 but that screwed backburner for me so then i didnt use 2013 anymore. In 2014 its no longer a problem, but editpoly modifiers on animated deformations kills playback too. and i realy dont know a way around it. maybe edit mesh instead. turbosmooth isnt that slow but edit poly is.

but unless you install update 6 you wont have playback with deformable objects even if editpoly and turbo smooth are off.
__________________
Home Page
 
Old 06 June 2013   #5
Originally Posted by insertmesh: Hi,

Im trying to figure out what the biggest performance killers are while animating in 3ds Max (2013) so I can improve my Animation workflow...with framerates like 0.5 fps and preview creation times of 10 Minutes for a 20 second animation its really no fun...
Some more infos on the scene Im working on right now:
-Around 500.000 polys
-No rigging, just animated transforms, animated camera, some path deformers and noise modifiers

What Ive heard of or tried out so far...: turning off modifiers, setting all turbosmooth modifiers to render iterations, turning off nitrous, using dummy objects for animation...

Whats your experience? Do you have any tips or advice?


So.. you don't have anything that deforms.

Then try to cleaning Slate Material Editor and environment map.
You can also check if your material is too complicated.
Try "object color" mode with "shaded"
 
Old 06 June 2013   #6
Quote: So.. you don't have anything that deforms.


Sorry, that wasnt quite true...
I actually also have rigged and skinned the mesh...
Im not 100% sure, that we have update 6 installed, so Im going to have to check that.
Turbosmooth is definitely killing the performance when on.
The only reason I have it on in the stack is because I want the mesh to be partially displaced and I cant do that with a Vraydisplacement modifier, unless I unwrap the model and paint the displacement map, which I didnt need to , because all maps are procedurally created...
 
Old 06 June 2013   #7
cant have everything I guess...
 
Old 06 June 2013   #8
A big killer of frame rate is having the material editor open, or having materials visible in viewport. you can turn them all off by going to:
View> Show materials in viewport as> turn off maps'n shit

Also you will have increased performance if the turbosmooth modifier is set to 'off in view' over just setting render iterations.
__________________
Debris Maker
Portfolio
Blog
 
Old 07 July 2013   #9
sorry for the late reply...just wanted to update that turning turbosmooth to "off in viewport" actually brings the biggest boost in performance overall (same goes of course for other heavy modifiers like flex etc.)...
 
Old 07 July 2013   #10
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 07:25 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.