Most Annoying feature in max 2012, triangles. help please

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 06 June 2013   #1
Most Annoying feature in max 2012, triangles. help please

Hi guys, I'm so new to CG, like less than a week has passed since I started to learn.
so here is my problem, I'll appreciate if you help me get rid of this annoying problem.
thanks.

look at those awful triangles:


I didn't make, them, whenever I draw a polygon it's triangulated instead of quad.

in the same project I create a cylinder and create a new poly:



now I go to vertex mode and try to pull a vertex, and look what happens:


when I select that edge and push CTRL+BACKSPACE it removes the edge, but it still won't make the poly plane:



I searched everywhere, I used Quadrangulate script I found, but it didn't do anything but removing and recreating the same object with same properties.

What should I do to not see these triangle anymore in the future?
 
Old 06 June 2013   #2
smoothing groups
 
Old 06 June 2013   #3
Originally Posted by CompanionCube: smoothing groups

IDK what's that, can you explain more please?
 
Old 06 June 2013   #4
Smoothing groups tell the program which polygons are supposed to be one smooth surface, so if you create a cylinder even if it has like 8 sides it will still look smooth and round. If you removed the smoothing groups it would look faceted and you could see each face. When you create new geometry (extrude) it does not have smoothing groups applied to the new faces which make them look faceted.
__________________
The Z-Axis
 
Old 06 June 2013   #5
Originally Posted by mohammadmdp: IDK what's that, can you explain more please?

When someone throws terms at you that you don't understand, try the program's user reference. Great resource with lots of explanations and someties step-by-step guides. Saves a lot of time.
 
Old 06 June 2013   #6
Thanks, so you suggest I never use cylinder anymore?
but I think I have to, because I need to create a hand, and I think I must use cylinder to create a hand. don't you think so? what to you suggest then?

What should I do to create objects even if they are rounded and never see triangles?
 
Old 06 June 2013   #7
Quote: Thanks, so you suggest I never use cylinder anymore?
No he didn't, he just used that as an example.
Quote: What should I do to create objects even if they are rounded and never see triangles?

Apply smoothing groups.
 
Old 06 June 2013   #8
it still didn't solve the problem, applying smoothing groups just makes surfaces smooth, and removing them won't remove the line in the middle of every polygon that divides them to two triangles like the image you see above, and CTRL+BACKSPACE won't remove it either even after removing smoothing or adding.

I just want plane flat polygons like old 3smaxs, why the hell did they make it like this? before it was better, I hate triangles.
 
Old 06 June 2013   #9
just upload the file. i don't know what your doing but this isn't a 3ds max issue, your just misunderstanding something
 
Old 06 June 2013   #10
Originally Posted by mohammadmdp: I just want plane flat polygons like old 3smaxs, why the hell did they make it like this? before it was better, I hate triangles.


Mesh geometry in Max has ALWAYS consisted of triangles, there never was something like a ngon/polygon with>3 vertices, that had'nt edges inside, they just are hidden from you.
With edit mesh, there was an edge visible/invisible toggle, with edit poly those inside edges are hidden from you altogether. The easiest way to proof this is going to Edit Poly->Edge subobject mode and activate "Turn edge Mode". This will display all the edges your geometry consists of, and you see - everything is built up from triangles...
This is because a triangle ALWAYS has it's vertices lying on imaginary perfect flat plane, whereas as soon as you have 4 or more vertices, the vertices might be pretty off from such an imaginary flat plane

To keep the current "flatness" of your quad/ngon, the only option is to transform the whole poly in subobject mode. As soon as you start moving individual vertices, you most likely will break that "flatness". This was always the case, but Nitrous might give you a more distinct display of the "non-flatness" of your polys...

BTW: this is the reason, many modelers prefer a "facet" display mode, which does'nt show smoothed faces, but the real face geometry shading. I even have a keyboard shortcut set to "Show All Edges Toggle", which lets me show all the internal, usually hidden edges as dashed lines if i want to
__________________

PowerPreview: High Quality Nitrous Previews for 3ds Max 2012|2013|2014

[ Free Download (ScriptSpot) ]

Home of The Frogs | Online Portfolio

Last edited by spacefrog : 06 June 2013 at 06:59 PM.
 
Old 06 June 2013   #11
The problem is your misconception on how polygon-meshes work and how they are displayed in the viewport. Everything in 3dsmax is displayed as a triangle mesh, because that`s the only thing your graphics-card can work with.

Take a look:
In the first image the extruded Face seems to be flat.

The second shows the triangulation of the face.You just can`t see the edge because of the shading across the triangles.

So, very likely you are just missing a display setting.

edit: Spacefrog response was faster and more eloquent, so please ignore this....
__________________
Meli
 
Old 06 June 2013   #12
scrimski, spacefrog,MGernot and everyone, thank you guys, I learned a lot.

now I understand why it's triangle because this is the main logic of graphic cards.

actually the reason why I'm asking this, is because I'm watching a video tutorial from Digital-Tutors, and I followed step by step, but suddenly I saw these edges which I don't see them in the video.

look, this is from the video, but it's not like mine at all, all of polygons are flat plane and quad:



idk why this happened to mine!
 
Old 06 June 2013   #13
I guess what you're seeing is how Nitrous displays faces. If you switch to directX things will look how they look in the video.
Hope this is what you're asking for.
 
Old 06 June 2013   #14
Originally Posted by pokoy: I guess what you're seeing is how Nitrous displays faces. If you switch to directX things will look how they look in the video.
Hope this is what you're asking for.


I don't know what is Nitrous, or how to switch to directx, I just launch the 64bit version of 3dsmax 2012 and I have nvidia g-card, but that's not the case. thanks anyway.

I think I just have to get used to it. I learned a lot guys thanks, I'll start creating objects with the imagination of triangles instead of quads from now on. I think that's better.

thank you all so much.
 
Old 06 June 2013   #15
Regardless of your graphics card, 3ds max can use different graphics systems. The one that's used by default is Nitrous and is what causes 4-sided polygons to be displayed that way, at least I remember there were many people complaining back then.

I'm quite confident the following will solve the issue, go to the menu, choose:
Customize > Preferences > Viewports > Choose Driver > Direct3D > OK > restart max

It hopefully works like expected then.

It's funny that most people forgot about this issue as it was one that caused many people to moan. I'm not sure if it has been resolved with the Product Updates they've released for max 2012 but I don't remember seeing it anymore in 2012 so it could be that they actually fixed it. If you didn't install the PUs it might be worth trying as well.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 10:01 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.