Show vertex colouring and NO lighting?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  04 April 2013
Show vertex colouring and NO lighting?

I'm trying to get my viewport to show just the vertex colours, no extra shading or lighting. It's proving difficult to get 3DS max to do "less"...

I want a retro video game look where there is no dynamic shading - just hand-panted vertex colours.

Examples of what I'm trying to achieve. These are screenshots from old video games;




I've got "Vertex Channel Display" checked, and I can see the colours are showing, but they're not exact colours I've picked.

Here's what I mean;





How do I achieve this look in the viewport? (Not render - this is a model for a video game)

I've also tried changing the viewport shading mode to "Consistent colours" which sounds like it would do the trick, but then the whole model turns white...
 
  04 April 2013
works fine here - vertex paint modifier, and "vertex color display - unshaded" (first button top left)
max 2013, nitrous viewport (Shaded)
 
  04 April 2013
Thanks Damjan, well I've checked I have everything set the way you said, and the colours are still washed out - although the shading has now gone, so that's a step forward.

 
  04 April 2013
A quick test here revealed similar problems with nitrous mode and vertex colors:
the vertex colors are displayed with incorrect color shading/gradients between vertices with the same color. IMHO, for such a task i simply would use the D3D display mode. It works perfectly and displays constant shading/vertex colors correctly

BTW: and i would disable gamma control for this
__________________

PowerPreview: High Quality Nitrous Previews for 3ds Max 2012|2013|2014

[ Free Download (ScriptSpot) ]

Home of The Frogs | Online Portfolio
 
  04 April 2013
Thanks spacefrog

Well I'm nearly tearing my hair out over this - I've switched to D3D viewport driver, had to disable hardware shading, and eventually got the same results as in my previous picture. They're still washed out on the object, even though the vertex colour panel shows the exact colour I picked.

Can you tell me what settings will show the true vertex colour?

Also I couldn't find anywhere to turn off "gamma control", even after Googling it...
 
  04 April 2013
ah - i overlooked your gamma..
check the attachment - if you set things like there it should work.. - but then again, if you plan to export your data to a realtime engine or similar, you could get problems as the colors wouldn't fit the viewport anymore (because of gamma correction)
i guess you would have to do (write) a gamma inversion script to correct the colors before output

should be 4 lines, just i dont know which ones
Attached Images
File Type: jpg vp.jpg (77.7 KB, 9 views)
 
  04 April 2013
Disable gamma, disable any exposure. Enable vertex colours without shading under the object properties (this is what the buttons in the vertex paint modifier do). That should work at least under DirectX, but I'm not sure about under Nitrous.
 
  04 April 2013
Guys, thanks for all your help. I think I've got where I need to be in the end. This was a very interesting experience.

damjan - you were right, although your approach "looks" correct on screen, the actual colour values it's assigning are not correct, and looks completely wrong in Unity (the game engine I'm using) BUT - thanks to your screenshot, I know where to disable gamma...

robinb - I tried disabling gamma - it works! But then the template images (including ones set as Viewport background) are too dark to use as geometry reference. But for colour picking reference I can always use Render / View Image File.
Oh and thanks for the explanation of how the vertex paint buttons just change those settings, that's useful to understand the software better.

I've discovered that even though the colours don't look right in the viewport, if I just trust it and import the model into Unity, it looks right.

I've concluded I can move forward like this, confident the values I'm picking with the colour picker are true, and disabling gamma for a preview inside 3DS Max if I need to.
 
  04 April 2013
Hmm. I don't use viewport background, I just use textured planes. If you make the textured plane fully self illuminated you should get the same colour.

I imagine there's a separate gamma setting somewhere for backgrounds you need to find and disable.
 
  04 April 2013
just add a 100%-selfillum material with Vertex Color map in diffuse to the mesh, and render it with anti-aliasing off. That should do the trick.
 
  04 April 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 02:16 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.