Dunno Where to post this- Hair Collision

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 04 April 2013   #1
Question Dunno Where to post this- Hair Collision

Hi, I am sort of new to animating Body parts in 3DS Max 2012, so I got a qyestion: I Tried EVERYTHING possible to make the Hair collide with the head of my Character, I followed the main Help of Autodesk , followed short Tutorial on how to set up precomputed simulation- but the Hair DOES NOT collide with the Sphere! It just Goes through, I dunno honestly wtf I've done wrong, but it seems I have all the .STAT files generated (checked in folder) and Yet the hair goes from front to the back of the head. Help much Appreciated.
PS. Dunno where to post this stuff, so I guessed the tutorials section would be fine- Please feel free to move if it's the wrong place, I couldn't see the support section. Thanks Before hand.
 
Old 04 April 2013   #2
Anyone? I rly need To have it by next Week, pls help if you can!
 
Old 04 April 2013   #3
Do you have a max file I can take a look at?
I've been working with hair a bit myself lately so I might be able to figure it out.
 
Old 04 April 2013   #4
Do you have "Polygon" and "Use Growth Object" checked for Collisions under the Dynamics rollout?
 
Old 04 April 2013   #5
If the object you're colliding with isn't the growth object then you also have to add it to the list of collision objects.

Also, I think some of the randomization features don't respect collision, like kink, frizz and stuff like that so those things can be causing it to go through objects.
__________________
The Z-Axis
 
Old 04 April 2013   #6
Yeah if you have a model for just the scalp, that the hair is applied to, then you have to add the character's mesh in the collision list. He said he couldn't also get it to collide with just a sphere though.
 
Old 04 April 2013   #7
Yeah, of Course, I chose Polygon and checked Use Growth Object, and Sphere and Checked again- None worked.
The File Uploaded: here
(tried To attach, it just Says "Uploading File(s) - Please Wait")
 
Old 04 April 2013   #8
Please, if Anyone- ANYONE knows the solution, help me, I Did hear of Advanced HairFarm Plugin, but it has been mainly released for Newer versions, besides you gotta pay for it via the internet, and I'm not prepared to do it at this stage.
I followed several Tutorials, and they all say use Polygon or Sphere, Use growth objects/ add the Extra objects, I did try all, and well nothing works.
Please, People of CG - You are my only hope!
 
Old 04 April 2013   #9
Maybe
Quote: Download not available

The download for this file has not been enabled. Only the user who uploaded it, can enable the download option.



Haven't used rapidshare. Is your quota here full? Maybe try dropbox.

Last edited by Ian31R : 04 April 2013 at 10:39 PM.
 
Old 04 April 2013   #10
I mocked up a quick dirty scene below:
Its just a ball brushing through hair/grass.
Hair Collision.zip

It was created in 3dsmax 2014 but I saved it as 2012 file.
I think that your problem might have been not having enough guides for the dynamics.

Download the file & open.
Set the Dynamics Mode to "Live"
Click Play.

Hope it helps.
__________________
Portfolio - https://www.behance.net/anthonyy
Animation - https://vimeo.com/user4968148/videos
 
Old 04 April 2013   #11
The download link not works (besides, I am using 3ds max 2011).

Have you tried cloth modifier?
I personally find hair and fur dynamics horrible (it' lacks weight, and every simulation behave like it's underwater).
If you have versions of the hair with planes, you can use cloth modifier to achieve very good dynamics.

One tip (whatever you using):
It is often pretty memory consuming if you try to make hair dynamics collide with rigged mesh, so to make things more easy for 3DS Max to handle, you can clone your mesh, collapse it to editable poly, delete every part of the body that won't collide with the hair (for example: legs, hands...), and then put a modifier "skinwrap", and add your rigged mesh.
That way the new (optimised) mesh will follow the rigged mesh.
After that (if you want to further optimise), you can do a "point cache", and delete the skinwrap modifier as-well.
__________________
Now it's the time to be extreme!
Demoreel
website
 
Old 04 April 2013   #12
Hi,
I'm sry that the Link is not working, it seemed to work for me, but I'm the Uploader, so maybe thats why.
Here's another link: http://depositfiles.com/rmv/4638209845547851
And yes, I'll check out the file you posted about hair collision.

Also, to d4rk3lf- how do I use skinwrap? cause I got the Rigged character (Bipeded one) I dunno will it work?
 
Old 04 April 2013   #13
Link still not working:
"No such downlodable file or incorrect removal code."

Try rapidshare, or something...

About skinwrap:
You can use it on pretty much anything.
Skinwrap is the modifier that forces one object to follow another object, and it does that by moving closest vertexs (or poly's) from reference object. Ofcourse, you'll need both objects in the same position at space, and with the same shape.
In you case, when you clone character, and delete unnecessary parts (also skin modifiers), you then put a skinwrap modifier and pick (within skinwrap options) your original rigged model, the skinwrap modifier will tell your new object to follow the vertices's of original object (where they move, the skinwrap will force your new object's vertices's to move)
That way, you have new (optimised) mesh which you will use for collision.

If it still turns to be slow, on top of skinwrap modifier, you can place "point cache" modifier, record the animation, and then delete the skinwrap modifier.
That will be even much faster.
__________________
Now it's the time to be extreme!
Demoreel
website
 
Old 09 September 2013   #14
Thanks to EVERYONE who helped me here- this is what I came out with:
http://forums.cgsociety.org/showthr...634#post7655634
 
Old 09 September 2013   #15
In my experience, hair and fur doesn't collide very well no matter what you do. I don't know why there isn't an option for increasing simulation steps or collision depth or any of that good stuff, at least there isn't as of max 2013.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 02:56 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.