uvw unwrap: can not select faces, only whole mesh

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 03 March 2013   #1
uvw unwrap: can not select faces, only whole mesh

I have an Editable Mesh with Unwrap UVW modifier
In the Edit window of the modifier, in Face sub-object mode
it is not possible to select a subset of faces ... either all faces or none are selectable

If I create another Editable Mesh (eg. from a simple Plane) then I can select single faces ...

As a workaround I broke the Editable Mesh into Elements, then applied the UVW modifier, then applied another Editable Mesh modifier and welded the vertices back together, this worked OK

Any idea why one Editable Mesh would disallow face selection?
 
Old 03 March 2013   #2
Yeah most likely you have "select by element" checked. Its a box icon that seemingly has nothing to do with it's actual function.

Since they redid the gui in the unwrap window it's easy to miss things like this. (Why I am still on max 2010/2011)
 
Old 03 March 2013   #3
Good idea, but that isn't my problem

"Select By Element" and "Select Element" is unchecked in both the flyout and the UVW Editor

This problem happens when I create an Editable Mesh (or Poly) from a Spline ...
 
Old 03 March 2013   #4
That's... not normal.

Just to be clear, you have an edit poly or edit mesh above the editable spline in the stack? Or you just have faces turned on in viewport and renderer?
 
Old 03 March 2013   #5
My stack looks like this on screen:

Unwrap UVW
Edit Poly (or Mesh)
Line

(there is no subobject selection in the poly/mesh)

Face sub-object mode is active on Unwrap UVW

I have been Unwrapping stuff all week, but this problem only occurs with Spline > Editable Poly (or Mesh)

(Planar Angle is unchecked also)
 
Old 03 March 2013   #6
What version of Max?...all bug fixes ...sorry PU's up to date? maybe better to post screens of exactly what your looking at.

For a more logical approach to unwrapping try .....

http://www.scriptspot.com/3ds-max/scripts/polyunwrapper

It may override your issue, and it's much easier to navigate than the default mess in unwrap uvw.
 
Old 03 March 2013   #7
I have tried this with 2011 SP2 and 2013 (PUs won't install)
On 2 different PCs (one new and one old both with Win7 x64 Pro)
And results are the same

After converting planar spline to Editable Poly it is impossible to select individual faces. You can only select the whole mesh.

It's as if coplanar faces form a cluster that can't be broken

I tried adding a UVW Mapping in Face mode, it worked in testing, but not in my scene.

Totally stumped now.
 
Old 03 March 2013   #8
Can you show a couple of screen grabs. It sounds like you're trying to select individual triangles from a big multi-sided polygon. You can't do that, you need to break it up into multiple polygons.

As a test you can try selecting all verts on the poly and connect. That will triangulate the poly. Then try the unwrap and see if you can select individual tris.

But I might be misunderstanding the issue. Normally you'd want to map a whole polygon as one anyway. Screens will help.
 
Old 03 March 2013   #9
You are correct

The workaround I found is to use Vertex sub-object mode and then Convert Vertex Selection to Face and then Break

This creates extra vertices

But the shape of the polygon requires breaking apart to make use of texture resolution

I still don't understand why some planar polygons can be selected face-by-face but not others

Is there no way to simply "unlock" these rigid polygons so I can select face-by-face and then break apart?

I also find it strange there is no way to edit the seams without working at the vertex level
 
Old 03 March 2013   #10
Hmm, that doesn't sound right one way or another. Again, a pic might help.

You don't need to break verts to make polys, you just need to create an edge. Select a pair of verts and Connect for example.

You can create seams at the edge level or select a poly and Detach Edge Verts.
 
Old 08 August 2013   #11
fix

i know it sux but

>file
>reset

this is the fastest way for me

sp3nce
 
Old 08 August 2013   #12
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 05:24 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.