Should we not use Exposure control?

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
  03 March 2013
Should we not use Exposure control?

When there is any pixel that has something to do with transparency and I have the exposure control turned on, I always see artifacts. (Either transparent planes are visible or matte objects are visible or white fog is black etc.)

I've had issues with cutout maps, opacity maps, fog, mist, matte shadow before, when MR Photographic Exposure Control is on but this time I turned on depth of field in a scene and there appeared some stupid contours around object edges which are in front of the background. And eventually that is, too, related with exposure control.

I believe this is the normal result of the transparency calculations under the effect of exposure ctrl. but, I haven't ever seen anyone other than me asking about this.
Looking at the possible occasions everyone should have problems frequently.
Am I the only person who has this issue or do you not use exposure control?

Turning it off solves all the problems and I actually don't turn it on anymore, but this time I have to set my light multiplier values to around 2% of the original values to compansate Furthermore it is a useful tool to have real life control over your scene illumination

Is there some value or switch to just wipe the entire transparency issues while Exp. Ctrl. is on, or should we not use it?

Last edited by Byteman3D : 03 March 2013 at 06:32 PM. Reason: Correcting grammar mistake
 
  03 March 2013
If you are using bitmaps for your opacity masks, check to make sure they aren't being gamma corrected (which would change their colors and cause problems) If you are using MR Photographic Exposure Control, they are being corrected, so you need to adjust for that with a Gamma and Gain node in your material.
__________________
www.psvisuals.com - 3D Visualization and Content Creation
 
  03 March 2013
But it happens even when you just turn on depth of field. Blurred edges infront of the background become a white contour.

look at the image. Left half of image is depth of field on, and right half is off. It happens even if the background is solid colour, and I even tried adding the colour or the bitmap as Gamma&gain input with all possible settings. Only gamma changes. There is always this contour.

 
  03 March 2013
This is an issue with non HDRI background images and having exposure control for BG images turned of ( there is an extra checkbox).
In short : Nitrous tries to blur/antialias the non-exposure controlled BG image with the exposure controlled rendered geometry. The result is that the highly lit geometry render spoils the nonexposure controlled BG image. The white noise is a result of that
You can try to turn on exposure control for BG images. Doing so, your non HDRI BG will turn totally dark, thus you can turn physical scale to unitless and crank up the scale value
Doing so you might be able to find a balance between BG and foregroud exposure ...
Applying Gamma&gain to the BG might be a way to achieve the same, but you have to enter insanely high numbers in the gain multiplier and its hard to control....
__________________

PowerPreview: High Quality Nitrous Previews for 3ds Max 2012|2013|2014

[ Free Download (ScriptSpot) ]

Home of The Frogs | Online Portfolio

Last edited by spacefrog : 03 March 2013 at 08:54 AM.
 
  03 March 2013
Thank you all for your valuable time.

And very special thanks to you, spacefrog, you've just spotted the issue which I long for finding a solution.

It seems "Process Background and environment maps" is my magic switch.
Although I'm aware of the switch, never occurred to me that it could be the key as for most cases, it just changed the background brightness to a level which seemed incorrectly darker than the default, off state, so I always left it off. Who could guess?!! that background, too, needs exposure adjustment.

I still have a question:

I created this simple scene you see above. Placed a daylight system, to have precise illumination. With 14-15 eV values, and mr physical sky at the back, everything is fine, however any HDR or bitmap file I have is very dark (even not visible) at this exposure value.
When I set the eV value to 0 or even -2 then the background is ok, but the objects are overexposed.
I tried to set the exposure of the hdr file during file selection I couldn't get it worked with any value or file.

It is always possible to set light value to a lower value like 0.02 or make objects darker, but I literally don't want to set a white wall with fluorescent attributes incorrectly just to compensate. What is the correct approach here?

Last edited by Byteman3D : 03 March 2013 at 11:38 AM. Reason: Still have a question
 
  03 March 2013
Set your system gamma(along with gamma input/output) to 2.2 This way you don't have to plug in any extra gamma/gain nodes. Just leave colour(diffuse0 maps at default in the 'open bitmap' dialogue and use the 'override to 1' radio button on all other maps: .hdr/.exr, normal maps, greyscale maps.
When you open your .hdr make sure the '32bit real exposure' box is checked. Now, set your MR exposure to unitless at around 80,000 and E.V to 14(as spacefrog mentioned) and try a render with process environment and background maps unchecked. Also, make sure 'aerial perspective' is unchecked in the MR sky settings.

It is a really bad idea to start setting lights and exposure values to crazy numbers to try and balance the lighting in the scene as this will break the physical accuracy and sort of defeats the purpose of using a linear workflow. And it is also what we had to hack back in the good old days of legacy lighting!
 
  03 March 2013
Originally Posted by musashidan: When you open your .hdr make sure the '32bit real exposure' box is checked. Now, set your MR exposure to unitless at around 80,000 and E.V to 14(as spacefrog mentioned) and try a render with process environment and background maps unchecked.


Looking at the help document on Physical Scale, I see "When you use this option, the renderer interprets all non-physical (standard) illumination values in units of cd/m 2 . If you use as a background image or texture map an HDR image with pixels correctly calibrated to cd/m 2 , it will be correct in the scene. However, if you attempt to use a low-dynamic-range photo such as a JPEG photo, it will appear too dark in the rendered output. (The renderer interprets a white pixel in such an image as "1 cd/m 2 " by default, which is darker than the deepest dungeon.) So you need to increase the output of the image to match a useful cd/m 2 value. The sky can be around 3,000 cd/m^2 ."

and " Unitless lets you define how the renderer interprets the illumination from standard lights"


Should I understand from the first statement that my HDR files are either not true HDR files or it should be calibrated? (Because they're dark unless I choose unitless and set it to higher values as you say)
 
  03 March 2013
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 03:09 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.