Vray flickering animation issue..help needed..

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 02 February 2013   #1
Question Vray flickering animation issue..help needed..

Hi
I have made a 3 minutes short animation which most of it looks great..
but I cant get rid of the flickering in a specific area between the Hat and the Head
of my giraffe ..

I'm struggling with this issue for more then a week .. tried many things with no luck..

I really hope someone will have an idea for me to try on.. Here is a picture..and the vray settings Im using..
( I am also using pre-pass and the animation pass with IR maps and light cache)

Thank you,
Elad
----------------------------------------------------
UPDATE : FOUND THE REASON : UN-CHECKING on both places irradiance map and light cache THE "USE CAMERA PATH" SOLVED THE PROBLEM!




Last edited by elado : 03 March 2013 at 10:25 AM. Reason: adding answer
 
Old 02 February 2013   #2
it is most def the irradiance map, here are a few things to try:
  • increase interp. samples - this will use more points to determine what the ir contribution will be on a given point.
  • reduce the surplus scene area - if there is a lot of scene around your character, the samples may be spread out across things you dont need it on.
  • seperate character pass - render character alone, so your ir map is more focused on him. ( tighten up lights as well)
__________________
Debris Maker
Portfolio
Blog
 
Old 02 February 2013   #3
Have you tried following the steps HERE?
 
Old 02 February 2013   #4
Thank you for your comments..
Aaron, I increased interp. samples but even when high-very high its still flickering..
I dont know a way to reduce the surplus scene area without affecting the story..
if there is a way to limit the scene area so that only lights will be affected..
that would be great..
I will try to render as a separate pass..I didnt try cause it made sense to me that the GI cant be calculated right without its closest objects..will try anyway to see what happens
musashidan, thanks for the link.. I actually used this link for this scene..

I passed my 100 render test now.. frustrating as it is, I must solve it somehow
 
Old 02 February 2013   #5
Have you tried rendering with Brute Force in the primary GI slot? I think (don't quote me on this) Irradiance map isn't particularly recommended for this type of animation.

Good luck.
 
Old 02 February 2013   #6
Thanks for the suggestion Zenith.. but Ive tried brute force and it caused grain even on very high settings..and it triples the anyway long render time per frame..
 
Old 02 February 2013   #7
Try this

Sorry I don't have the answer but I stumbled upon this blog post about the very same thing. The example is in Maya but the Vray settings are the same. http://cum-md.blogspot.com/2012/12/...no-flicker.html
 
Old 02 February 2013   #8
thanks fleech I read all of it..
but couldnt find something in it to reduce flickering...
 
Old 03 March 2013   #9
Originally Posted by elado: Thank you for your comments..
Aaron, I increased interp. samples but even when high-very high its still flickering..
I dont know a way to reduce the surplus scene area without affecting the story..
if there is a way to limit the scene area so that only lights will be affected..
that would be great..
I will try to render as a separate pass..I didnt try cause it made sense to me that the GI cant be calculated right without its closest objects..will try anyway to see what happens
musashidan, thanks for the link.. I actually used this link for this scene..

I passed my 100 render test now.. frustrating as it is, I must solve it somehow



Have you actually increased the sample number/subdivs (which is now 50/30) or have you just used another preset? Try something around 80/70 or even up it to 100/90 if you see it improving.

The other thing: in the posted screenshot, you used single frame with camera path. That only works good for static scenes where nothing but the camera is moving. For anything else you need to render the whole sequence in light animation. Also add 2 frames on each end (so from -2 to 102 if you use multiframe incremental - so it has enough frames to interpolate). I'm not entirely sure if you do need to do that with the animation prepass too. But it doesn't do any harm to add those couple of frames so just in case.
 
Old 03 March 2013   #10
Thank you chrisitan, the screenshot of the settings is only one out of so many I did
and in many of them I pushed up the subdivs and almost anything else to a high level..
and most of them with animation prepass method, still this spot between the
head to the hat is flickering..
regarding to 2 frames..thanks I'm using that even with more frames just in case..
 
Old 03 March 2013   #11
found an answer!

so it took about 140 test renders to find out the reason for my flickering animation
and it turned out to be something I didn't suspect at all.

Un-checking the "use camera path" resolved the problem!


I know it doesnt make sense since on the official guide of vray you are asked to check it to reduce flickering...but in fact that was the cause of them.

So ..for any future vray animation flickering..please try that too..
even if it doesn't make sense.

have a great weekend!
and really thanks a lot you for all your posts and help!
Elad (render farm beware here I come! )

Last edited by elado : 03 March 2013 at 10:22 AM. Reason: spelling
 
Old 03 March 2013   #12
Originally Posted by elado: so it took about 140 test renders to find out the reason for my flickering animation
and it turned out to be something I didn't suspect at all.

Un-checking the "use camera path" resolved the problem!


I know it doesnt make sense since on the official guide of vray you are asked to check it to reduce flickering...but in fact that was the cause of them.

So ..for any future vray animation flickering..please try that too..
even if it doesn't make sense.

have a great weekend!
and really thanks a lot you for all your posts and help!
Elad (render farm beware here I come! )



As far as I know, the use camera path option is for walk through animations where only the camera moves. You then only calculate 1 frame for the whole animation.
 
Old 03 March 2013   #13
I guess you are right in terms of what is recommended to do..
but you can see on link I put..that its from their tutrial:
Rendering an animation with moving objects II

Im pasting below from the guide:
The "Use camera path" option
"...However, if we also have moving objects, we cannot use this approach, as we need a new irradiance map for each frame. What we can do, however, is to shoot rays not only for the position of the camera at the current frame, but for the entire camera animation path - similar to what V-Ray does with the Fly-through mode of the light cache, only done for each frame. The Use camera path option, introduced in V-Ray SP3, does exactly that. In this way, the camera rays used for calculating the irradiance map are the same for every single frame of the animation, thus removing flickering caused by camera movement."
 
Old 03 March 2013   #14
Originally Posted by elado: I guess you are right in terms of what is recommended to do..
but you can see on link I put..that its from their tutrial:
Rendering an animation with moving objects II

Im pasting below from the guide:
The "Use camera path" option
"...However, if we also have moving objects, we cannot use this approach, as we need a new irradiance map for each frame. What we can do, however, is to shoot rays not only for the position of the camera at the current frame, but for the entire camera animation path - similar to what V-Ray does with the Fly-through mode of the light cache, only done for each frame. The Use camera path option, introduced in V-Ray SP3, does exactly that. In this way, the camera rays used for calculating the irradiance map are the same for every single frame of the animation, thus removing flickering caused by camera movement."


yeah, I read that after I posted my comment. But I had some settings-tutorial i read once where they said it's not the best idea. Have to see if I can find that again.
But still, if chaos group themselves recomment the setting and its making it worse - thats odd
 
Old 03 March 2013   #15
you are right it is odd..I guessed it suited some scene tests they made
but it not suitable for all cases..so best to try with and without..

by the way its not the first mistake on this tutorial.. an even bigger error on this very same common used tutorial for moving objects animation.. you can see that they wrote on both stages pre pass and anim pass :
that the user should choose "Animation-Rendering" ..
I already emailed them and they will change it..
I guess its not easy to keep all the info right
when you have a lot of it, so I cant blame them..

Last edited by elado : 03 March 2013 at 09:39 AM. Reason: spelling
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 09:11 PM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.