Can't turn off the DOF

Become a member of the CGSociety

Connect, Share, and Learn with our Large Growing CG Art Community. It's Free!

THREAD CLOSED
 
Thread Tools Search this Thread Display Modes
Old 11 November 2012   #1
Can't turn off the DOF

I can't turn off Depth of field for camera from the Multi pass effect section of camera properties. It's not enabled but it renders the scene blurred. For one time rendering I even turned it to perspective but still DOF is on It is not enabled in renderer tab of the render settings either!!

I haven't been using DOF for a long time because of its performance issues. Just returned and I can't control it anymore.

Is there any other setting to turn it off. Actually it seems like a bug but some settings might have changed.
 
Old 11 November 2012   #2
there are also DoF setting sin Mental ray render. Check if that's been left on by accident.

Alternatively test it with a new camera.
__________________
[Invivo Animation Reel]
 
Old 11 November 2012   #3
What is that DOF setting you mantion Dan?

I'm trying to turn in on this time on a new scene.
In the previous scene I mention, it was previewing DOF in the viewport without even pressing a button. This time no previews:
I turn it on from Multipass effect section in Camera settings. I click enable. Select Depth of Field (mental ray) Decrease the f stop. No preview whatsoever. I press Preview. It doesn't work either. I switched viewing types shaded, realistic, illuminate with scene lights, default lights...

??? Am I missing some point or is it again one of the very usual problems of 3DS Max?
 
Old 11 November 2012   #4
It should work fine. Just use a normal Max Camera, tick 'enable' for multipass effect and select 'Depth of field (mental Ray)' from the dropdown list. Make sure you have the Nitrous driver enabled, not Direct 3D. It only shows in the viewport in Max 2013.

If it's still not working, try switching viewport to a perspective view, press 'H', select the camera, then press 'C', to switch view to active camera. It should then display fine.

Viewport DOF preview is pretty cool. It should display in the viewport with any production renderer selected (mental ray, Vray, etc). The actual rendered view might not match exactly, unless your production renderer is Quicksilver Hardware.

Check out Spacefrog's 'powerpreview' free 3Ds max plugin if you want to take the viewport quality further (better shadows, AO, dynamic reflections, 4k sized batch renders, etc. Very useful!
__________________
Michael Wentworth-Bell | 3D Artist & VR Designer | Melbourne, Australia

Espire 1: My VR Stealth game - CGTalk thread
 
Old 11 November 2012   #5
Just want to add a couple more suggestions:

Under 'Viewport Configuration' -> 'Display Performance' make sure 'improve quality progressively' checkbox is ticked.

Still not working, close down max and try in completely empty scene.

Make sure you have the latest driver updates for the Card and latest product update for Max 2013.

I use this feature often, Max 2013 Product update #5, Nvidia GTX 680 with latest driver, never had issues. I've seen a similar thread on the chaosgroup forum, so it sounds like a common problem! Would be good to try and narrow it down to a common hardware/software combo so maybe ADSK can fix it!
__________________
Michael Wentworth-Bell | 3D Artist & VR Designer | Melbourne, Australia

Espire 1: My VR Stealth game - CGTalk thread
 
Old 11 November 2012   #6
Thank you for the very useful, step by step information.

It really changes from one day to the other. It just worked seamlessly on a fresh scene -but you can't guess how much I have been surprised. Turn on or off, works perfect, then the mentioned scene: it also works this time.

I wonder what all these type of issues all about.
I mean things that stop working properly. Machine is fast enough, latest graphics card, latest drivers, high amount of ram.

It occurs so often with the viewport elements. Surfaces flip, objects dissappear, this is one thing that happens quite often. As I work enough with one scene, delete a modifier in the stack and undo for example. It comes back, but no longer the model's visual integrity. It renders fine but never displays correctly anymore. I create a box align it to that object then attach the object to the box to make the object come to itself. Faces' normal info is lost.

This blur thing was somewhat similar, I really gained familiarity that it won't work so I'm really surprised to see it turned off and back on.

I started to feel either I'm missing something, or just getting old...
 
Old 11 November 2012   #7
Thread automatically closed

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.
__________________
CGTalk Policy/Legalities
Note that as CGTalk Members, you agree to the terms and conditions of using this website.
 
Thread Closed share thread



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
CGSociety
Society of Digital Artists
www.cgsociety.org

Powered by vBulletin
Copyright 2000 - 2006,
Jelsoft Enterprises Ltd.
Minimize Ads
Forum Jump
Miscellaneous

All times are GMT. The time now is 04:26 AM.


Powered by vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.